aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby-programmingruby/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-24 13:24:08 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-24 13:24:08 +0000
commitef909891685099a5b82ffcf4c0e74daf6dc7d08b (patch)
treef4635c492b7855cfcb4162f9fd0d832e1d076e71 /lang/ruby-programmingruby/Makefile
parenta343c046e784dfc0a90e771ede7c8c60c8febd0e (diff)
downloadports-ef909891685099a5b82ffcf4c0e74daf6dc7d08b.tar.gz
ports-ef909891685099a5b82ffcf4c0e74daf6dc7d08b.zip
- Use PORTDOCS feature
- Speedup install (no need to double-copy) - Set correct permissions on installed files - Fix install without ruby - Take maintainership PR: ports/100626 Submitted by: Stanislav Sedov <ssedov_AT_mbsd dot msk dot ru>
Notes
Notes: svn path=/head/; revision=168626
Diffstat (limited to 'lang/ruby-programmingruby/Makefile')
-rw-r--r--lang/ruby-programmingruby/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/ruby-programmingruby/Makefile b/lang/ruby-programmingruby/Makefile
index 284f9c94fde1..98da00129a89 100644
--- a/lang/ruby-programmingruby/Makefile
+++ b/lang/ruby-programmingruby/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ProgrammingRuby-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= The source of the Programming Ruby ("pick-axe") book in XML and HTML
USE_RUBY= yes
@@ -22,9 +22,14 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
NO_BUILD= yes
+NO_WRKSUBDIR= yes
+DOCSDIR= ${RUBY_MODDOCDIR}
+PORTDOCS= *
do-install:
${MKDIR} ${RUBY_MODDOCDIR}
- ${CP} -R ${WRKSRC}/* ${RUBY_MODDOCDIR}/
+ @${TAR} -xf ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} -C ${RUBY_MODDOCDIR}
+ @${FIND} ${RUBY_MODDOCDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${FIND} ${RUBY_MODDOCDIR}/ -type f -exec ${CHOWN} ${SHAREOWN} {} \;
.include <bsd.port.mk>