aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby14-irb
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-12 20:09:41 +0000
commit596ebf8a494ccec324a561d381d1c60d5f35cf02 (patch)
tree740528554f6f5efe5651a2e1c0f603dcf8fb5474 /lang/ruby14-irb
parentfa205cf0127276fbc75367f39be16135d70b5d9e (diff)
downloadports-596ebf8a494ccec324a561d381d1c60d5f35cf02.tar.gz
ports-596ebf8a494ccec324a561d381d1c60d5f35cf02.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Notes
Notes: svn path=/head/; revision=31584
Diffstat (limited to 'lang/ruby14-irb')
-rw-r--r--lang/ruby14-irb/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/lang/ruby14-irb/Makefile b/lang/ruby14-irb/Makefile
index 8f2a350e8bd3..13514100a607 100644
--- a/lang/ruby14-irb/Makefile
+++ b/lang/ruby14-irb/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: irb
-# Date created: 19 April 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+# New ports collection makefile for: irb
+# Date created: 19 April 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
#
# $FreeBSD$
#
@@ -20,22 +20,20 @@ MAINTAINER= yasuf@big.or.jp
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+NO_BUILD= yes
+
WRKSRC= ${WRKDIR}/irb
PLIST_SUB+= RUBY_VER="${RUBY_VER}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
post-patch:
+ ${PERL} -i -pe '$$. == 1 && s,^#!\s*\S+,#!${RUBY},' ${WRKSRC}/irb.rb
${RM} -f ${WRKSRC}/instirb.rb
-do-build:
- ( cd ${WRKSRC}; \
- ${MV} irb.rb irb.tmpl; \
- ${SED} -e '1s,^#!.*$$,#!${RUBY},' irb.tmpl > irb )
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/irb ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/irb.rb ${PREFIX}/bin/irb
${MKDIR} ${PREFIX}/lib/ruby/${RUBY_VER}/irb
${INSTALL_DATA} ${WRKSRC}/*.rb ${PREFIX}/lib/ruby/${RUBY_VER}/irb
.if !defined(NOPORTDOCS)