aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-01-27 06:21:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-01-27 06:21:25 +0000
commit0ff0daf382568a2fb5548c0cb09290f6eea0c2cf (patch)
tree140a3a0f64a9bab43fdcc8c660e6006cbccbc211 /lang/rust
parent6aa591c4f321dd12596faa51c42b7cffa2374a6f (diff)
downloadports-0ff0daf382568a2fb5548c0cb09290f6eea0c2cf.tar.gz
ports-0ff0daf382568a2fb5548c0cb09290f6eea0c2cf.zip
Unbreak lang/rust-nightly after r524013
Notes
Notes: svn path=/head/; revision=524242
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index fd9e5dcbab09..223489ec54d7 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -42,11 +42,6 @@ USES= pkgconfig python:3.3+,build ssl tar:xz
CONFLICTS_INSTALL?= rust-nightly
-# lang/rust-bootstrap builds the bundled libgit2 and using the patch
-# to fix runtime with system libgit2 is incompatible with it. Keep
-# it separate.
-EXTRA_PATCHES= ${PATCHDIR}/libgit2
-
PLIST_FILES= lib/rustlib/components \
lib/rustlib/rust-installer-version
@@ -81,6 +76,12 @@ _CARGO_BOOTSTRAP= ${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}/cargo-${CARGO_B
.include <bsd.port.pre.mk>
+.if exists(${PATCHDIR}/libgit2)
+# lang/rust-bootstrap builds the bundled libgit2 and using the patch
+# to fix runtime with system libgit2 is incompatible with it. Keep
+# it separate.
+EXTRA_PATCHES+= ${PATCHDIR}/libgit2
+.endif
.if exists(${PATCHDIR}/${ARCH}${BOOTSTRAPS_SUFFIX})
EXTRA_PATCHES+= ${PATCHDIR}/${ARCH}${BOOTSTRAPS_SUFFIX}
.endif