aboutsummaryrefslogtreecommitdiff
path: root/lang/slib-guile2/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-10-05 13:29:40 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-10-05 13:29:40 +0000
commitcc5c75bd956c3dbffb0fd3aaba4a353bfd58c9bb (patch)
treee5003b68c00abf0ccce29ce606baaa1f1d8eeecc /lang/slib-guile2/Makefile
parent42bfb6237efb034c0855bb713cf11b81d1a7db08 (diff)
downloadports-cc5c75bd956c3dbffb0fd3aaba4a353bfd58c9bb.tar.gz
ports-cc5c75bd956c3dbffb0fd3aaba4a353bfd58c9bb.zip
- Update slib and slib-guile to 3b4
- Fix build for lang/slib with new texinfo [1] - Convert slib-guile @exec/@unexec directives to post install/deinstall scripts - Add new port slib-guile2 based on slib-guile - Remove dirrms MFH: 2014Q4
Notes
Notes: svn path=/head/; revision=370066
Diffstat (limited to 'lang/slib-guile2/Makefile')
-rw-r--r--lang/slib-guile2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/lang/slib-guile2/Makefile b/lang/slib-guile2/Makefile
new file mode 100644
index 000000000000..6ff66ace19ff
--- /dev/null
+++ b/lang/slib-guile2/Makefile
@@ -0,0 +1,23 @@
+# Created by: Kimura Fuyuki <fuyuki@nigredo.org>
+# $FreeBSD$
+# $MCom: ports/lang/slib-guile/Makefile,v 1.3 2006/10/13 02:32:48 marcus Exp $
+
+PORTNAME= slib
+PORTVERSION= 3b4 # Keep this in sync with lang/slib
+CATEGORIES= lang scheme
+MASTER_SITES= # empty
+PKGNAMESUFFIX= -guile2
+DISTFILES= # empty
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SLIB installation for Guile
+
+BUILD_DEPENDS= ${LOCALBASE}/share/slib/require.scm:${PORTSDIR}/lang/slib \
+ guile:${PORTSDIR}/lang/guile2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+SUB_FILES+= pkg-install pkg-deinstall
+NO_BUILD= yes
+NO_INSTALL= yes
+
+.include <bsd.port.mk>