aboutsummaryrefslogtreecommitdiff
path: root/lang/snobol4/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-01-24 16:43:54 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-01-24 16:43:54 +0000
commitf40b99ab62ff4e0d0b6614604685cbb2d8f52054 (patch)
tree1f23d567d834f29255b3c8393210ea90be91dcb6 /lang/snobol4/Makefile
parent6ae684bbdeb6f1c79d2fa3496146995d3d24b5ca (diff)
downloadports-f40b99ab62ff4e0d0b6614604685cbb2d8f52054.tar.gz
ports-f40b99ab62ff4e0d0b6614604685cbb2d8f52054.zip
- Update to csnobol4 version 2.0; this is a major upgrade
http://www.snobol4.org/csnobol4/curr/CHANGES - Added some patches to work around broken build dependencies
Notes
Notes: svn path=/head/; revision=377801
Diffstat (limited to 'lang/snobol4/Makefile')
-rw-r--r--lang/snobol4/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/lang/snobol4/Makefile b/lang/snobol4/Makefile
index 1f7faa8b6215..f67df6c4e1b2 100644
--- a/lang/snobol4/Makefile
+++ b/lang/snobol4/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= snobol4
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= lang
MASTER_SITES= ftp://ftp.ultimate.com/snobol/
@@ -13,14 +12,22 @@ COMMENT= Port of Macro SNOBOL4, supports full SNOBOL4 plus SPITBOL
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--snolibdir=${PREFIX}/lib/${PORTNAME}
+CONFIGURE_ENV+= DL_EXT=".so"
USES= gmake
PLIST_SUB+= VERSION=${PORTVERSION}
+ALL_TARGET= xsnobol4
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
post-patch:
@${REINPLACE_CMD} 's:[^=]*\.tmp$$:${WRKSRC}/&:' ${WRKSRC}/configure
-
-post-install:
- ${LN} -sf sdb-${PORTVERSION} ${STAGEDIR}${PREFIX}/bin/sdb
- ${LN} -sf snobol4-${PORTVERSION} ${STAGEDIR}${PREFIX}/bin/snobol4
+ @${REINPLACE_CMD} '/grep/s/$$/| egrep -v "built-in|command line"/' \
+ ${WRKSRC}/cc-M
+ @${REINPLACE_CMD} 's:../snobol4:../xsnobol4:' \
+ ${WRKSRC}/doc/Makefile ${WRKSRC}/modules/*/Makefile
+ @${REINPLACE_CMD} -e 's:<BINDIR>:${PREFIX}/bin:' \
+ -e 's:<SNOLIB_LIB>:${PREFIX}/lib/${PORTNAME}:' \
+ ${WRKSRC}/snopea.in ${WRKSRC}/sdb.sh
.include <bsd.port.mk>