aboutsummaryrefslogtreecommitdiff
path: root/lang/snobol4
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-23 09:23:44 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-23 09:23:44 +0000
commit321b3c69803e907d5cf9d9f1a92a3fa535faf4e8 (patch)
tree5887ec3f3db6201e42edc40cdc0bc1209da6e1ca /lang/snobol4
parent85831c769f739f549a8253bcb12529e80dccbee0 (diff)
downloadports-321b3c69803e907d5cf9d9f1a92a3fa535faf4e8.tar.gz
ports-321b3c69803e907d5cf9d9f1a92a3fa535faf4e8.zip
Upgrade to version 2.1.6
Notes
Notes: svn path=/head/; revision=549673
Diffstat (limited to 'lang/snobol4')
-rw-r--r--lang/snobol4/Makefile14
-rw-r--r--lang/snobol4/distinfo5
-rw-r--r--lang/snobol4/files/LICENSE25
-rw-r--r--lang/snobol4/files/patch-Makefile2.m422
-rw-r--r--lang/snobol4/files/patch-include_macros.h11
5 files changed, 47 insertions, 30 deletions
diff --git a/lang/snobol4/Makefile b/lang/snobol4/Makefile
index 9621d6ef5357..d6c8a2ca79d7 100644
--- a/lang/snobol4/Makefile
+++ b/lang/snobol4/Makefile
@@ -2,31 +2,33 @@
# $FreeBSD$
PORTNAME= snobol4
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.1.6
CATEGORIES= lang
MASTER_SITES= ftp://ftp.ultimate.com/snobol/
MAINTAINER= ports@FreeBSD.org
COMMENT= Port of Macro SNOBOL4, supports full SNOBOL4 plus SPITBOL
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${PATCHDIR}/LICENSE
+
+USES= gmake libedit
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--snolibdir=${PREFIX}/lib/${PORTNAME}
CONFIGURE_ENV+= DL_EXT=".so"
-USES= gmake
-PLIST_SUB+= VERSION=${PORTVERSION}
ALL_TARGET= xsnobol4
+LDFLAGS+= -L${PREFIX}/lib
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PLIST_SUB+= VERSION=${PORTVERSION}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's:[^=]*\.tmp$$:${WRKSRC}/&:' ${WRKSRC}/configure
- @${REINPLACE_CMD} '/grep/s/$$/| egrep -v "built-in|command line"/' \
- ${WRKSRC}/cc-M
@${REINPLACE_CMD} 's:../snobol4:../xsnobol4:' \
${WRKSRC}/doc/Makefile ${WRKSRC}/modules/*/Makefile
@${REINPLACE_CMD} -e 's:<BINDIR>:${PREFIX}/bin:' \
diff --git a/lang/snobol4/distinfo b/lang/snobol4/distinfo
index eb4866792e89..8fa2ce0b7259 100644
--- a/lang/snobol4/distinfo
+++ b/lang/snobol4/distinfo
@@ -1,2 +1,3 @@
-SHA256 (snobol4-2.0.tar.gz) = 94ae7af4fcaa9139954c6d530ca91f25ffd7a69ff45f1ba52b52095bbdf6631f
-SIZE (snobol4-2.0.tar.gz) = 903436
+TIMESTAMP = 1600849218
+SHA256 (snobol4-2.1.6.tar.gz) = ae9306ac523bd99b8881860e31b5b779e87652d4a416fff50277b11dfbc8001e
+SIZE (snobol4-2.1.6.tar.gz) = 907278
diff --git a/lang/snobol4/files/LICENSE b/lang/snobol4/files/LICENSE
new file mode 100644
index 000000000000..9d44bf1b12d3
--- /dev/null
+++ b/lang/snobol4/files/LICENSE
@@ -0,0 +1,25 @@
+Copyright © 1993-2020, Philip L. Budne
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+Redistributions of source code must retain the above copyright notice,
+this list of conditions and the following disclaimer.
+
+Redistributions in binary form must reproduce the above copyright
+notice, this list of conditions and the following disclaimer in the
+documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/lang/snobol4/files/patch-Makefile2.m4 b/lang/snobol4/files/patch-Makefile2.m4
index c13c66e02c8f..d80450b0e048 100644
--- a/lang/snobol4/files/patch-Makefile2.m4
+++ b/lang/snobol4/files/patch-Makefile2.m4
@@ -1,17 +1,17 @@
---- Makefile2.m4.orig 2014-12-31 08:04:21.000000000 +0100
-+++ Makefile2.m4 2015-01-24 16:39:40.000000000 +0100
-@@ -614,8 +614,8 @@ snopea.1: snopea snolib/snopea.sno snobo
+--- Makefile2.m4.orig 2020-06-22 02:02:06 UTC
++++ Makefile2.m4
+@@ -615,8 +615,8 @@ snopea.1: snopea snolib/snopea.sno snobol4
snopea.1.html: snopea snolib/snopea.sno snobol4
$(SNOPEA) snopea snopea.1.html
--$(GENERATED_DOCS_DOCDIR): snopea snolib/snopea.sno snobol4
+-docs $(GENERATED_DOCS_DOCDIR): snopea snolib/snopea.sno snobol4 always
- cd doc; make
-+$(GENERATED_DOCS_DOCDIR): snopea snolib/snopea.sno xsnobol4
-+ cd doc; $(MAKE)
++docs $(GENERATED_DOCS_DOCDIR): snopea snolib/snopea.sno xsnobol4 always
++ cd doc; ${MAKE}
- #################
- # installation
-@@ -628,17 +628,18 @@ INSTALL_H=[include]/h.h [include]/snotyp
+ always:
+
+@@ -631,17 +631,18 @@ INSTALL_H=[include]/h.h [include]/snotypes.h [include]
# generated SNOLIB files (host.sno generated at top level)
GENSNOLIB=host.sno config.sno
@@ -35,7 +35,7 @@
$(INSTALL) -d $(MAN1DIR)
for F in $(GENERATED_DOCS_DOCDIR1); do \
$(INSTALL) -m 644 $$F $(MAN1DIR); \
-@@ -664,15 +665,12 @@ install: snobol4 sdb timing.out $(GENERA
+@@ -668,15 +669,12 @@ install: snobol4 sdb timing.out $(GENERATED_DOCS)
for F in $(SNOLIB_FILES); do \
$(INSTALL) -m 644 $$F $(SNOLIB_LIB); \
done
@@ -51,4 +51,4 @@
+ for F in doc/load.txt doc/*.html; do \
$(INSTALL) -m 644 $$F $(DOC_DIR); \
done
- ifdef([INSTALL_SYSDEP], INSTALL_SYSDEP
+ ifdef([INSTALL_SYSDEP],[ ]INSTALL_SYSDEP
diff --git a/lang/snobol4/files/patch-include_macros.h b/lang/snobol4/files/patch-include_macros.h
deleted file mode 100644
index a64f0f32039b..000000000000
--- a/lang/snobol4/files/patch-include_macros.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/macros.h.orig 2014-02-22 22:43:58 UTC
-+++ include/macros.h
-@@ -204,7 +204,7 @@ extern volatile int math_error;
- #define RETURN(VALUE) {RSTSTK(); return (VALUE);}
- #endif /* TRACE_DEPTH not defined */
-
--struct descr _NORET[1];
-+extern struct descr _NORET[1];
- #define NORET ((ptr_t)_NORET)
-
- /****************/