aboutsummaryrefslogtreecommitdiff
path: root/lang/solidity
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2018-08-09 08:01:28 +0000
committerAlex Dupre <ale@FreeBSD.org>2018-08-09 08:01:28 +0000
commitb0b72ea45e2e04f4fb21be0da6cc9c92563bd957 (patch)
tree478549d978be96d8f185d613bf054107dfa8281f /lang/solidity
parentcf0b3f197388f30a8e17225506c52876f69b4db4 (diff)
downloadports-b0b72ea45e2e04f4fb21be0da6cc9c92563bd957.tar.gz
ports-b0b72ea45e2e04f4fb21be0da6cc9c92563bd957.zip
Update to 0.4.24 release and fix build with newer boost lib.
Notes
Notes: svn path=/head/; revision=476725
Diffstat (limited to 'lang/solidity')
-rw-r--r--lang/solidity/Makefile5
-rw-r--r--lang/solidity/distinfo6
-rw-r--r--lang/solidity/files/patch-libdevcore_JSON.cpp6
-rw-r--r--lang/solidity/files/patch-libevmasm_Assembly.cpp20
4 files changed, 27 insertions, 10 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index cfbfd8962117..770d47f26bf0 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= solidity
-PORTVERSION= 0.4.23
-PORTREVISION= 1
+PORTVERSION= 0.4.24
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -13,8 +12,6 @@ COMMENT= Solidity Contract-Oriented Programming Language
LICENSE= GPLv3
-BROKEN= fails to build with boost 1.68, see bug 230392
-
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
diff --git a/lang/solidity/distinfo b/lang/solidity/distinfo
index c9c2e750be7d..a0ebca464915 100644
--- a/lang/solidity/distinfo
+++ b/lang/solidity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524729659
-SHA256 (solidity_0.4.23.tar.gz) = 1a01dfd0f19617c543a9dc012d4ae99aecc38bb3931e0c7af88007005e60413f
-SIZE (solidity_0.4.23.tar.gz) = 1136930
+TIMESTAMP = 1533799823
+SHA256 (solidity_0.4.24.tar.gz) = b6828266d9b108a035f44127a6107c9fbc516018b0fcf5de370196306cddb2a8
+SIZE (solidity_0.4.24.tar.gz) = 1154386
diff --git a/lang/solidity/files/patch-libdevcore_JSON.cpp b/lang/solidity/files/patch-libdevcore_JSON.cpp
index d13d32977f07..e7ab35a5c2d1 100644
--- a/lang/solidity/files/patch-libdevcore_JSON.cpp
+++ b/lang/solidity/files/patch-libdevcore_JSON.cpp
@@ -1,4 +1,4 @@
---- libdevcore/JSON.cpp.orig 2018-04-19 21:36:04 UTC
+--- libdevcore/JSON.cpp.orig 2018-05-16 14:30:44 UTC
+++ libdevcore/JSON.cpp
@@ -27,10 +27,12 @@
@@ -6,8 +6,8 @@
+/*
static_assert(
- (JSONCPP_VERSION_MAJOR == 1) && (JSONCPP_VERSION_MINOR == 7) && (JSONCPP_VERSION_PATCH == 7),
- "Unexpected jsoncpp version: " JSONCPP_VERSION_STRING ". Expecting 1.7.7."
+ (JSONCPP_VERSION_MAJOR == 1) && (JSONCPP_VERSION_MINOR == 8) && (JSONCPP_VERSION_PATCH == 4),
+ "Unexpected jsoncpp version: " JSONCPP_VERSION_STRING ". Expecting 1.8.4."
);
+*/
diff --git a/lang/solidity/files/patch-libevmasm_Assembly.cpp b/lang/solidity/files/patch-libevmasm_Assembly.cpp
new file mode 100644
index 000000000000..74b1e40133a1
--- /dev/null
+++ b/lang/solidity/files/patch-libevmasm_Assembly.cpp
@@ -0,0 +1,20 @@
+--- libevmasm/Assembly.cpp.orig 2018-05-16 14:30:44 UTC
++++ libevmasm/Assembly.cpp
+@@ -264,7 +264,7 @@ Json::Value Assembly::assemblyJSON(Strin
+ createJsonValue("PUSH [ErrorTag]", i.location().start, i.location().end, ""));
+ else
+ collection.append(
+- createJsonValue("PUSH [tag]", i.location().start, i.location().end, string(i.data())));
++ createJsonValue("PUSH [tag]", i.location().start, i.location().end, dev::toString(i.data())));
+ break;
+ case PushSub:
+ collection.append(
+@@ -290,7 +290,7 @@ Json::Value Assembly::assemblyJSON(Strin
+ break;
+ case Tag:
+ collection.append(
+- createJsonValue("tag", i.location().start, i.location().end, string(i.data())));
++ createJsonValue("tag", i.location().start, i.location().end, dev::toString(i.data())));
+ collection.append(
+ createJsonValue("JUMPDEST", i.location().start, i.location().end));
+ break;