aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey170
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-13 01:42:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-13 01:42:45 +0000
commita1d0f2efdef77cd73040ff40fa4b206d2d902a54 (patch)
tree0465df4db50585728474c555726391c6a3c74f04 /lang/spidermonkey170
parentf56d387f2c7201d6e3faeef64a4dd255a9d21352 (diff)
downloadports-a1d0f2efdef77cd73040ff40fa4b206d2d902a54.tar.gz
ports-a1d0f2efdef77cd73040ff40fa4b206d2d902a54.zip
lang/spidermonkey170: unbreak with clang 4.0
Fix quoting failure handling in JSOP_CALLPROP and JSOP_STRING. jsopcode.cpp:6070:45: error: ordered comparison between pointer and zero ('char *' and 'int') return QuoteString(&sprinter, s, quote) >= 0; ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~ PR: 215861 Regressed by: https://github.com/llvm-mirror/clang/commit/4b6ad14285f3 Obtained from: upstream (only the specific fix) Approved by: portmgr blanket MFH: 2017Q1 (changes existing behavior)
Notes
Notes: svn path=/head/; revision=431335
Diffstat (limited to 'lang/spidermonkey170')
-rw-r--r--lang/spidermonkey170/Makefile2
-rw-r--r--lang/spidermonkey170/files/patch-bug101297132
2 files changed, 33 insertions, 1 deletions
diff --git a/lang/spidermonkey170/Makefile b/lang/spidermonkey170/Makefile
index 904e35e3aca0..aad5bf4630d9 100644
--- a/lang/spidermonkey170/Makefile
+++ b/lang/spidermonkey170/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spidermonkey170
PORTVERSION= 17.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= MOZILLA/js
DISTNAME= mozjs${PORTVERSION}
diff --git a/lang/spidermonkey170/files/patch-bug1012971 b/lang/spidermonkey170/files/patch-bug1012971
new file mode 100644
index 000000000000..10dae0ec9b0f
--- /dev/null
+++ b/lang/spidermonkey170/files/patch-bug1012971
@@ -0,0 +1,32 @@
+commit ad6d8397a05a
+Author: Dan Gohman <sunfish@mozilla.com>
+Date: Thu May 22 11:15:06 2014 -0700
+
+ Bug 1012971 - SpiderMonkey: Fix various warnings. r=nbp
+---
+ js/public/RootingAPI.h | 4 +++-
+ js/src/configure.in | 1 +
+ js/src/jit/IonFrames.h | 17 ++++++++---------
+ js/src/jit/MIR.h | 12 +++++-------
+ js/src/jit/PerfSpewer.cpp | 12 ++++++------
+ js/src/jit/RegisterSets.h | 2 +-
+ js/src/jscntxt.h | 2 +-
+ js/src/jsgcinlines.h | 4 ++--
+ js/src/jsopcode.cpp | 2 +-
+ js/src/jsscript.cpp | 6 +++---
+ js/src/shell/js.cpp | 2 +-
+ js/src/vm/ArrayBufferObject.h | 16 ++++++++--------
+ js/src/vm/TypedArrayObject.cpp | 26 +++++++++++++-------------
+ 13 files changed, 53 insertions(+), 53 deletions(-)
+
+--- jsopcode.cpp.orig 2013-02-11 22:33:23 UTC
++++ jsopcode.cpp
+@@ -6067,7 +6067,7 @@ ExpressionDecompiler::write(JSString *s)
+ bool
+ ExpressionDecompiler::quote(JSString *s, uint32_t quote)
+ {
+- return QuoteString(&sprinter, s, quote) >= 0;
++ return QuoteString(&sprinter, s, quote) != NULL;
+ }
+
+ JSAtom *