aboutsummaryrefslogtreecommitdiff
path: root/lang/squeak
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-30 11:25:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-30 11:25:30 +0000
commitafbeb7332b652a8e9fcf59c1328a1879b64eb521 (patch)
treed61d593e1472407cc63ddd51434b82c01057ae1a /lang/squeak
parent9a4d72307573b3d569d67e507a5796536aa30dd2 (diff)
downloadports-afbeb7332b652a8e9fcf59c1328a1879b64eb521.tar.gz
ports-afbeb7332b652a8e9fcf59c1328a1879b64eb521.zip
- Drop `archivers/unzip' bdep; base system unzip(1) is sufficient
- Fix some sloppy code to make Clang happy and remove USE_GCC knob - Simplify post-install target recipe; remove one trivial comment
Notes
Notes: svn path=/head/; revision=363463
Diffstat (limited to 'lang/squeak')
-rw-r--r--lang/squeak/Makefile26
-rw-r--r--lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c15
2 files changed, 28 insertions, 13 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 6e2fa0a15640..b2155008058b 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -12,7 +12,7 @@ DISTFILES= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}:vmsrc \
Squeak${IMAGE_VERSION}.zip:src \
${SQUEAK_SRC}.gz:sqsrc
EXTRACT_ONLY= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}
-DIST_SUBDIR= squeak
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Full Smalltalk 80 with portability to Unix, Mac, and Windows
@@ -20,9 +20,7 @@ COMMENT= Full Smalltalk 80 with portability to Unix, Mac, and Windows
LICENSE= APACHE20 MIT
LICENSE_COMB= multi
-# Don't set USE_ZIP as this breaks EXTRACT_CMD.
-BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
- cmake:${PORTSDIR}/devel/cmake \
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake \
v4l_compat>=1.0.20120501:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas \
libffi.so:${PORTSDIR}/devel/libffi \
@@ -33,10 +31,10 @@ LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas \
ONLY_FOR_ARCHS= i386 amd64 powerpc
USES= pkgconfig
-USE_GCC= any
USE_GL= gl
HAS_CONFIGURE= yes
USE_GSTREAMER= yes
+
VM_VERSION= ${PORTVERSION}.${SVN_VERSION}
SVN_VERSION= 2614
IMAGE_VERSION= 4.3
@@ -65,22 +63,24 @@ IMAGES= Squeak${IMAGE_VERSION}/Squeak${IMAGE_VERSION}.image \
.include <bsd.port.pre.mk>
post-patch:
-# Fix utmp.h
.if ${OSVERSION} > 900007
- @${REINPLACE_CMD} -e 's,<utmp.h>,<utmpx.h>,' \
+ @${REINPLACE_CMD} -e 's,<utmp\.h>,<utmpx.h>,' \
${WRKSRC}/unix/plugins/PseudoTTYPlugin/openpty.h
.endif
+ @${REINPLACE_CMD} -e 's,return;,return 0;,' \
+ ${WRKSRC}/Cross/plugins/Mpeg3Plugin/libmpeg/video/idct.c \
+ ${WRKSRC}/Cross/plugins/Mpeg3Plugin/libmpeg/audio/layer3.c
+ @${REINPLACE_CMD} -e 's,return;,return 1;,' \
+ ${WRKSRC}/Cross/plugins/Mpeg3Plugin/libmpeg/video/getpicture.c
pre-configure:
@${MKDIR} ${CONFIGURE_WRKSRC}
post-install:
- ${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/${SQUEAK_SRC}.gz > \
- ${WRKDIR}/${SQUEAK_SRC} && ${INSTALL_DATA} \
- ${WRKDIR}/${SQUEAK_SRC} \
- ${STAGEDIR}${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}
- (cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -u \
- Squeak${IMAGE_VERSION}.zip -d ${WRKDIR})
+ ${GUNZIP_CMD} -c ${_DISTDIR}/${SQUEAK_SRC}.gz > \
+ ${STAGEDIR}${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}/${SQUEAK_SRC}
+ ${UNZIP_NATIVE_CMD} -u ${_DISTDIR}/Squeak${IMAGE_VERSION}.zip \
+ -d ${WRKDIR}
${INSTALL_DATA} ${IMAGES:S,^,${WRKDIR}/,} \
${STAGEDIR}${PREFIX}/lib/squeak
diff --git a/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c b/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c
new file mode 100644
index 000000000000..8eaf251b3059
--- /dev/null
+++ b/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c
@@ -0,0 +1,15 @@
+--- unix/vm-sound-pulse/sqUnixSoundPulseAudio.c.orig 2012-08-08 10:34:42 +0800
++++ unix/vm-sound-pulse/sqUnixSoundPulseAudio.c
+@@ -995,10 +995,10 @@ DBGMSG("<sound_StartRecording()");
+ static sqInt sound_StopRecording(void) {
+ DBGMSG(">sound_StopRecording()");
+
+- if (!audioIn.open) return;
++ if (!audioIn.open) return false;
+ audioIn.open = false;
+
+- if (NULL == audioIn.pa_conn) return;
++ if (NULL == audioIn.pa_conn) return false;
+
+ ioThreadStall(&audioIn);
+