aboutsummaryrefslogtreecommitdiff
path: root/lang/tcc/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2006-05-16 01:42:47 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2006-05-16 01:42:47 +0000
commit2dae626b2edb5d9f3cbc8a533c7f433643fec36e (patch)
tree0f472517d7b1d1905cb84708e4aff3d7e563dd31 /lang/tcc/Makefile
parent3cc6b36726ff435c89d8dae9551ab70834ba5b55 (diff)
downloadports-2dae626b2edb5d9f3cbc8a533c7f433643fec36e.tar.gz
ports-2dae626b2edb5d9f3cbc8a533c7f433643fec36e.zip
A new port for TinyCC, a small and fast C compiler.
Tcc's features include: * Small: You can compile and execute C code everywhere, for example on rescue disks (about 100KB for x86 TCC executable, including C preprocessor, C compiler, assembler and linker). * Fast: tcc generates optimized x86 code. No byte code overhead. Compile, assemble and link several times faster than GCC. * Unlimited: Any C dynamic library can be used directly. TCC is heading torward full ISOC99 compliance. TCC can of course compile itself. * Safe: tcc includes an optional memory and bound checker. Bound checked code can be mixed freely with standard code. * Compile and execute C source directly. No linking or assembly necessary. Full C preprocessor and GNU-like assembler included. * C script supported : just add '#!/usr/local/bin/tcc -run' at the first line of your C source, and execute it directly from the command line. * With libtcc, you can use TCC as a backend for dynamic code generation.
Notes
Notes: svn path=/head/; revision=162507
Diffstat (limited to 'lang/tcc/Makefile')
-rw-r--r--lang/tcc/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/lang/tcc/Makefile b/lang/tcc/Makefile
new file mode 100644
index 000000000000..d1e2e957df86
--- /dev/null
+++ b/lang/tcc/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: tcc
+# Date created: 16 May 2006
+# Whom: Joseph Koshy <jkoshy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcc
+PORTVERSION= 0.9.23
+CATEGORIES= lang
+MASTER_SITES= http://fabrice.bellard.free.fr/tcc/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= jkoshy
+
+MAINTAINER= jkoshy@FreeBSD.org
+COMMENT= A small and fast C compiler
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+MAN1= tcc.1
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>