aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl86/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-03-02 23:53:17 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-03-02 23:53:17 +0000
commit2c47fce0e6f526d1935c4dcfe0005290c14f78b7 (patch)
treed102c437fdbedabc1e6dc1c5881ec927f9bb18c4 /lang/tcl86/Makefile
parent50d7a2cb56b674e0afa48ea19b312f94dc9f350a (diff)
downloadports-2c47fce0e6f526d1935c4dcfe0005290c14f78b7.tar.gz
ports-2c47fce0e6f526d1935c4dcfe0005290c14f78b7.zip
- Separate common tcl85 and tcl86 modules to a new port lang/tcl-modules
- Make tcl-modules a slave port of tcl85 - Fix incompatible pkg-lists of tcl85 and tcl86 - Add modules to OPTIONS - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=229389
Diffstat (limited to 'lang/tcl86/Makefile')
-rw-r--r--lang/tcl86/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index cbcfb319db48..783d062fa60d 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.6.b.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -34,7 +34,8 @@ EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude compat/
.if !defined(BUILDING_TCL_THREADS)
OPTIONS= TCL86_MAN "Install tcl 8.6 function manpages" off \
- TZDATA "Install tcl timezone data" off
+ TZDATA "Install tcl timezone data" off \
+ TCL_MODULES "Install tcl common modules" on
.else
USE_TCL= ${SHORT_TCL_VER}
PLIST= ${PKGDIR}/pkg-plist.threads
@@ -44,6 +45,10 @@ LATEST_LINK= tcl86${THREADS_SUFFIX}
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_TCL_MODULES)
+RUN_DEPENDS+= ${LOCALBASE}/lib/tcl8/8.5/tcltest-2.3.0.tm:${PORTSDIR}/lang/tcl-modules
+.endif
+
DATADIR= ${PREFIX}/share/${PORTNAME}${TCL_VER}
.if defined(WITH_TZDATA)