aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl86/Makefile
diff options
context:
space:
mode:
authorJonathan Anderson <jonathan@FreeBSD.org>2016-07-27 16:07:51 +0000
committerJonathan Anderson <jonathan@FreeBSD.org>2016-07-27 16:07:51 +0000
commita503a9cf75dafab2d53e28ec7aa62411665f2ced (patch)
tree91200aa700ca5080936563d6ee757a6bea5a0550 /lang/tcl86/Makefile
parenta83cd5bf9217dc109b33c57916756e222663548d (diff)
downloadports-a503a9cf75dafab2d53e28ec7aa62411665f2ced.tar.gz
ports-a503a9cf75dafab2d53e28ec7aa62411665f2ced.zip
Remove `Requires.private: zlib` on FreeBSD <10.
On FreeBSD 9, the 'Requires.private: zlib' line in tcl.pc causes breakage in ports that use pkg-config tcl to build their cflags, libraries, etc. This commit fixes at least the devel/libdistance build on 9; it may fix others, too. Approved by: gahr Differential Revision: https://reviews.freebsd.org/D4359
Notes
Notes: svn path=/head/; revision=419183
Diffstat (limited to 'lang/tcl86/Makefile')
-rw-r--r--lang/tcl86/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index 2dc7ae6f0a9e..4445fbf7d26d 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -56,6 +56,8 @@ MODULES_INSTALL_TARGET= install-modules
THREADS_CONFIGURE_ENABLE= threads
DEBUG_CONFIGURE_ENABLE= symbols
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e \
's|@TCL_BUILD_LIB_SPEC@|@TCL_LIB_SPEC@|; \
@@ -63,6 +65,12 @@ post-patch:
s|@TCL_BUILD_STUB_LIB_PATH@|@TCL_STUB_LIB_PATH@|; \
s|@TCL_SRC_DIR@|${PREFIX}/include/tcl${TCL_VER}|' \
${PATCH_WRKSRC}/unix/tclConfig.sh.in
+# On FreeBSD 9, pkg-config --cflags tcl can't find zlib.
+.if ${OSVERSION} < 1000000
+ ${REINPLACE_CMD} -e \
+ 's|Requires.private: zlib >= 1.2.3||' \
+ ${PATCH_WRKSRC}/unix/tcl.pc.in
+.endif
post-patch-TCLMAN-off:
@${FIND} ${PATCH_WRKSRC}/pkgs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \