aboutsummaryrefslogtreecommitdiff
path: root/lang/tclX/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-03-26 17:11:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-03-26 17:11:37 +0000
commitd3f0ec500755648b3037b8315802c3dd0e0fcb0e (patch)
tree0f80705654803be89a86048c211d2fb4112bf3ea /lang/tclX/Makefile
parentf6886cf793aa29e0d71b19d198a9111d1de267ad (diff)
downloadports-d3f0ec500755648b3037b8315802c3dd0e0fcb0e.tar.gz
ports-d3f0ec500755648b3037b8315802c3dd0e0fcb0e.zip
- Fix a breakage caused by revision v 1.91 of ports/lang/tcl84/Makefile
- Switch to USE_TCL - s/INSTALLS_SHLIB/USE_LDCONFIG/ - Support tcl84-thread - Fix tclsh detection in configure - Pet portlint. Note: this port is still broken, because a test is failing, and tests are part of the all target. PR: ports/110805 Submitted by: /me Approved by: mi (excepted the move of tests to a regression-test target)
Notes
Notes: svn path=/head/; revision=188400
Diffstat (limited to 'lang/tclX/Makefile')
-rw-r--r--lang/tclX/Makefile35
1 files changed, 21 insertions, 14 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 4da4f0c00dd3..8d25b460d89a 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tclX
PORTVERSION= 8.4
-CATEGORIES= lang tcl${TCL_DVER} devel
+CATEGORIES= lang tcl${USE_TCL} devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=tclx
DISTNAME= tclx${PORTVERSION}
@@ -16,18 +16,15 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Extended TCL
USE_BZIP2= yes
-LIB_DEPENDS= tcl${TCL_DVER}:${PORTSDIR}/lang/tcl${TCL_DVER}
+USE_TCL_BUILD= yes
-TCL_VER?= 8.4
-TCL_DVER?= ${TCL_VER:S/.//}
-
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/tcl${TCL_VER}/unix\
- -I${LOCALBASE}/include/tcl${TCL_VER}/generic"
-CONFIGURE_ARGS= --enable-shared \
+CONFIGURE_ENV+= CPPFLAGS="-I${TCL_INCLUDEDIR}/unix\
+ -I${TCL_INCLUDEDIR}/generic"
+CONFIGURE_ARGS= --enable-shared \
--with-help=Help \
- --with-tcl="${LOCALBASE}/lib/tcl${TCL_VER}"
+ --with-tcl="${TCL_LIBDIR}"
PLIST_SUB= TCLX_VER=${PORTVERSION}
ALL_TARGET= binaries libraries test
INSTALL_TARGET= install-binaries install-libraries
@@ -36,7 +33,7 @@ ALL_TARGET+= doc
INSTALL_TARGET+=install-help
.endif
-MAN3= CmdWrite.3 Handles.3 Keylist.3 ObjCmdWrite.3 TclXInit.3
+MAN3= CmdWrite.3 Handles.3 Keylist.3 ObjCmdWrite.3 TclXInit.3
MANN= TclX.n
MLINKS= CmdWrite.3 TclCommandWriting.3 \
@@ -51,15 +48,25 @@ MLINKS+= Handles.3 TclX_Handle$l.3
MLINKS+= TclXInit.3 $l.3
.endfor
+.include <bsd.port.pre.mk>
+
+pre-configure:
+.if exists(${TCL_LIBDIR}/tclConfig-threads.sh)
+ ${REINPLACE_CMD} -e 's|tclConfig.sh|tclConfig-threads.sh|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+ ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-configure:
${REINPLACE_CMD} -e \
- 's,^TCLSH_PROG.*,TCLSH_PROG=${LOCALBASE}/bin/tclsh${TCL_VER},' \
+ 's,^TCLSH_PROG.*,TCLSH_PROG=${TCLSH},' \
-e 's,TCL_LIBRARY=.*,\\,' ${WRKSRC}/Makefile
# Disabling the failing help.test
- mv ${WRKSRC}/tests/help.test ${WRKSRC}/tests/help.test.dis
+ ${MV} ${WRKSRC}/tests/help.test ${WRKSRC}/tests/help.test.dis
pre-su-install:
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN3} ${PREFIX}/man/man3
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MANN} ${PREFIX}/man/mann
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>