aboutsummaryrefslogtreecommitdiff
path: root/lang/tinypy/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 15:13:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 15:13:42 +0000
commitd4600efa64b02956fc97a76bd14229f63a8d2b57 (patch)
tree0b36792fa675c2edf5b15e43588e3ae7a3958ffc /lang/tinypy/Makefile
parent3b0fd06fc8d70804ca3abc205f0f7685d06e31ad (diff)
downloadports-d4600efa64b02956fc97a76bd14229f63a8d2b57.tar.gz
ports-d4600efa64b02956fc97a76bd14229f63a8d2b57.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=319870
Diffstat (limited to 'lang/tinypy/Makefile')
-rw-r--r--lang/tinypy/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/lang/tinypy/Makefile b/lang/tinypy/Makefile
index 4ae1bab04658..9d0239eeb6dc 100644
--- a/lang/tinypy/Makefile
+++ b/lang/tinypy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tinypy
-# Date created: 2009-02-26
-# Whom: Marcin Cieslak <saper@SYSTEM.PL>
-#
+# Created by: Marcin Cieslak <saper@SYSTEM.PL>
# $FreeBSD$
-#
PORTNAME= tinypy
PORTVERSION= 1.1
@@ -22,11 +18,12 @@ PYDISTUTILS_NOEGGINFO= yes
PLIST_FILES= bin/tinypy
PORTEXAMPLES= *
-OPTIONS= PYGAME "Enable PyGame support (requires SDL)" off
+OPTIONS_DEFINE= PYGAME
+PYGAME_DESC= PyGame support (requires SDL)
.include <bsd.port.options.mk>
-.if defined(WITH_PYGAME)
+.if ${PORT_OPTIONS:MPYGAME}
PYDISTUTILS_BUILD_TARGET+= pygame
USE_SDL= sdl
.endif
@@ -42,7 +39,7 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/tinypy ${PREFIX}/bin
-.if !defined(NOPORTEXAMPLES) && defined(WITH_PYGAME)
+.if ${PORT_OPTIONS:MEXAMPLES} && ${PORT_OPTIONS:MPYGAME}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/julia.py ${EXAMPLESDIR}
.endif