aboutsummaryrefslogtreecommitdiff
path: root/lang/twelf/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-26 12:49:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-26 12:49:47 +0000
commit70b1179c61675622ee3de992eacb5c99f9032045 (patch)
treee305aca4b175baacf2bb7b6d284dc01bd5c3b5cc /lang/twelf/Makefile
parent3abb57addc4978907fa6eb21daefcdb9275a9f23 (diff)
downloadports-70b1179c61675622ee3de992eacb5c99f9032045.tar.gz
ports-70b1179c61675622ee3de992eacb5c99f9032045.zip
New port: lang/twelf A meta-logical framework for deductive systems
The Twelf implementation comprises * the LF logical framework, including type reconstruction; * the Elf constraint logic programming language; * an inductive meta-theorem prover for LF; * and an Emacs interface. PR: ports/84625 Submitted by: "Andrew Bernard" <andrew@hobnob.com>
Notes
Notes: svn path=/head/; revision=149566
Diffstat (limited to 'lang/twelf/Makefile')
-rw-r--r--lang/twelf/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/twelf/Makefile b/lang/twelf/Makefile
new file mode 100644
index 000000000000..8e790e9e6813
--- /dev/null
+++ b/lang/twelf/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: twelf
+# Date created: 7/8/5
+# Whom: andrewb@cs.cmu.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= twelf
+PORTVERSION= 1.4
+CATEGORIES= lang
+MASTER_SITES= http://www-2.cs.cmu.edu/~twelf/dist/ http://www.cs.cmu.edu/~twelf/dist/
+DISTNAME= twelf-1-4
+
+MAINTAINER= andrewb@cs.cmu.edu
+COMMENT= A meta-logical framework for deductive systems
+
+RUN_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
+BUILD_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
+
+WRKSRC= ${WRKDIR}/twelf
+USE_REINPLACE= yes
+INFO= twelf
+
+RESTRICTED= "License is currently indeterminate (expected to be GPL)"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>