aboutsummaryrefslogtreecommitdiff
path: root/lang/v8
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-21 11:31:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-21 11:31:58 +0000
commit039218878aaed195d23e6833a23a4dd31bbf9ec4 (patch)
tree1fc15e93324ee19d2549bc9fb6e1d10a7cd66328 /lang/v8
parentd91e95f155c1901ec873018c9b8b07a079700c33 (diff)
downloadports-039218878aaed195d23e6833a23a4dd31bbf9ec4.tar.gz
ports-039218878aaed195d23e6833a23a4dd31bbf9ec4.zip
- Fix build with Clang 3.6.0
- Use CXXFLAGS instead of CFLAGS - Simplify CXXFLAGS: all supported Clang are 3.3+
Notes
Notes: svn path=/head/; revision=379501
Diffstat (limited to 'lang/v8')
-rw-r--r--lang/v8/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index eb378737eb07..77afb4d505ef 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -32,14 +32,14 @@ python_CMD= ${PYTHON_CMD}
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang
-CFLAGS+= -Wno-unused-private-field
+CXXFLAGS+= -Wno-nested-anon-types -Wno-unused-function -Wno-unused-private-field
MAKE_ENV+= LINK=clang++
-.if ${COMPILER_VERSION} >= 33
-CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.if ${COMPILER_VERSION} >= 34
-CFLAGS+= -Wno-unused-const-variable
+CXXFLAGS+= -Wno-unused-const-variable
.if ${COMPILER_VERSION} >= 35
-CFLAGS+= -Wno-tautological-undefined-compare
+CXXFLAGS+= -Wno-tautological-undefined-compare
+.if ${COMPILER_VERSION} >= 36
+CXXFLAGS+= -Wno-unused-local-typedef
.endif
.endif
.endif