aboutsummaryrefslogtreecommitdiff
path: root/lang/whitespace
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-30 20:04:03 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-30 20:04:03 +0000
commit4136ed975a0e8b21a4d464e03468cf056dd5e053 (patch)
tree349937a794dbe14c5721e91dcce9bb4dec7ad370 /lang/whitespace
parent311e60699d3c554aae5eedc90a793e6ab3e3b964 (diff)
downloadports-4136ed975a0e8b21a4d464e03468cf056dd5e053.tar.gz
ports-4136ed975a0e8b21a4d464e03468cf056dd5e053.zip
Add whitespace 0.3, an interpreter for the Whitespace programming
language. PR: ports/97479 Submitted by: Li-Lun Wang <llwang@infor.org> Approved by: tobez
Notes
Notes: svn path=/head/; revision=163999
Diffstat (limited to 'lang/whitespace')
-rw-r--r--lang/whitespace/Makefile36
-rw-r--r--lang/whitespace/distinfo3
-rw-r--r--lang/whitespace/pkg-descr13
-rw-r--r--lang/whitespace/pkg-plist11
4 files changed, 63 insertions, 0 deletions
diff --git a/lang/whitespace/Makefile b/lang/whitespace/Makefile
new file mode 100644
index 000000000000..27a0f54a8969
--- /dev/null
+++ b/lang/whitespace/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: whitespace
+# Date created: 18 May 2006
+# Whom: Li-Lun Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whitespace
+PORTVERSION= 0.3
+CATEGORIES= lang
+MASTER_SITES= http://compsoc.dur.ac.uk/whitespace/downloads/
+DISTNAME= wspace-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= llwang@infor.org
+COMMENT= An interpreter for the Whitespace programming language
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+WRKSRC= ${WRKDIR}/WSpace
+USE_GMAKE= yes
+ALL_TARGET= ${TARGET}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wspace ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/tutorial.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/whitespace/distinfo b/lang/whitespace/distinfo
new file mode 100644
index 000000000000..5b8ab6c38aa3
--- /dev/null
+++ b/lang/whitespace/distinfo
@@ -0,0 +1,3 @@
+MD5 (wspace-0.3.tgz) = fda72d6e3e5a0e5af2f0a42829f031e5
+SHA256 (wspace-0.3.tgz) = 53e47bf05df991c1d0f88a75cf5208bfc42d42b87f8fe3e8ee6a05ac78544a73
+SIZE (wspace-0.3.tgz) = 15471
diff --git a/lang/whitespace/pkg-descr b/lang/whitespace/pkg-descr
new file mode 100644
index 000000000000..dd6d1a51384a
--- /dev/null
+++ b/lang/whitespace/pkg-descr
@@ -0,0 +1,13 @@
+Whitespace is a imperative stack-based programming language that,
+contrary to most languages, ignores any non-whitespace characters.
+Only spaces, tabs, and newlines are considered syntax in Whitespace.
+
+This port is a prototype interpreter for the Whitespace programming
+language written in Haskell.
+
+Author: Edwin Brady
+ Chris Morris
+WWW: http://compsoc.dur.ac.uk/whitespace/
+
+- Li-Lun Wang
+llwang@infor.org
diff --git a/lang/whitespace/pkg-plist b/lang/whitespace/pkg-plist
new file mode 100644
index 000000000000..ee3ec5a10f23
--- /dev/null
+++ b/lang/whitespace/pkg-plist
@@ -0,0 +1,11 @@
+bin/wspace
+%%PORTDOCS%%%%DOCSDIR%%/tutorial.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/count.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/fact.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/hanoi.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/hworld.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/loctest.ws
+%%PORTDOCS%%%%EXAMPLESDIR%%/name.ws
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%