aboutsummaryrefslogtreecommitdiff
path: root/lang/whitespace
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-09 23:28:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-09 23:28:12 +0000
commit59b098fcb319c421c07a9ce6317f7e1efcba9d8a (patch)
tree5eb5d717a1af9556e00b3c177e1d02462eb74fbb /lang/whitespace
parent46b0b07c8897b1472e165f72c9a332c1f19966d3 (diff)
downloadports-59b098fcb319c421c07a9ce6317f7e1efcba9d8a.tar.gz
ports-59b098fcb319c421c07a9ce6317f7e1efcba9d8a.zip
- Support staging
- Convert USE_GMAKE to USES - Use new LIB_DEPENDS syntax - Remove redundant OPTIONS_DEFAULT - Convert single-line pkg-plist to PLIST_FILES - Remove Author lines
Notes
Notes: svn path=/head/; revision=353537
Diffstat (limited to 'lang/whitespace')
-rw-r--r--lang/whitespace/Makefile34
-rw-r--r--lang/whitespace/pkg-descr3
-rw-r--r--lang/whitespace/pkg-plist1
3 files changed, 12 insertions, 26 deletions
diff --git a/lang/whitespace/Makefile b/lang/whitespace/Makefile
index 49dc758cf9a4..49361b184195 100644
--- a/lang/whitespace/Makefile
+++ b/lang/whitespace/Makefile
@@ -15,35 +15,25 @@ COMMENT= Interpreter for the Whitespace programming language
LICENSE= GPLv2
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- ffi.6:${PORTSDIR}/devel/libffi
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libffi.so:${PORTSDIR}/devel/libffi
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
WRKSRC= ${WRKDIR}/WSpace
-USE_GMAKE= yes
ALL_TARGET= ${TARGET}
-OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_DEFAULT= DOCS EXAMPLES
-
-PORTEXAMPLES= *
-PORTDOCS= *
+PLIST_FILES= bin/wspace
+PORTEXAMPLES= *
+PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wspace ${PREFIX}/bin
-
-post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/tutorial.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/wspace ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/tutorial.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/lang/whitespace/pkg-descr b/lang/whitespace/pkg-descr
index 29b2906255ed..0a7960ea3bff 100644
--- a/lang/whitespace/pkg-descr
+++ b/lang/whitespace/pkg-descr
@@ -5,7 +5,4 @@ Only spaces, tabs, and newlines are considered syntax in Whitespace.
This port is a prototype interpreter for the Whitespace programming
language written in Haskell.
-Author: Edwin Brady
- Chris Morris
-
WWW: http://compsoc.dur.ac.uk/whitespace/
diff --git a/lang/whitespace/pkg-plist b/lang/whitespace/pkg-plist
deleted file mode 100644
index 01f5e5987eb6..000000000000
--- a/lang/whitespace/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/wspace