aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-04 19:14:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-04 19:14:05 +0000
commit012dbaaa7911c575272d97723041183f4033781e (patch)
tree2b325608d2b3d968a989327c32a1426c14ab46b6 /lang
parent76aff84cb5872b088d085a61be49f92693b26f59 (diff)
downloadports-012dbaaa7911c575272d97723041183f4033781e.tar.gz
ports-012dbaaa7911c575272d97723041183f4033781e.zip
- Update to 1.5-rc6
PR: ports/66208 Submitted by: Dan Rench <citric@cubicone.tmetic.com> (maintainer)
Notes
Notes: svn path=/head/; revision=108394
Diffstat (limited to 'lang')
-rw-r--r--lang/spidermonkey/Makefile20
-rw-r--r--lang/spidermonkey/distinfo4
-rw-r--r--lang/spidermonkey/pkg-plist10
3 files changed, 26 insertions, 8 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index d6936ddc3351..ff67227dd559 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -5,20 +5,19 @@
# $FreeBSD$
PORTNAME= js
-PORTVERSION= 1.5.p5
-PORTREVISION= 2
+PORTVERSION= 1.5.p6
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= js
-DISTNAME= js-1.5-rc5a
+DISTNAME= js-1.5-rc6
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= A standalone JavaScript interpreter from the Mozilla project
CONFLICTS= njs-*
-PLIST_FILES= bin/js
USE_GMAKE= YES
+INSTALLS_SHLIB= YES
.include <bsd.port.pre.mk>
@@ -26,15 +25,24 @@ USE_GMAKE= YES
BROKEN= "Does not compile on amd64 or ia64 (missing -fPIC)"
.endif
+JS_ARCH:= `uname -s``uname -r`
+JS_HEADERS!= ${GREP} '\.h$$' ${MASTERDIR}/pkg-plist | ${SED} 'sX^include/XX'
+
post-extract:
${MV} ${WRKDIR}/js/src ${WRKSRC} && \
${RM} -rf js && \
${CP} ${WRKSRC}/config/Linux_All.mk \
- ${WRKSRC}/config/`uname -s``uname -r`.mk && \
+ ${WRKSRC}/config/${JS_ARCH}.mk && \
${CP} ${WRKSRC}/Makefile.ref ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/`uname -s``uname -r`_DBG.OBJ/js \
+ ${INSTALL_PROGRAM} ${WRKSRC}/${JS_ARCH}_DBG.OBJ/js \
${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${JS_ARCH}_DBG.OBJ/libjs.so \
+ ${PREFIX}/lib
+ ${CP} ${WRKSRC}/${JS_ARCH}_DBG.OBJ/jsautocfg.h ${WRKSRC}
+.for jsh in ${JS_HEADERS}
+ @${INSTALL_DATA} ${WRKSRC}/${jsh} ${PREFIX}/include/
+.endfor
.include <bsd.port.post.mk>
diff --git a/lang/spidermonkey/distinfo b/lang/spidermonkey/distinfo
index 84989643a8a2..df06a5487f60 100644
--- a/lang/spidermonkey/distinfo
+++ b/lang/spidermonkey/distinfo
@@ -1,2 +1,2 @@
-MD5 (js-1.5-rc5a.tar.gz) = 001fae2f953c2bbc0b495ee0823a3539
-SIZE (js-1.5-rc5a.tar.gz) = 1122135
+MD5 (js-1.5-rc6.tar.gz) = ffb1c63d5c828a7e3251356e7df3c807
+SIZE (js-1.5-rc6.tar.gz) = 1038863
diff --git a/lang/spidermonkey/pkg-plist b/lang/spidermonkey/pkg-plist
new file mode 100644
index 000000000000..20ab0fd5e126
--- /dev/null
+++ b/lang/spidermonkey/pkg-plist
@@ -0,0 +1,10 @@
+bin/js
+lib/libjs.so
+include/jsapi.h
+include/jsautocfg.h
+include/jscompat.h
+include/jslong.h
+include/jsosdep.h
+include/jsotypes.h
+include/jspubtd.h
+include/jstypes.h