aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-09-04 19:51:15 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-09-04 19:51:15 +0000
commit1b358ee9b232c13319ad3cea0cbf35a712717b3e (patch)
treedad3b7fe43a73ef6c87b3ff80ac6fd3ccf6b4b34 /lang
parenta817fff05a418cd34ddddd32a2cde8d2ed163aae (diff)
downloadports-1b358ee9b232c13319ad3cea0cbf35a712717b3e.tar.gz
ports-1b358ee9b232c13319ad3cea0cbf35a712717b3e.zip
Update to the 20110827 snapshot of GCC 4.7.0 (which apparently requires
the newer version of binutils that we are using). Remove a patch for ia64 that was not accepted upstream and where the are in question was restructured recently.
Notes
Notes: svn path=/head/; revision=281177
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc47/distinfo4
-rw-r--r--lang/gcc47/files/patch-unwind-ia64.h19
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gcc48/distinfo4
-rw-r--r--lang/gcc48/files/patch-unwind-ia64.h19
6 files changed, 6 insertions, 44 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 0d976fe86bcf..a46a3dd1bce4 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gcc
-PORTVERSION= 4.7.0.20110730
+PORTVERSION= 4.7.0.20110827
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
diff --git a/lang/gcc47/distinfo b/lang/gcc47/distinfo
index 88d00c25422f..b50bed888da6 100644
--- a/lang/gcc47/distinfo
+++ b/lang/gcc47/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.7-20110730.tar.bz2) = 118027b90b721d9920b4577560ef50085364d8a33c7216d5f1029e33e013f4b2
-SIZE (gcc-4.7-20110730.tar.bz2) = 70186483
+SHA256 (gcc-4.7-20110827.tar.bz2) = 70c27388a1c089aede3d59f52aa79c9b1badc211571944dd88b95a77d7b1f520
+SIZE (gcc-4.7-20110827.tar.bz2) = 72708908
diff --git a/lang/gcc47/files/patch-unwind-ia64.h b/lang/gcc47/files/patch-unwind-ia64.h
deleted file mode 100644
index 265c82c77042..000000000000
--- a/lang/gcc47/files/patch-unwind-ia64.h
+++ /dev/null
@@ -1,19 +0,0 @@
-2010-09-12 Gerald Pfeifer <gerald@pfeifer.com>
-
- PR target/45650
- * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
- hidden on FreeBSD.
-
-Index: gcc/config/ia64/unwind-ia64.h
-===================================================================
---- gcc/config/ia64/unwind-ia64.h (revision 164211)
-+++ gcc/config/ia64/unwind-ia64.h (working copy)
-@@ -40,4 +40,7 @@
- extern struct unw_table_entry *
- _Unwind_FindTableEntry (void *pc, unsigned long *segment_base,
- unsigned long *gp, struct unw_table_entry *ent)
-- __attribute__ ((__visibility__ ("hidden")));
-+#ifndef __FreeBSD__
-+ __attribute__ ((__visibility__ ("hidden")))
-+#endif
-+ ;
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 0d976fe86bcf..a46a3dd1bce4 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gcc
-PORTVERSION= 4.7.0.20110730
+PORTVERSION= 4.7.0.20110827
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
diff --git a/lang/gcc48/distinfo b/lang/gcc48/distinfo
index 88d00c25422f..b50bed888da6 100644
--- a/lang/gcc48/distinfo
+++ b/lang/gcc48/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.7-20110730.tar.bz2) = 118027b90b721d9920b4577560ef50085364d8a33c7216d5f1029e33e013f4b2
-SIZE (gcc-4.7-20110730.tar.bz2) = 70186483
+SHA256 (gcc-4.7-20110827.tar.bz2) = 70c27388a1c089aede3d59f52aa79c9b1badc211571944dd88b95a77d7b1f520
+SIZE (gcc-4.7-20110827.tar.bz2) = 72708908
diff --git a/lang/gcc48/files/patch-unwind-ia64.h b/lang/gcc48/files/patch-unwind-ia64.h
deleted file mode 100644
index 265c82c77042..000000000000
--- a/lang/gcc48/files/patch-unwind-ia64.h
+++ /dev/null
@@ -1,19 +0,0 @@
-2010-09-12 Gerald Pfeifer <gerald@pfeifer.com>
-
- PR target/45650
- * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
- hidden on FreeBSD.
-
-Index: gcc/config/ia64/unwind-ia64.h
-===================================================================
---- gcc/config/ia64/unwind-ia64.h (revision 164211)
-+++ gcc/config/ia64/unwind-ia64.h (working copy)
-@@ -40,4 +40,7 @@
- extern struct unw_table_entry *
- _Unwind_FindTableEntry (void *pc, unsigned long *segment_base,
- unsigned long *gp, struct unw_table_entry *ent)
-- __attribute__ ((__visibility__ ("hidden")));
-+#ifndef __FreeBSD__
-+ __attribute__ ((__visibility__ ("hidden")))
-+#endif
-+ ;