aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-02-28 22:56:08 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-02-28 22:56:08 +0000
commit1e5ca7aefcdff036c619b4dd4e9e6320be3166e3 (patch)
tree9a18b1cecf8dd4c6bc8ba41dae7d2054881ab529 /lang
parentde4e011218a370c2b88fdbaa0dc70910a292b8d3 (diff)
downloadports-1e5ca7aefcdff036c619b4dd4e9e6320be3166e3.tar.gz
ports-1e5ca7aefcdff036c619b4dd4e9e6320be3166e3.zip
Remove lang/gcc44 aka GCC 4.4 which has been deprecated since 2011-05-08
and was originally created 2008-03-01, thirteen months before the upstream release of GCC 4.4.0. Even lang/gcc45 has been gone for more than two years now. Recommend the generic lang/gcc as a replacement.
Notes
Notes: svn path=/head/; revision=346580
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc44/Makefile102
-rw-r--r--lang/gcc44/distinfo2
-rw-r--r--lang/gcc44/files/java-patch-hier13
-rw-r--r--lang/gcc44/files/patch-libcpp10
-rw-r--r--lang/gcc44/pkg-descr7
-rw-r--r--lang/gcc44/pkg-plist19
-rw-r--r--lang/gcc49/Makefile2
-rw-r--r--lang/gcc49/distinfo4
9 files changed, 3 insertions, 157 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 21616f102a6f..602f90ddbc7c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -87,7 +87,6 @@
SUBDIR += gcc
SUBDIR += gcc-aux
SUBDIR += gcc-ecj45
- SUBDIR += gcc44
SUBDIR += gcc46
SUBDIR += gcc47
SUBDIR += gcc48
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
deleted file mode 100644
index 0a0737c1ddbf..000000000000
--- a/lang/gcc44/Makefile
+++ /dev/null
@@ -1,102 +0,0 @@
-# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= gcc44
-PORTVERSION= 4.4.7
-PORTEPOCH= 1
-CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_GCC}
-MASTER_SITE_SUBDIR= releases/gcc-${DISTVERSION}
-DISTNAME= gcc-${DISTVERSION}
-
-MAINTAINER= gerald@FreeBSD.org
-COMMENT= GNU Compiler Collection 4.4
-
-LICENSE= GPLv3 GPLv3RLE
-LICENSE_COMB= multi
-
-LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
- libmpfr.so:${PORTSDIR}/math/mpfr
-RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
-
-DEPRECATED= Superseded by GCC 4.6
-
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed.
-DISTVERSION= ${PORTVERSION}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
-SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-ONLY_FOR_ARCHS= amd64 i386 sparc64
-USE_BINUTILS= yes
-USES= gmake iconv perl5
-USE_BZIP2= yes
-USE_PERL5= build
-SSP_UNSAFE= yes
-
-PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-${OPSYS:L}${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-${OPSYS:L}${OSREL}
-.endif
-
-SRCDIR= ${WRKDIR}/gcc-${DISTVERSION}
-WRKSRC= ${WRKDIR}/build
-TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
-LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
-GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include -fgnu89-inline
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+=--disable-bootstrap \
- --disable-nls \
- --enable-languages=c,c++,fortran \
- --libdir=${TARGLIB} \
- --libexecdir=${LIBEXEC} \
- --program-suffix=${SUFFIX} \
- --with-as=${LOCALBASE}/bin/as \
- --with-gmp=${LOCALBASE} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/ \
- --with-ld=${LOCALBASE}/bin/ld \
- ${ICONV_CONFIGURE_ARG} \
- --with-pkgversion="FreeBSD Ports Collection" \
- --with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
- GNU_HOST=${CONFIGURE_TARGET} \
- SUFFIX=${SUFFIX}
-INFO= gcc${SUFFIX}/cpp \
- gcc${SUFFIX}/cppinternals \
- gcc${SUFFIX}/gcc \
- gcc${SUFFIX}/gccinstall \
- gcc${SUFFIX}/gccint \
- gcc${SUFFIX}/gfortran \
- gcc${SUFFIX}/libgomp
-
-pre-everything::
- @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${CONFIGURE_TARGET} [${LANGUAGES}]"
-
-pre-configure:
- cd ${SRCDIR} ; contrib/gcc_update --touch
- @${RM} -f ${SRCDIR}/gcc/*/*.info*
- @${MKDIR} ${CONFIGURE_WRKSRC}
-
-post-install:
- ${RM} -f ${STAGEDIR}${TARGLIB}/*.la
- ${RM} -f ${STAGEDIR}${PREFIX}/man/man7/*
- # Add target libraries and include files to packaging list.
- ${RM} -f ${WRKDIR}/PLIST.lib
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
- cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
- ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
- ${FIND} $d -type d | ${SORT} -r \
- | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.lib ;\
- fi
-.endfor
- cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc44/distinfo b/lang/gcc44/distinfo
deleted file mode 100644
index 520606004572..000000000000
--- a/lang/gcc44/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gcc-4.4.7.tar.bz2) = 5ff75116b8f763fa0fb5621af80fc6fb3ea0f1b1a57520874982f03f26cd607f
-SIZE (gcc-4.4.7.tar.bz2) = 63179340
diff --git a/lang/gcc44/files/java-patch-hier b/lang/gcc44/files/java-patch-hier
deleted file mode 100644
index edb122b087b8..000000000000
--- a/lang/gcc44/files/java-patch-hier
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libjava/Makefile.in
-===================================================================
---- libjava/Makefile.in (revision 117734)
-+++ libjava/Makefile.in (working copy)
-@@ -712,7 +712,7 @@
- $(am__append_2) $(am__append_3)
- toolexecmainlib_DATA = libgcj.spec
- dbexec_LTLIBRARIES = libjvm.la
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- jardir = $(datadir)/java
- jar_DATA = libgcj-$(gcc_version).jar libgcj-tools-$(gcc_version).jar
- @JAVA_HOME_SET_FALSE@JAVA_HOME_DIR = $(prefix)
diff --git a/lang/gcc44/files/patch-libcpp b/lang/gcc44/files/patch-libcpp
deleted file mode 100644
index 80ed1a7f246d..000000000000
--- a/lang/gcc44/files/patch-libcpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libcpp/internal.h 2012-07-30 09:24:59.000000000 +0000
-+++ libcpp/internal.h 2013-09-04 00:41:26.000000000 +0000
-@@ -27,6 +27,7 @@
- #include "cpp-id-data.h"
-
- #if HAVE_ICONV
-+#define __bool_true_false_are_defined
- #include <iconv.h>
- #else
- #define HAVE_ICONV 0
diff --git a/lang/gcc44/pkg-descr b/lang/gcc44/pkg-descr
deleted file mode 100644
index ff8b85469f22..000000000000
--- a/lang/gcc44/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-GCC, the GNU Compiler Collection, supports a number of languages. This
-port installs the C, C++, and Fortran front ends as gcc44, g++44, and
-gfortran44 respectively.
-
-WWW: http://gcc.gnu.org/
-
-Gerald Pfeifer <gerald@FreeBSD.org>
diff --git a/lang/gcc44/pkg-plist b/lang/gcc44/pkg-plist
deleted file mode 100644
index e7ccb0126182..000000000000
--- a/lang/gcc44/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/%%GNU_HOST%%-c++%%SUFFIX%%
-bin/%%GNU_HOST%%-g++%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-%%GCC_VERSION%%
-bin/%%GNU_HOST%%-gfortran%%SUFFIX%%
-bin/c++%%SUFFIX%%
-bin/cpp%%SUFFIX%%
-bin/g++%%SUFFIX%%
-bin/gcc%%SUFFIX%%
-bin/gccbug%%SUFFIX%%
-bin/gcov%%SUFFIX%%
-bin/gfortran%%SUFFIX%%
-info/gcc%%SUFFIX%%/dir
-man/man1/cpp%%SUFFIX%%.1.gz
-man/man1/g++%%SUFFIX%%.1.gz
-man/man1/gcc%%SUFFIX%%.1.gz
-man/man1/gcov%%SUFFIX%%.1.gz
-man/man1/gfortran%%SUFFIX%%.1.gz
-@comment Insert PLIST.lib here
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index 4eb4835a2bfb..c9ba9c7b1f89 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc49
-PORTVERSION= 4.9.0.20140216
+PORTVERSION= 4.9.0.20140223
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${DISTVERSION}
diff --git a/lang/gcc49/distinfo b/lang/gcc49/distinfo
index 70171346c882..f2d3bc1af4e2 100644
--- a/lang/gcc49/distinfo
+++ b/lang/gcc49/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.9-20140216.tar.bz2) = e324608d4fa03356f7854cf2925fdbadd3244704ac3516015f53653b3664f63b
-SIZE (gcc-4.9-20140216.tar.bz2) = 85110946
+SHA256 (gcc-4.9-20140223.tar.bz2) = 9ad922988e9a535ac5892f64cc67d9345bf40c042a471e55923a2d7e0ed9e0c7
+SIZE (gcc-4.9-20140223.tar.bz2) = 85087748