aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-04-13 12:53:17 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-04-15 17:49:59 +0000
commit2a4f447e3b26d99d9498c644fef38f03f8fec90c (patch)
treeccc23d0ce1b3ee01ee2a5bad41bbacfabd75d4f6 /lang
parente98a12e370d7419c704dc38754f34fcd7f601fa0 (diff)
downloadports-2a4f447e3b26d99d9498c644fef38f03f8fec90c.tar.gz
ports-2a4f447e3b26d99d9498c644fef38f03f8fec90c.zip
lang/gir-to-d: Pull in a fix from upstream.
Sponsored by: Serenity Cybersecurity, LLC
Diffstat (limited to 'lang')
-rw-r--r--lang/gir-to-d/Makefile2
-rw-r--r--lang/gir-to-d/files/patch-source_gtd_GirFunction.d12
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/gir-to-d/Makefile b/lang/gir-to-d/Makefile
index 7d034b3518d3..c3cb6e74fce7 100644
--- a/lang/gir-to-d/Makefile
+++ b/lang/gir-to-d/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gir-to-d
PORTVERSION= 0.23.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MAINTAINER= arrowd@FreeBSD.org
diff --git a/lang/gir-to-d/files/patch-source_gtd_GirFunction.d b/lang/gir-to-d/files/patch-source_gtd_GirFunction.d
new file mode 100644
index 000000000000..af780f6323ad
--- /dev/null
+++ b/lang/gir-to-d/files/patch-source_gtd_GirFunction.d
@@ -0,0 +1,12 @@
+--- source/gtd/GirFunction.d.orig 2022-03-23 22:26:51 UTC
++++ source/gtd/GirFunction.d
+@@ -1277,6 +1277,9 @@ final class GirFunction
+ if ( type.cType == "guchar*" )
+ return "char[]";
+
++ if ( type.cType == "gunichar2*" )
++ return "wchar[]";
++
+ if ( type.size > -1 )
+ size = to!string(type.size);
+