aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-12-18 04:11:03 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-12-18 04:11:03 +0000
commit37d2142ea544532de3c71ab857f81e983ba39644 (patch)
tree8e5d165d7b45fa01ffe009398e0957489f3db080 /lang
parent73e96a4bc143f472567852ea13d31f8b9f79f315 (diff)
downloadports-37d2142ea544532de3c71ab857f81e983ba39644.tar.gz
ports-37d2142ea544532de3c71ab857f81e983ba39644.zip
- Use libraries from boehm-gc-redirect instead of building own version.
This fixes build failure after the boehm-gc update. Reported by: pav
Notes
Notes: svn path=/head/; revision=246114
Diffstat (limited to 'lang')
-rw-r--r--lang/Sather/Makefile26
1 files changed, 5 insertions, 21 deletions
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index 3d138a179df0..d9339a68fb4e 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sather
PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,8 @@ COMMENT= Sather compiler
#
# NOTE: currently build fails with threaded Tk
#
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84 \
+ gc-redirect.1:${PORTSDIR}/devel/boehm-gc-redirect
BUILD_DEPENDS= ${LOCALBASE}/bin/libtool:${PORTSDIR}/devel/libtool22
USE_BZIP2= yes
@@ -29,11 +30,11 @@ MAN1= sabrowse.1 sacomp.1
INFO= sather sather-mode sather-tutorial
-SAT_CFLAGS= ${CFLAGS} -I. -I${BC_DIR}/include \
+SAT_CFLAGS= ${CFLAGS} -I. \
-I../System/Common \
-I${LOCALBASE}/include \
-I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4
-SAT_LIBS= -L${BC_DIR}/.libs -L${LOCALBASE}/lib -lgc -lm
+SAT_LIBS= -L${LOCALBASE}/lib -lgc-redirect -lm
SAT_LIBDIR= ${PREFIX}/lib/sather
OPTIONS= EMACS "Install Emacs syntax files" off
@@ -44,12 +45,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= boehm-gc is broken on ia64
-.endif
-
-BC_DIR!= cd ${PORTSDIR}/devel/boehm-gc && ${MAKE} -V WRKSRC
-
post-extract:
#
# Precompiled binaries are for Linux only
@@ -110,17 +105,6 @@ post-patch:
#
@${ECHO_CMD} \"abort2\" >> ${WRKSRC}/System/FORBID
-pre-build:
-#
-# We need to clean since REDIRECT is required
-#
- @(cd ${PORTSDIR}/devel/boehm-gc && \
- ${MAKE} BATCH=yes WITH_REDIRECT=yes clean all)
-#
-# We're wanting static linking
-#
- @${RM} -f ${BC_DIR}/.libs/*.so*
-
post-build:
.for file in sather-tutorial.texinfo sather-mode.texinfo sather.texinfo
cd ${WRKSRC}/Emacs && makeinfo --no-split ${file}