aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-04-17 14:49:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-04-17 14:49:31 +0000
commit3b2acc8b25ec23e19cadc093bfe91bcedc392697 (patch)
tree4b1867de7d1f817b84f67f9a025097fe13371f6f /lang
parentaa2ce4fb60f5936f8f4c167c00fb9eafb535711d (diff)
downloadports-3b2acc8b25ec23e19cadc093bfe91bcedc392697.tar.gz
ports-3b2acc8b25ec23e19cadc093bfe91bcedc392697.zip
lang/intel-compute-runtime: update to 20.15.16524
Notes
Notes: svn path=/head/; revision=531938
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-max_freq18
-rw-r--r--lang/intel-compute-runtime/files/patch-no-blitter37
4 files changed, 50 insertions, 13 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index aa996d4168d6..973ccf3427aa 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 20.14.16441
+DISTVERSION= 20.15.16524
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 8e2774351242..ba5fca008d0d 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1585911199
-SHA256 (intel-compute-runtime-20.14.16441_GH0.tar.gz) = 169e7833121beea8ec69ff9249ca06f3bae981e14593c7a62f363d4991acb7e2
-SIZE (intel-compute-runtime-20.14.16441_GH0.tar.gz) = 3012283
+TIMESTAMP = 1586590867
+SHA256 (intel-compute-runtime-20.15.16524_GH0.tar.gz) = 6b0f8f12fdda8c379f803b8b08e2219ca18377dea9487519ea46c1ecb4089f6a
+SIZE (intel-compute-runtime-20.15.16524_GH0.tar.gz) = 3031777
diff --git a/lang/intel-compute-runtime/files/patch-max_freq b/lang/intel-compute-runtime/files/patch-max_freq
index 44e3b0b82387..c0e4d7e751cc 100644
--- a/lang/intel-compute-runtime/files/patch-max_freq
+++ b/lang/intel-compute-runtime/files/patch-max_freq
@@ -3,11 +3,11 @@
$ clinfo | fgrep clock
Max clock frequency 0MHz
---- shared/source/os_interface/linux/drm_neo.cpp.orig 2020-03-06 21:12:07 UTC
+--- shared/source/os_interface/linux/drm_neo.cpp.orig 2020-04-11 07:41:07 UTC
+++ shared/source/os_interface/linux/drm_neo.cpp
-@@ -22,6 +22,11 @@
- #include <cstring>
+@@ -24,6 +24,11 @@
#include <fstream>
+ #include <linux/limits.h>
+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+#include <sys/param.h>
@@ -16,8 +16,8 @@
+
namespace NEO {
- const char *Drm::sysFsDefaultGpuPath = "/drm/card0";
-@@ -106,6 +111,16 @@ int Drm::getEnabledPooledEu(int &enabled) {
+ namespace IoctlHelper {
+@@ -104,6 +109,16 @@ int Drm::getEnabledPooledEu(int &enabled) {
int Drm::getMaxGpuFrequency(int &maxGpuFrequency) {
maxGpuFrequency = 0;
@@ -31,10 +31,10 @@
+
+ maxGpuFrequency = std::stoi(max_freq);
+#else
- int deviceID = 0;
- int ret = getDeviceID(deviceID);
- if (ret != 0) {
-@@ -127,6 +142,7 @@ int Drm::getMaxGpuFrequency(int &maxGpuFrequency) {
+ std::string clockSysFsPath = getSysFsPciPath();
+
+ clockSysFsPath += "/gt_max_freq_mhz";
+@@ -115,6 +130,7 @@ int Drm::getMaxGpuFrequency(int &maxGpuFrequency) {
ifs >> maxGpuFrequency;
ifs.close();
diff --git a/lang/intel-compute-runtime/files/patch-no-blitter b/lang/intel-compute-runtime/files/patch-no-blitter
new file mode 100644
index 000000000000..9fa59d0f9c03
--- /dev/null
+++ b/lang/intel-compute-runtime/files/patch-no-blitter
@@ -0,0 +1,37 @@
+Regressed by https://github.com/intel/compute-runtime/commit/691a4ea8237f
+blitterOperationsSupported isn't enabled on any GPU yet
+
+Process 82663 stopped
+* thread #1, name = 'ze_peak', stop reason = signal SIGABRT
+ frame #0: 0x000000080060b02a libc.so.7`__sys_thr_kill at thr_kill.S:4
+(lldb) bt
+* thread #1, name = 'ze_peak', stop reason = signal SIGABRT
+ * frame #0: 0x000000080060b02a libc.so.7`__sys_thr_kill at thr_kill.S:4
+ frame #1: 0x000000080060a9c4 libc.so.7`__raise(s=6) at raise.c:52:10
+ frame #2: 0x0000000800573459 libc.so.7`abort at abort.c:67:8
+ frame #3: 0x00000008003d6a49 libcxxrt.so.1`report_failure(err=<unavailable>, thrown_exception=0x0000000802717fa8) at exception.cc:719:5
+ frame #4: 0x000000000020df59 ze_peak`L0Context::init_xe(this=0x00007fffffffde70) at ze_peak.cpp:183:5
+ frame #5: 0x00000000002115d9 ze_peak`main(argc=1, argv=0x00007fffffffe0f0) at ze_peak.cpp:760:11
+ frame #6: 0x000000000020b8bf ze_peak`_start(ap=<unavailable>, cleanup=<unavailable>) at crt1.c:76:7
+(lldb) f 4
+frame #4: 0x000000000020df59 ze_peak`L0Context::init_xe(this=0x00007fffffffde70) at ze_peak.cpp:183:5
+ 180 result =
+ 181 zeCommandListCreate(device, &command_list_description, &command_list);
+ 182 if (result) {
+-> 183 throw std::runtime_error("zeDeviceCreateCommandList failed: " +
+ 184 std::to_string(result));
+ 185 }
+ 186 if (verbose)
+
+--- level_zero/core/source/device/device_imp.cpp.orig 2020-04-11 07:41:07 UTC
++++ level_zero/core/source/device/device_imp.cpp
+@@ -725,9 +725,7 @@ ze_result_t DeviceImp::isCreatedCommandListCopyOnly(co
+ auto hwInfo = neoDevice->getHardwareInfo();
+ if (hwInfo.capabilityTable.blitterOperationsSupported) {
+ *useBliter = true;
+- return ZE_RESULT_SUCCESS;
+ }
+- return ZE_RESULT_ERROR_INVALID_ENUMERATION;
+ }
+ return ZE_RESULT_SUCCESS;
+ }