aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2021-10-16 09:51:03 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2021-10-16 09:51:39 +0000
commit4460cf727a7788c9ce21f3344ce5745e5cd9fc4a (patch)
tree85ee27f029c1ee293667902fe22b65ecac0ff154 /lang
parent6e6416d8c14628219cd46134e032add468fa7411 (diff)
downloadports-4460cf727a7788c9ce21f3344ce5745e5cd9fc4a.tar.gz
ports-4460cf727a7788c9ce21f3344ce5745e5cd9fc4a.zip
*: fix tab vs. space issues, and comments according to the guide.
Diffstat (limited to 'lang')
-rw-r--r--lang/adacontrol/Makefile2
-rw-r--r--lang/fpc-source/Makefile2
-rw-r--r--lang/ghc/Makefile2
-rw-r--r--lang/gnatdroid-binutils/Makefile2
-rw-r--r--lang/linux-dotnet-sdk/Makefile2
-rw-r--r--lang/mono6.8/Makefile28
-rw-r--r--lang/php74/Makefile2
-rw-r--r--lang/picoc/Makefile2
-rw-r--r--lang/swi-pl/Makefile6
9 files changed, 25 insertions, 23 deletions
diff --git a/lang/adacontrol/Makefile b/lang/adacontrol/Makefile
index f10261df27ff..49e923b795f1 100644
--- a/lang/adacontrol/Makefile
+++ b/lang/adacontrol/Makefile
@@ -21,7 +21,7 @@ BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= build
PORTDOCS= adacontrol*
-OPTIONS_DEFINE= DOCS PROJECTS
+OPTIONS_DEFINE= DOCS PROJECTS
PROJECTS_DESC= Support the direct processing of .gpr files
PROJECTS_BUILD_DEPENDS= gprbuild:devel/gprbuild \
diff --git a/lang/fpc-source/Makefile b/lang/fpc-source/Makefile
index 96867b2004ce..58c788c060e9 100644
--- a/lang/fpc-source/Makefile
+++ b/lang/fpc-source/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
ftp://ftp.no.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
ftp://ftp.us.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
SF/freepascal/Source/${PORTVERSION}
-PKGNAMESUFFIX= -source
+PKGNAMESUFFIX= -source
DIST_SUBDIR= freepascal
MAINTAINER= acm@FreeBSD.org
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 229b48d08b2e..03bfac0c7b35 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= --enable-dtrace=0
.endif
.if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
-BOOT_GHC_VERSION= 8.6.3
+BOOT_GHC_VERSION= 8.6.3
.elif ${ARCH} == aarch64 || ${ARCH:Marmv*}
BOOT_GHC_VERSION= 8.10.7
.else
diff --git a/lang/gnatdroid-binutils/Makefile b/lang/gnatdroid-binutils/Makefile
index d828a959821b..0117e208e817 100644
--- a/lang/gnatdroid-binutils/Makefile
+++ b/lang/gnatdroid-binutils/Makefile
@@ -22,7 +22,7 @@ USES= gmake tar:bzip2
HAS_CONFIGURE= yes
NO_MTREE= yes
-NO_LICENSES_INSTALL= yes
+NO_LICENSES_INSTALL= yes
WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}
PREFIX?= ${LOCALBASE}/android
diff --git a/lang/linux-dotnet-sdk/Makefile b/lang/linux-dotnet-sdk/Makefile
index 9bb983af0c13..3cf067b13d32 100644
--- a/lang/linux-dotnet-sdk/Makefile
+++ b/lang/linux-dotnet-sdk/Makefile
@@ -23,7 +23,7 @@ USES= linux:c7 python:build
DATADIR= ${PREFIX}/share/dotnet
DESCR= ${.CURDIR}/../linux-dotnet-runtime/pkg-descr
-EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions \
+EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions \
--include LICENSE.txt --include sdk ${EXTRACT_EXTRA_ARGS}
EXTRACT_EXTRA_ARGS?= --include additionalDeps --include store
NO_WRKSUBDIR= yes
diff --git a/lang/mono6.8/Makefile b/lang/mono6.8/Makefile
index 6ce25bc56cba..b0eda708849b 100644
--- a/lang/mono6.8/Makefile
+++ b/lang/mono6.8/Makefile
@@ -35,15 +35,17 @@ CONFIGURE_SCRIPT= autogen.sh
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-SHEBANG_FILES= scripts/mono-package-runtime scripts/mono-heapviz mono/mini/genmdesc.py \
- mono/tests/test_lldb.py mono/tests/gc-descriptors/gen-descriptor-tests.py \
- scripts/mono-find-provides.in scripts/mono-find-requires.in
-BINARY_ALIAS= python=${PYTHON_CMD}
-
-CONFIGURE_ARGS_aarch64= --with-csc=mcs
-CONFIGURE_ARGS= ${CONFIGURE_ARGS_${ARCH}} --disable-dtrace
+SHEBANG_FILES= mono/mini/genmdesc.py \
+ mono/tests/gc-descriptors/gen-descriptor-tests.py \
+ mono/tests/test_lldb.py scripts/mono-find-provides.in \
+ scripts/mono-find-requires.in scripts/mono-heapviz \
+ scripts/mono-package-runtime
+BINARY_ALIAS= python=${PYTHON_CMD}
+
+CONFIGURE_ARGS_aarch64= --with-csc=mcs
+CONFIGURE_ARGS= ${CONFIGURE_ARGS_${ARCH}} --disable-dtrace
# Do not remove - this is needed to work around automake's lack of hinting
-CONFIGURE_ENV+= ac_cv_header_sys_inotify_h=yes
+CONFIGURE_ENV+= ac_cv_header_sys_inotify_h=yes
MAKE_ENV= MONO_SHARED_DIR="${WRKDIR}" \
INSTALL_STRIP_FLAG="${STRIP}"
@@ -68,12 +70,12 @@ OPTIONS_SUB= yes
BIGARRAY_DESC= Enable allocating arrays greater than Int32.MaxValue
BIGARRAY_CONFIGURE_ENABLE= big-arrays
-MONOLITE_DESC= Use monolite to bootstrap mcs (otherwise use installed mcs)
-MONOLITE_DISTFILES= monolite-linux-${MONOLITE_VERSION}-latest.tar.gz:monolite
-MONOLITE_MASTER_SITES= http://download.mono-project.com/monolite/:monolite
+MONOLITE_DESC= Use monolite to bootstrap mcs (otherwise use installed mcs)
+MONOLITE_DISTFILES= monolite-linux-${MONOLITE_VERSION}-latest.tar.gz:monolite
+MONOLITE_MASTER_SITES= http://download.mono-project.com/monolite/:monolite
# DO NOT ALTER OR REMOVE. DANGER, CASE-SENSITIVE!
# monolite 2020-01-13 @ 1798d23b
-MONOLITE_VERSION= 1798d23b-3dbc-4161-b3f4-6bb00134ee4e
+MONOLITE_VERSION= 1798d23b-3dbc-4161-b3f4-6bb00134ee4e
MONODEV_DESC= Build for Mono development (disables crash privacy)
MONODEV_CONFIGURE_ON= --enable-icall-symbol-map --enable-icall-export --with-crash_privacy=no
@@ -101,7 +103,7 @@ X11_RUN_DEPENDS= pango>0:x11-toolkits/pango \
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc*}
-PLIST+= ${.CURDIR}/pkg-plist.powerpc
+PLIST+= ${.CURDIR}/pkg-plist.powerpc
.endif
.include <bsd.port.pre.mk>
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index ce14e4aff5f4..2a83ded973f1 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -2,7 +2,7 @@ PORTNAME= php74
DISTVERSION= 7.4.24
PORTREVISION?= 0
CATEGORIES?= lang devel www
-MASTER_SITES= PHP/distributions
+MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
MAINTAINER= tz@FreeBSD.org
diff --git a/lang/picoc/Makefile b/lang/picoc/Makefile
index 816059bbf754..4fdae8dbbc96 100644
--- a/lang/picoc/Makefile
+++ b/lang/picoc/Makefile
@@ -13,7 +13,7 @@ BROKEN_riscv64= Fails to link: missing sbrk
USE_GITHUB= yes
GH_ACCOUNT= zsaleeba
-GH_TAGNAME= 4555e84
+GH_TAGNAME= 4555e84
USES= gmake readline
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 4856d0bf1167..f19a7a409455 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -24,9 +24,9 @@ USES= cmake compiler:c11 libarchive libedit pathfix pkgconfig \
readline shebangfix ssl xorg
USE_XORG= ice sm x11 xext xft xinerama xpm xt
-OPTIONS_DEFINE= DOCS TCMALLOC EXAMPLES XPCE GMP THREADED ODBC
-OPTIONS_DEFAULT= XPCE TCMALLOC GMP THREADED ODBC
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= DOCS EXAMPLES GMP ODBC TCMALLOC THREADED XPCE
+OPTIONS_DEFAULT= GMP ODBC TCMALLOC THREADED XPCE
+OPTIONS_SUB= yes
MAKE_ENV= XDG_DATA_DIRS=/dummy
CMAKE_ARGS= -DSWIPL_PACKAGES_JAVA=OFF -DBUILD_TESTING=OFF