aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-05 08:51:22 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-05 08:51:47 +0000
commit58f1c18c9424bee87b4a121707b437fd26754ecd (patch)
tree8543ab11a2b530d3f0ee051ebfce1788728183c4 /lang
parentee4bbe35644d9ab7f214246616040f6b63fe4e7a (diff)
downloadports-58f1c18c9424bee87b4a121707b437fd26754ecd.tar.gz
ports-58f1c18c9424bee87b4a121707b437fd26754ecd.zip
cleanup: Remove expired ports:
2021-09-03 lang/gcc7: Unsupported by upstream. Use GCC 10 or newer instead.
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc7/Makefile116
-rw-r--r--lang/gcc7/distinfo3
-rw-r--r--lang/gcc7/files/patch-gcc_config_i386_i386.c31
-rw-r--r--lang/gcc7/files/patch-gets-no-more47
-rw-r--r--lang/gcc7/files/pkg-message.in13
-rw-r--r--lang/gcc7/pkg-descr7
-rw-r--r--lang/gcc7/pkg-plist30
8 files changed, 0 insertions, 248 deletions
diff --git a/lang/Makefile b/lang/Makefile
index df6a0e048468..fdf97c9ed338 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -98,7 +98,6 @@
SUBDIR += gcc12-devel
SUBDIR += gcc48
SUBDIR += gcc6-aux
- SUBDIR += gcc7
SUBDIR += gcc8
SUBDIR += gcc9
SUBDIR += gcc9-devel
diff --git a/lang/gcc7/Makefile b/lang/gcc7/Makefile
deleted file mode 100644
index 379e6e16f93f..000000000000
--- a/lang/gcc7/Makefile
+++ /dev/null
@@ -1,116 +0,0 @@
-# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
-
-PORTNAME= gcc
-PORTVERSION= 7.5.0
-PORTREVISION= 4
-CATEGORIES= lang
-MASTER_SITES= GCC
-PKGNAMESUFFIX= ${SUFFIX}
-
-MAINTAINER= leres@FreeBSD.org
-COMMENT= GNU Compiler Collection 7
-
-LICENSE= GPLv3 GPLv3RLE
-LICENSE_COMB= multi
-
-DEPRECATED= Unsupported by upstream. Use GCC 10 or newer instead.
-EXPIRATION_DATE=2021-09-03
-ONLY_FOR_ARCHS= amd64
-
-LIB_DEPENDS= libgmp.so:math/gmp \
- libmpfr.so:math/mpfr \
- libmpc.so:math/mpc
-BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
-RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
-.if defined(MAINTAINER_MODE)
-BUILD_DEPENDS+= runtest:misc/dejagnu
-.endif
-
-USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:xz
-USE_BINUTILS= yes
-USE_PERL5= build
-
-CPE_VENDOR= gnu
-
-GCC_VERSION= ${PORTVERSION}
-SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
-CFLAGS:= ${CFLAGS:N-mretpoline}
-CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64
-CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
-.endif
-
-LANGUAGES:= c,c++
-TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
-TARGLIB32= ${PREFIX}/lib32 # The version information is added later
-LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
-GNU_CONFIGURE= yes
-CONFIGURE_OUTSOURCE= yes
-CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
-ALL_TARGET= bootstrap-lean
-INSTALL_TARGET= install-strip
-.if ${UID} != 0
-BINMODE= 755
-.endif
-CONFIGURE_ARGS+=--disable-nls \
- --disable-multilib \
- --enable-gnu-indirect-function \
- --enable-languages=${LANGUAGES} \
- --libdir=${TARGLIB} \
- --libexecdir=${LIBEXEC} \
- --program-suffix=${SUFFIX} \
- --with-as=${LOCALBASE}/bin/as \
- --with-gmp=${LOCALBASE} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/ \
- --with-ld=${LOCALBASE}/bin/ld \
- ${ICONV_CONFIGURE_ARG} \
- --with-pkgversion="FreeBSD Ports Collection" \
- --with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB+= GCC_VERSION=${GCC_VERSION} \
- GNU_HOST=${CONFIGURE_TARGET} \
- SUFFIX=${SUFFIX}
-INFO= gcc${SUFFIX}/cpp \
- gcc${SUFFIX}/cppinternals \
- gcc${SUFFIX}/gcc \
- gcc${SUFFIX}/gccinstall \
- gcc${SUFFIX}/gccint \
- gcc${SUFFIX}/gfortran \
- gcc${SUFFIX}/libgomp
-# Release tarballs (as opposed to snapshots) always carry this.
-INFO+= gcc${SUFFIX}/libquadmath \
- gcc${SUFFIX}/libitm
-SUB_FILES= pkg-message
-SUB_LIST+= TARGLIB=${TARGLIB}
-
-pre-everything::
- @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${CONFIGURE_TARGET} [${LANGUAGES}]"
-
-pre-configure:
- cd ${WRKSRC} ; contrib/gcc_update --touch
- @${RM} ${WRKSRC}/gcc/*/*.info*
-
-.if defined(MAINTAINER_MODE)
-full-regression-test: build
- cd ${TEST_WRKSRC}; ${MAKE_CMD} -sk check \
- ; ${WRKSRC}/contrib/test_summary
-.endif
-
-post-stage:
- ${RM} ${STAGEDIR}${PREFIX}/man/man7/*
- ${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
- # Add target libraries and include files to packaging list.
- ${RM} ${WRKDIR}/PLIST.lib
-
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${TARGLIB32:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
- cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
- ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
- fi
-.endfor
- cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc7/distinfo b/lang/gcc7/distinfo
deleted file mode 100644
index b5e1fd10509e..000000000000
--- a/lang/gcc7/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1573747413
-SHA256 (gcc-7.5.0.tar.xz) = b81946e7f01f90528a1f7352ab08cc602b9ccc05d4e44da4bd501c5a189ee661
-SIZE (gcc-7.5.0.tar.xz) = 62783088
diff --git a/lang/gcc7/files/patch-gcc_config_i386_i386.c b/lang/gcc7/files/patch-gcc_config_i386_i386.c
deleted file mode 100644
index 0096b5f6e431..000000000000
--- a/lang/gcc7/files/patch-gcc_config_i386_i386.c
+++ /dev/null
@@ -1,31 +0,0 @@
-This fixes
-
-/wrkdirs/usr/ports/lang/gcc7/work/gcc-7.5.0/gcc/config/i386/i386.c:9631:8: error: cannot initialize a variable of type 'bool' with an rvalue of type 'nullptr_t'
- bool error_p = NULL;
- ^ ~~~~
-
-and comes from upstream as part of
-
- commit 9f36390d429502f0a0dee20bda5b4870da948f6a
- Author: Uros Bizjak <ubizjak@gmail.com>
- Date: Sat May 6 09:01:51 2017 +0200
-
- i386.c (ext_80387_constant_init): Do not explicitly initialize to zero.
-
- * config/i386/i386.c (ext_80387_constant_init): Do not explicitly
- initialize to zero.
- (init_regs): Remove declaration.
- (function_arg_advance_32): Initialize error_p as boolean variable.
-
---- UTC
---- gcc/config/i386/i386.c.orig 2019-11-01 20:30:26 UTC
-+++ gcc/config/i386/i386.c
-@@ -9628,7 +9628,7 @@ function_arg_advance_32 (CUMULATIVE_ARGS *cum, machine
- HOST_WIDE_INT words)
- {
- int res = 0;
-- bool error_p = NULL;
-+ bool error_p = false;
-
- if (TARGET_IAMCU)
- {
diff --git a/lang/gcc7/files/patch-gets-no-more b/lang/gcc7/files/patch-gets-no-more
deleted file mode 100644
index 4b49aba3ca28..000000000000
--- a/lang/gcc7/files/patch-gets-no-more
+++ /dev/null
@@ -1,47 +0,0 @@
-Disable the build/use of libssp/gets-chk since FreeBSD 12 and later
-do not feature gets() any longer.
-
---- UTC
-Index: libssp/Makefile.am
-===================================================================
---- libssp/Makefile.am (revision 263319)
-+++ libssp/Makefile.am (working copy)
-@@ -42,7 +42,7 @@
- nobase_libsubinclude_HEADERS = ssp/ssp.h ssp/string.h ssp/stdio.h ssp/unistd.h
-
- libssp_la_SOURCES = \
-- ssp.c gets-chk.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
-+ ssp.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
- memset-chk.c snprintf-chk.c sprintf-chk.c stpcpy-chk.c \
- strcat-chk.c strcpy-chk.c strncat-chk.c strncpy-chk.c \
- vsnprintf-chk.c vsprintf-chk.c
-Index: libssp/Makefile.in
-===================================================================
---- libssp/Makefile.in (revision 263319)
-+++ libssp/Makefile.in (working copy)
-@@ -108,7 +108,7 @@
- am__installdirs = "$(DESTDIR)$(toolexeclibdir)" \
- "$(DESTDIR)$(libsubincludedir)"
- LTLIBRARIES = $(toolexeclib_LTLIBRARIES)
--am_libssp_la_OBJECTS = ssp.lo gets-chk.lo memcpy-chk.lo memmove-chk.lo \
-+am_libssp_la_OBJECTS = ssp.lo memcpy-chk.lo memmove-chk.lo \
- mempcpy-chk.lo memset-chk.lo snprintf-chk.lo sprintf-chk.lo \
- stpcpy-chk.lo strcat-chk.lo strcpy-chk.lo strncat-chk.lo \
- strncpy-chk.lo vsnprintf-chk.lo vsprintf-chk.lo
-@@ -291,7 +291,7 @@
- libsubincludedir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include
- nobase_libsubinclude_HEADERS = ssp/ssp.h ssp/string.h ssp/stdio.h ssp/unistd.h
- libssp_la_SOURCES = \
-- ssp.c gets-chk.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
-+ ssp.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
- memset-chk.c snprintf-chk.c sprintf-chk.c stpcpy-chk.c \
- strcat-chk.c strcpy-chk.c strncat-chk.c strncpy-chk.c \
- vsnprintf-chk.c vsprintf-chk.c
-@@ -452,7 +452,6 @@
- distclean-compile:
- -rm -f *.tab.c
-
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gets-chk.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libssp_nonshared_la-ssp-local.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memcpy-chk.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memmove-chk.Plo@am__quote@
diff --git a/lang/gcc7/files/pkg-message.in b/lang/gcc7/files/pkg-message.in
deleted file mode 100644
index df3ea725ce59..000000000000
--- a/lang/gcc7/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-[
-{ type: install
- message: <<EOD
-To ensure binaries built with this toolchain find appropriate versions
-of the necessary run-time libraries, you may want to link using
-
- -Wl,-rpath=%%TARGLIB%%
-
-For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
-transparently.
-EOD
-}
-]
diff --git a/lang/gcc7/pkg-descr b/lang/gcc7/pkg-descr
deleted file mode 100644
index 24a2627db47d..000000000000
--- a/lang/gcc7/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-GCC, the GNU Compiler Collection, supports a number of languages.
-This port installs the C, C++, and Fortran front ends as gcc7, g++7,
-and gfortran7, respectively.
-
-WWW: https://gcc.gnu.org
-
-Gerald Pfeifer <gerald@FreeBSD.org>
diff --git a/lang/gcc7/pkg-plist b/lang/gcc7/pkg-plist
deleted file mode 100644
index 5da6985fe118..000000000000
--- a/lang/gcc7/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-bin/%%GNU_HOST%%-c++%%SUFFIX%%
-bin/%%GNU_HOST%%-g++%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-%%GCC_VERSION%%
-bin/%%GNU_HOST%%-gcc-ar%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-nm%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-ranlib%%SUFFIX%%
-bin/c++%%SUFFIX%%
-bin/cpp%%SUFFIX%%
-bin/g++%%SUFFIX%%
-bin/gcc%%SUFFIX%%
-bin/gcc-ar%%SUFFIX%%
-bin/gcc-nm%%SUFFIX%%
-bin/gcc-ranlib%%SUFFIX%%
-bin/gcov%%SUFFIX%%
-bin/gcov-dump%%SUFFIX%%
-bin/gcov-tool%%SUFFIX%%
-man/man1/cpp%%SUFFIX%%.1.gz
-man/man1/g++%%SUFFIX%%.1.gz
-man/man1/gcc%%SUFFIX%%.1.gz
-man/man1/gcov%%SUFFIX%%.1.gz
-man/man1/gcov-dump%%SUFFIX%%.1.gz
-man/man1/gcov-tool%%SUFFIX%%.1.gz
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/__init__.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/__init__.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/printers.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/xmethods.py
-@postexec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
-@postunexec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
-@comment Insert PLIST.lib here