aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 21:54:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 21:54:28 +0000
commit625521b37aae8aa74ab4d9fe14e56d8397c4f538 (patch)
treefaa0fa927d2204e503c37c8a6d35e50c99f63cec /lang
parentf5d75319409234a4e21dc1107db5df970c1d0e5f (diff)
downloadports-625521b37aae8aa74ab4d9fe14e56d8397c4f538.tar.gz
ports-625521b37aae8aa74ab4d9fe14e56d8397c4f538.zip
Fix build on head by removing USE_GCC=any, and adding -fgnu89-inline to cflags
(gfortran requires gnu99) PR: ports/181816 Submitted by: tijl Approved by: gerald
Notes
Notes: svn path=/head/; revision=326553
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc44/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 7c701064e7a8..ef9e4ff8b016 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -22,11 +22,9 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 sparc64
USE_BINUTILS= yes
-USES= bison iconv
+USES= bison gmake iconv perl5
USE_BZIP2= yes
-USE_GCC= any
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -44,7 +42,7 @@ WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -fgnu89-inline
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-bootstrap \
--disable-nls \