aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-01-18 12:06:17 +0000
committerRene Ladan <rene@FreeBSD.org>2022-01-18 12:06:17 +0000
commit6552162aa7c846e68250019220db7dbccfb8d1d8 (patch)
tree43d8bedba0f0a0a7210123fbef51fc01f5573a76 /lang
parentdcbf6bef46feebbf9cb042533c1a362a2a1f91a0 (diff)
downloadports-6552162aa7c846e68250019220db7dbccfb8d1d8.tar.gz
ports-6552162aa7c846e68250019220db7dbccfb8d1d8.zip
cleanup: Remove expired ports:
2020-12-31 lang/spidermonkey60: Requires python2 to build
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/spidermonkey60/Makefile68
-rw-r--r--lang/spidermonkey60/distinfo3
-rw-r--r--lang/spidermonkey60/files/patch-js_public_TypeDecls.h26
-rw-r--r--lang/spidermonkey60/pkg-descr3
-rw-r--r--lang/spidermonkey60/pkg-plist172
6 files changed, 0 insertions, 273 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 7fa3d004f658..10e3709bd0ed 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -339,7 +339,6 @@
SUBDIR += snobol4
SUBDIR += solidity
SUBDIR += spidermonkey17
- SUBDIR += spidermonkey60
SUBDIR += spidermonkey78
SUBDIR += spl
SUBDIR += squeak
diff --git a/lang/spidermonkey60/Makefile b/lang/spidermonkey60/Makefile
deleted file mode 100644
index 5da89992b238..000000000000
--- a/lang/spidermonkey60/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-PORTNAME= spidermonkey
-DISTVERSION= 60.9.0
-PORTREVISION= 7
-CATEGORIES= lang
-MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
-PKGNAMESUFFIX= ${SP_VER}
-DISTNAME= firefox-${DISTVERSION}esr.source
-
-MAINTAINER= tcberner@FreeBSD.org
-COMMENT= Standalone JavaScript based from Mozilla 60-esr
-
-LICENSE= MPL20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-DEPRECATED= Requires python2 to build
-EXPIRATION_DATE= 2020-12-31
-
-BUILD_DEPENDS= autoconf-2.13:devel/autoconf213
-LIB_DEPENDS= libnspr4.so:devel/nspr \
- libffi.so:devel/libffi \
- libicudata.so:devel/icu
-
-HAS_CONFIGURE= yes
-USES= compiler:c++14-lang gmake localbase pathfix pkgconfig \
- python:2.7,build tar:xz
-USE_LDCONFIG= yes
-SP_VER= 60
-
-WRKSRC= ${WRKDIR}/firefox-${DISTVERSION}
-PATCH_WRKSRC= ${WRKDIR}/firefox-${DISTVERSION}/
-CONFIGURE_OUTSOURCE= yes
-CONFIGURE_SCRIPT= ../firefox-${DISTVERSION}/js/src/configure
-
-CONFIGURE_ARGS= --with-pthreads \
- --prefix=${PREFIX:Q} \
- --target=${CONFIGURE_TARGET} \
- --with-intl-api \
- --with-system-zlib \
- --disable-gold \
- --disable-debug \
- --disable-debug-symbols \
- --disable-jemalloc \
- --with-system-icu \
- --with-system-nspr \
- --enable-shared-js \
- --enable-optimize \
- --enable-readline
-
-CONFIGURE_ENV= HOST_CC=${CC} HOST_CXX=${CXX}
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64
-CONFIGURE_TARGET=x86_64-portbld-freebsd${OSREL}
-.endif
-
-.if ${ARCH} == i386
-# ld: error: undefined symbol: __atomic_load
-USE_GCC= yes
-.endif
-
-post-install:
- ${RM} ${STAGEDIR}${PREFIX}/lib/libjs_static.ajs
- ${LN} -fs libmozjs-${SP_VER}.so ${STAGEDIR}${PREFIX}/lib/libmozjs-${SP_VER}.so.1
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/js${SP_VER}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmozjs-${SP_VER}.*
-
-.include <bsd.port.post.mk>
diff --git a/lang/spidermonkey60/distinfo b/lang/spidermonkey60/distinfo
deleted file mode 100644
index d49620ac6d30..000000000000
--- a/lang/spidermonkey60/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1573931253
-SHA256 (firefox-60.9.0esr.source.tar.xz) = 9f453c8cc5669e46e38f977764d49a36295bf0d023619d9aac782e6bb3e8c53f
-SIZE (firefox-60.9.0esr.source.tar.xz) = 269089044
diff --git a/lang/spidermonkey60/files/patch-js_public_TypeDecls.h b/lang/spidermonkey60/files/patch-js_public_TypeDecls.h
deleted file mode 100644
index 6872c648187c..000000000000
--- a/lang/spidermonkey60/files/patch-js_public_TypeDecls.h
+++ /dev/null
@@ -1,26 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=1426865
-
-Add "dumb" patch to fix undefined symbols when trying to build gjs against
-this spidermonkey version.
-
-This issue was fix in firefox and backported to esr 68.
-
---- js/public/TypeDecls.h.orig 2019-09-01 13:09:17 UTC
-+++ js/public/TypeDecls.h
-@@ -20,6 +20,8 @@
- #include <stddef.h>
- #include <stdint.h>
-
-+#pragma GCC visibility push(default)
-+
- #include "js-config.h"
-
- typedef uint8_t jsbytecode;
-@@ -89,5 +91,7 @@ typedef PersistentRooted<JS::Symbol*> PersistentRooted
- typedef PersistentRooted<Value> PersistentRootedValue;
-
- } // namespace JS
-+
-+#pragma GCC visibility pop
-
- #endif /* js_TypeDecls_h */
diff --git a/lang/spidermonkey60/pkg-descr b/lang/spidermonkey60/pkg-descr
deleted file mode 100644
index 271ddb7e1386..000000000000
--- a/lang/spidermonkey60/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Spidermonkey is the JavaScript interpreter from the Mozilla project.
-
-WWW: https://spidermonkey.dev/
diff --git a/lang/spidermonkey60/pkg-plist b/lang/spidermonkey60/pkg-plist
deleted file mode 100644
index f3b3076b878e..000000000000
--- a/lang/spidermonkey60/pkg-plist
+++ /dev/null
@@ -1,172 +0,0 @@
-bin/js60
-bin/js60-config
-include/mozjs-60/double-conversion/double-conversion.h
-include/mozjs-60/double-conversion/utils.h
-include/mozjs-60/fdlibm.h
-include/mozjs-60/js-config.h
-include/mozjs-60/js.msg
-include/mozjs-60/js/AllocPolicy.h
-include/mozjs-60/js/CallArgs.h
-include/mozjs-60/js/CallNonGenericMethod.h
-include/mozjs-60/js/CharacterEncoding.h
-include/mozjs-60/js/Class.h
-include/mozjs-60/js/Conversions.h
-include/mozjs-60/js/Date.h
-include/mozjs-60/js/Debug.h
-include/mozjs-60/js/GCAPI.h
-include/mozjs-60/js/GCAnnotations.h
-include/mozjs-60/js/GCHashTable.h
-include/mozjs-60/js/GCPolicyAPI.h
-include/mozjs-60/js/GCVariant.h
-include/mozjs-60/js/GCVector.h
-include/mozjs-60/js/HashTable.h
-include/mozjs-60/js/HeapAPI.h
-include/mozjs-60/js/Id.h
-include/mozjs-60/js/Initialization.h
-include/mozjs-60/js/MemoryMetrics.h
-include/mozjs-60/js/Principals.h
-include/mozjs-60/js/Printf.h
-include/mozjs-60/js/ProfilingFrameIterator.h
-include/mozjs-60/js/ProfilingStack.h
-include/mozjs-60/js/ProtoKey.h
-include/mozjs-60/js/Proxy.h
-include/mozjs-60/js/Realm.h
-include/mozjs-60/js/RefCounted.h
-include/mozjs-60/js/RequiredDefines.h
-include/mozjs-60/js/Result.h
-include/mozjs-60/js/RootingAPI.h
-include/mozjs-60/js/SliceBudget.h
-include/mozjs-60/js/Stream.h
-include/mozjs-60/js/StructuredClone.h
-include/mozjs-60/js/SweepingAPI.h
-include/mozjs-60/js/TraceKind.h
-include/mozjs-60/js/TracingAPI.h
-include/mozjs-60/js/TrackedOptimizationInfo.h
-include/mozjs-60/js/TypeDecls.h
-include/mozjs-60/js/UbiNode.h
-include/mozjs-60/js/UbiNodeBreadthFirst.h
-include/mozjs-60/js/UbiNodeCensus.h
-include/mozjs-60/js/UbiNodeDominatorTree.h
-include/mozjs-60/js/UbiNodePostOrder.h
-include/mozjs-60/js/UbiNodeShortestPaths.h
-include/mozjs-60/js/UniquePtr.h
-include/mozjs-60/js/Utility.h
-include/mozjs-60/js/Value.h
-include/mozjs-60/js/Vector.h
-include/mozjs-60/js/WeakMapPtr.h
-include/mozjs-60/js/Wrapper.h
-include/mozjs-60/jsapi.h
-include/mozjs-60/jsfriendapi.h
-include/mozjs-60/jsperf.h
-include/mozjs-60/jspubtd.h
-include/mozjs-60/jstypes.h
-include/mozjs-60/malloc_decls.h
-include/mozjs-60/mozilla/Alignment.h
-include/mozjs-60/mozilla/AllocPolicy.h
-include/mozjs-60/mozilla/AlreadyAddRefed.h
-include/mozjs-60/mozilla/Array.h
-include/mozjs-60/mozilla/ArrayUtils.h
-include/mozjs-60/mozilla/Assertions.h
-include/mozjs-60/mozilla/Atomics.h
-include/mozjs-60/mozilla/Attributes.h
-include/mozjs-60/mozilla/AutoProfilerLabel.h
-include/mozjs-60/mozilla/BinarySearch.h
-include/mozjs-60/mozilla/BloomFilter.h
-include/mozjs-60/mozilla/BufferList.h
-include/mozjs-60/mozilla/Casting.h
-include/mozjs-60/mozilla/ChaosMode.h
-include/mozjs-60/mozilla/Char16.h
-include/mozjs-60/mozilla/CheckedInt.h
-include/mozjs-60/mozilla/Compiler.h
-include/mozjs-60/mozilla/Compression.h
-include/mozjs-60/mozilla/DebugOnly.h
-include/mozjs-60/mozilla/Decimal.h
-include/mozjs-60/mozilla/DefineEnum.h
-include/mozjs-60/mozilla/DoublyLinkedList.h
-include/mozjs-60/mozilla/EndianUtils.h
-include/mozjs-60/mozilla/EnumSet.h
-include/mozjs-60/mozilla/EnumTypeTraits.h
-include/mozjs-60/mozilla/EnumeratedArray.h
-include/mozjs-60/mozilla/EnumeratedRange.h
-include/mozjs-60/mozilla/FStream.h
-include/mozjs-60/mozilla/FastBernoulliTrial.h
-include/mozjs-60/mozilla/FloatingPoint.h
-include/mozjs-60/mozilla/GuardObjects.h
-include/mozjs-60/mozilla/HashFunctions.h
-include/mozjs-60/mozilla/IndexSequence.h
-include/mozjs-60/mozilla/IntegerPrintfMacros.h
-include/mozjs-60/mozilla/IntegerRange.h
-include/mozjs-60/mozilla/IntegerTypeTraits.h
-include/mozjs-60/mozilla/JSONWriter.h
-include/mozjs-60/mozilla/Likely.h
-include/mozjs-60/mozilla/LinkedList.h
-include/mozjs-60/mozilla/MacroArgs.h
-include/mozjs-60/mozilla/MacroForEach.h
-include/mozjs-60/mozilla/MathAlgorithms.h
-include/mozjs-60/mozilla/Maybe.h
-include/mozjs-60/mozilla/MaybeOneOf.h
-include/mozjs-60/mozilla/MemoryChecking.h
-include/mozjs-60/mozilla/MemoryReporting.h
-include/mozjs-60/mozilla/Move.h
-include/mozjs-60/mozilla/NotNull.h
-include/mozjs-60/mozilla/NullPtr.h
-include/mozjs-60/mozilla/Opaque.h
-include/mozjs-60/mozilla/OperatorNewExtensions.h
-include/mozjs-60/mozilla/Pair.h
-include/mozjs-60/mozilla/Path.h
-include/mozjs-60/mozilla/PlatformConditionVariable.h
-include/mozjs-60/mozilla/PlatformMutex.h
-include/mozjs-60/mozilla/PodOperations.h
-include/mozjs-60/mozilla/Poison.h
-include/mozjs-60/mozilla/Printf.h
-include/mozjs-60/mozilla/Range.h
-include/mozjs-60/mozilla/RangedArray.h
-include/mozjs-60/mozilla/RangedPtr.h
-include/mozjs-60/mozilla/ReentrancyGuard.h
-include/mozjs-60/mozilla/RefCountType.h
-include/mozjs-60/mozilla/RefCounted.h
-include/mozjs-60/mozilla/RefPtr.h
-include/mozjs-60/mozilla/Result.h
-include/mozjs-60/mozilla/ResultExtensions.h
-include/mozjs-60/mozilla/ReverseIterator.h
-include/mozjs-60/mozilla/RollingMean.h
-include/mozjs-60/mozilla/SHA1.h
-include/mozjs-60/mozilla/Saturate.h
-include/mozjs-60/mozilla/ScopeExit.h
-include/mozjs-60/mozilla/Scoped.h
-include/mozjs-60/mozilla/SegmentedVector.h
-include/mozjs-60/mozilla/SmallPointerArray.h
-include/mozjs-60/mozilla/Span.h
-include/mozjs-60/mozilla/SplayTree.h
-include/mozjs-60/mozilla/Sprintf.h
-include/mozjs-60/mozilla/StackWalk.h
-include/mozjs-60/mozilla/StaticAnalysisFunctions.h
-include/mozjs-60/mozilla/TaggedAnonymousMemory.h
-include/mozjs-60/mozilla/TemplateLib.h
-include/mozjs-60/mozilla/TextUtils.h
-include/mozjs-60/mozilla/ThreadLocal.h
-include/mozjs-60/mozilla/ThreadSafeWeakPtr.h
-include/mozjs-60/mozilla/TimeStamp.h
-include/mozjs-60/mozilla/ToString.h
-include/mozjs-60/mozilla/Tuple.h
-include/mozjs-60/mozilla/TypeTraits.h
-include/mozjs-60/mozilla/TypedEnumBits.h
-include/mozjs-60/mozilla/Types.h
-include/mozjs-60/mozilla/UniquePtr.h
-include/mozjs-60/mozilla/UniquePtrExtensions.h
-include/mozjs-60/mozilla/Unused.h
-include/mozjs-60/mozilla/Variant.h
-include/mozjs-60/mozilla/Vector.h
-include/mozjs-60/mozilla/WeakPtr.h
-include/mozjs-60/mozilla/WrappingOperations.h
-include/mozjs-60/mozilla/XorShift128PlusRNG.h
-include/mozjs-60/mozilla/fallible.h
-include/mozjs-60/mozilla/mozalloc.h
-include/mozjs-60/mozilla/mozalloc_abort.h
-include/mozjs-60/mozilla/mozalloc_oom.h
-include/mozjs-60/mozjemalloc_types.h
-include/mozjs-60/mozmemory.h
-include/mozjs-60/mozmemory_wrap.h
-lib/libmozjs-60.so
-lib/libmozjs-60.so.1
-libdata/pkgconfig/mozjs-60.pc