aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2018-03-05 09:36:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2018-03-05 09:36:29 +0000
commit67107f068113858de0d8876394a83f836b71d7b1 (patch)
tree26ee5185cd876c1415ac565e64704c31ceb52900 /lang
parentd8c26ee2c57fb6f863214677bee9a2e46187bcd8 (diff)
downloadports-67107f068113858de0d8876394a83f836b71d7b1.tar.gz
ports-67107f068113858de0d8876394a83f836b71d7b1.zip
lang/seed7: update to 05_20180304
20180304: - In fil_rtl.c and ut8_rlt.c the functions filLineRead, filWordRead, ut8LineRead and ut8WordRead have been improved to use getc_unlocked() instead of getc(). This way the performance of the functions has been improved by a factor of 2 (filLineRead has been measured with gcc and valgrind). - In listutl.c the performance of the function copy_list has been improved by 15% (measured with gcc and valgrind). - In getf.s7i the performance of the function readf has been improved by a factor of 4 (measured with gcc and valgrind). - The functions free_helem and free_hash in hshlib.c have been improved to stop searching for helems as soon as the last helem has been freed. This improves the performance free_hash by 36% (measured with gcc and valgrind). - In fil_rtl.c the function read_and_alloc_stri and filGets have been improved to have less usages of err_info and num_of_chars_read. - In soc_rtl.c the function receive_and_alloc_stri has been improved to have less usages of err_info and better logError messages. - In hsh_rtl.c and hshlib.c the function create_hash has been improved to use memset to initialize empty hash tables. - The functions bstCmp, genericCmp, ptrCmp, rflCmp and typCmp have been improved to use a result variable named signumValue. - Interpreter and compiler have been improved to support the actions ACT_ICONV1, ACT_ICONV3, INT_ICONV1, INT_ICONV3 and REF_HSHLENGTH. - The libraries integer.s7i, bin32.s7i, bin64.s7i, category.s7i and graph.s7i have been improved to use the new primitive actions. - The function boolean(), which converts a string to a boolean value, has been added to boolean.s7i. - The function char(), which converts a string to a char value, has been added to char.s7i. - The function float(), which converts a string to a float value, has been added to float.s7i. - The compiler has been improved to support the actions ACT_GEN and TYP_VARFUNC. - The compiler now uses the function process_call_by_name_expr to create code for loop conditions, loop bodies and other call by name parameters. - The functions process_match and process_inline_param have been added to the compiler. - The compiler has been improved to implement functions, which just call one of the special actions HSH_CONTAINS, HSH_EXCL, HSH_INCL, HSH_KEYS, SET_BASELIT, SET_CONV, SET_ELEM, SET_EXCL, SET_INCL, SET_NOT_ELEM, as inline functions. This allows optimizations for the types set of char and set of string. - The compiler has been improved to optimize the action HSH_CONTAINS, when the hash table is constant. - The compiler optimizations for the actions SET_ELEM and SET_NOT_ELEM have been improved. - A test, that checks for-loops over hash tables, has been added to chkhsh.sd7.
Notes
Notes: svn path=/head/; revision=463636
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/distinfo6
-rw-r--r--lang/seed7/pkg-plist1
3 files changed, 5 insertions, 4 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index bcfd833dc7ce..a1e9bb25e296 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20180107
+DISTVERSION= 05_20180304
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 700ce69d50d7..1fa75fb26673 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515406547
-SHA256 (seed7_05_20180107.tgz) = 4fcd35bdab1f0178822dbe21a91cc10ae5b24cecd5e71b776882ccaffb97540c
-SIZE (seed7_05_20180107.tgz) = 2780835
+TIMESTAMP = 1520239050
+SHA256 (seed7_05_20180304.tgz) = 142444dcce2c4060698d9afb35cda2558edc223d00879c3d07da8f77b2a26a51
+SIZE (seed7_05_20180304.tgz) = 2787759
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index f0569f6a967b..78e139847c6b 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -60,6 +60,7 @@ lib/seed7/lib/comp/fil_act.s7i
lib/seed7/lib/comp/flt_act.s7i
lib/seed7/lib/comp/gkb_act.s7i
lib/seed7/lib/comp/hsh_act.s7i
+lib/seed7/lib/comp/inline.s7i
lib/seed7/lib/comp/int_act.s7i
lib/seed7/lib/comp/itf_act.s7i
lib/seed7/lib/comp/kbd_act.s7i