aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
commit68c2f99c6300bc38a37eb3a8292b562cc2d8952b (patch)
tree0898749bb767b388765958548da12c5b50b3825d /lang
parent031bd55ed2b892d722ffdba72b339be33879e047 (diff)
downloadports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.tar.gz
ports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.zip
Remove do-configure section, use PERL_CONFIGURE now.
Notes
Notes: svn path=/head/; revision=38917
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-Error/Makefile5
-rw-r--r--lang/p5-Expect/Makefile8
-rw-r--r--lang/p5-ExtUtils-F77/Makefile9
-rw-r--r--lang/p5-F77/Makefile9
-rw-r--r--lang/p5-Tcl/Makefile7
-rw-r--r--lang/p5-Tcl/pkg-descr48
-rw-r--r--lang/p5-ePerl/Makefile6
-rw-r--r--lang/p5-ePerl/pkg-message1
8 files changed, 36 insertions, 57 deletions
diff --git a/lang/p5-Error/Makefile b/lang/p5-Error/Makefile
index 54d9fe7bd5d8..aa7ac7f1708e 100644
--- a/lang/p5-Error/Makefile
+++ b/lang/p5-Error/Makefile
@@ -14,12 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pvh@egenetics.com
-USE_PERL5= YES
+PERL_CONFIGURE= YES
MAN3= Error.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/lang/p5-Expect/Makefile b/lang/p5-Expect/Makefile
index fc8bde0c0532..9173a89e4435 100644
--- a/lang/p5-Expect/Makefile
+++ b/lang/p5-Expect/Makefile
@@ -10,8 +10,8 @@ PORTVERSION= 1.07
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Expect
-DISTNAME= ${PORTNAME}.pm-${PORTVERSION}
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}.pm-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -20,11 +20,9 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Tty.pm:${PORTSDIR}/devel/p5-IO-Tty \
RUN_DEPENDS= ${BUILD_DEPENDS}
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+
MAN3= Expect.3 Expect_intro.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/lang/p5-ExtUtils-F77/Makefile b/lang/p5-ExtUtils-F77/Makefile
index 1cbf586f3ae0..b1300ecd0375 100644
--- a/lang/p5-ExtUtils-F77/Makefile
+++ b/lang/p5-ExtUtils-F77/Makefile
@@ -14,23 +14,20 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jmz@FreeBSD.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= ExtUtils::F77.3
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400005
-F2CLIB= -lg2c
+F2CLIB= -lg2c
.else
-F2CLIB= -lf2c
+F2CLIB= -lf2c
.endif
post-patch:
@cd ${WRKSRC}; ${PERL5} -i.orig -pe \
's/(.*Freebsd.*lib )(-lf2c)(.*)/$$1 ${F2CLIB} $$3/' F77.pm
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.post.mk>
diff --git a/lang/p5-F77/Makefile b/lang/p5-F77/Makefile
index 1cbf586f3ae0..b1300ecd0375 100644
--- a/lang/p5-F77/Makefile
+++ b/lang/p5-F77/Makefile
@@ -14,23 +14,20 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jmz@FreeBSD.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= ExtUtils::F77.3
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400005
-F2CLIB= -lg2c
+F2CLIB= -lg2c
.else
-F2CLIB= -lf2c
+F2CLIB= -lf2c
.endif
post-patch:
@cd ${WRKSRC}; ${PERL5} -i.orig -pe \
's/(.*Freebsd.*lib )(-lf2c)(.*)/$$1 ${F2CLIB} $$3/' F77.pm
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.post.mk>
diff --git a/lang/p5-Tcl/Makefile b/lang/p5-Tcl/Makefile
index f4e4cbc30dda..fc2e25fd79d3 100644
--- a/lang/p5-Tcl/Makefile
+++ b/lang/p5-Tcl/Makefile
@@ -16,15 +16,10 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
-USE_PERL5= yes
-
+PERL_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Tcl.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/lang/p5-Tcl/pkg-descr b/lang/p5-Tcl/pkg-descr
index 8e1f32b60d9c..5142825a6362 100644
--- a/lang/p5-Tcl/pkg-descr
+++ b/lang/p5-Tcl/pkg-descr
@@ -1,30 +1,30 @@
- The Tcl extension module gives access to the Tcl library
- with functionality and interface similar to the C
- functions of Tcl. In other words, you can
+The Tcl extension module gives access to the Tcl library
+with functionality and interface similar to the C
+functions of Tcl. In other words, you can
- create Tcl interpreters
- The Tcl interpreters so created are Perl objects
- whose destructors delete the interpreters cleanly
- when appropriate.
+create Tcl interpreters
+ The Tcl interpreters so created are Perl objects
+ whose destructors delete the interpreters cleanly
+ when appropriate.
- execute Tcl code in an interpreter
- The code can come from strings, files or Perl
- filehandles.
+execute Tcl code in an interpreter
+ The code can come from strings, files or Perl
+ filehandles.
- bind in new Tcl procedures
- The new procedures can be either C code (with
- addresses presumably obtained using dl_open and
- dl_find_symbol) or Perl subroutines (by name,
- reference or as anonymous subs). The (optional)
- deleteProc callback in the latter case is another
- perl subroutine which is called when the command
- is explicitly deleted by name or else when the
- destructor for the interpreter object is
- explicitly or implicitly called.
+bind in new Tcl procedures
+ The new procedures can be either C code (with
+ addresses presumably obtained using dl_open and
+ dl_find_symbol) or Perl subroutines (by name,
+ reference or as anonymous subs). The (optional)
+ deleteProc callback in the latter case is another
+ perl subroutine which is called when the command
+ is explicitly deleted by name or else when the
+ destructor for the interpreter object is
+ explicitly or implicitly called.
- Manipulate the result field of a Tcl interpreter
+Manipulate the result field of a Tcl interpreter
- Set and get values of variables in a Tcl interpreter
+Set and get values of variables in a Tcl interpreter
- Tie perl variables to variables in a Tcl interpreter
- The variables can be either scalars or hashes.
+Tie perl variables to variables in a Tcl interpreter
+ The variables can be either scalars or hashes.
diff --git a/lang/p5-ePerl/Makefile b/lang/p5-ePerl/Makefile
index 352cf79a855f..58ae5cfd8d72 100644
--- a/lang/p5-ePerl/Makefile
+++ b/lang/p5-ePerl/Makefile
@@ -17,13 +17,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rse@engelschall.com
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Parse::ePerl.3 Apache::ePerl.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/lang/p5-ePerl/pkg-message b/lang/p5-ePerl/pkg-message
index b82d39eac9e6..9596ee1faefd 100644
--- a/lang/p5-ePerl/pkg-message
+++ b/lang/p5-ePerl/pkg-message
@@ -11,4 +11,3 @@
ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE. See either the Artistic License or the
GNU General Public License for more details.
-