aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 06:01:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 06:01:23 +0000
commit6c9b37352c8ddd6ef4956d50c8b4824f62dafbbd (patch)
treef76d12bf773f042eaf7eab673f322f5c91871fc0 /lang
parent12decc890db291bd07426785ce4f51d5ffd87fc1 (diff)
downloadports-6c9b37352c8ddd6ef4956d50c8b4824f62dafbbd.tar.gz
ports-6c9b37352c8ddd6ef4956d50c8b4824f62dafbbd.zip
add mdk
MIX Development Kit offers an emulation of MIX and MIXAL
Notes
Notes: svn path=/head/; revision=40716
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/mdk/Makefile33
-rw-r--r--lang/mdk/distinfo1
-rw-r--r--lang/mdk/pkg-comment1
-rw-r--r--lang/mdk/pkg-descr22
-rw-r--r--lang/mdk/pkg-plist9
6 files changed, 67 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index e65223c45cdf..5f41d5108144 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -61,6 +61,7 @@
SUBDIR += lua
SUBDIR += m3gdb
SUBDIR += mawk
+ SUBDIR += mdk
SUBDIR += mit-scheme
SUBDIR += mixal
SUBDIR += mmix
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
new file mode 100644
index 000000000000..896876b4b24d
--- /dev/null
+++ b/lang/mdk/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: mdk
+# Date created: Apr 1, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdk
+PORTVERSION= 0.3
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ intl.1:${PORTSDIR}/devel/gettext
+# glade.4:${PORTSDIR}/devel/libglade
+
+# gui depends on some GNU specific stdio function, so disable it first :<
+# I've contacted the author for help
+USE_GLIB= yes
+#USE_GTK= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-gui
+
+USE_GMAKE= yes
+MAKE_ARGS= LDFLAGS="${CFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
+
+.include <bsd.port.mk>
diff --git a/lang/mdk/distinfo b/lang/mdk/distinfo
new file mode 100644
index 000000000000..0bd63a09f83a
--- /dev/null
+++ b/lang/mdk/distinfo
@@ -0,0 +1 @@
+MD5 (mdk-0.3.tar.gz) = 4f5620531fea03fcf07fcc93f677a829
diff --git a/lang/mdk/pkg-comment b/lang/mdk/pkg-comment
new file mode 100644
index 000000000000..0da39a6ea9e4
--- /dev/null
+++ b/lang/mdk/pkg-comment
@@ -0,0 +1 @@
+MIX Development Kit offers an emulation of MIX and MIXAL
diff --git a/lang/mdk/pkg-descr b/lang/mdk/pkg-descr
new file mode 100644
index 000000000000..0b9e0fdabf96
--- /dev/null
+++ b/lang/mdk/pkg-descr
@@ -0,0 +1,22 @@
+MIX is Donald Knuth's mythical computer as described in his monumental work
+The Art Of Computer Programming. As any of its real counterparts, the MIX
+features registers, memory cells, an overflow toggle, comparison flags,
+input-output devices, and a set of binary instructions executable by its
+virtual CPU. You can programme the MIX using an assembly language called
+MIXAL, the MIX Assembly Language.
+
+The MIX Development Kit offers an emulation of MIX and MIXAL. The current
+version of MDK includes the following applications:
+
+ - mixasm A MIXAL compiler, which translates your source files into binary
+ ones, executable by the MIX virtual machine.
+ - mixvm A MIX virtual machine which is able to run and debug compiled MIXAL
+ programs, using a command line interface with readline's line editting
+ capabilities.
+ - gmixvm A MIX virtual machine with a GTK+ GUI which allows you running and
+ debugging your MIXAL programs through a nice graphical interface.
+ - mixvm.el An elisp program which allows you to run mixvm within an Emacs
+ GUD window, simultaneously viewing your MIXAL source file in another
+ buffer.
+
+WWW: http://www.gnu.org/software/mdk/mdk.html
diff --git a/lang/mdk/pkg-plist b/lang/mdk/pkg-plist
new file mode 100644
index 000000000000..4dfa09d1d27f
--- /dev/null
+++ b/lang/mdk/pkg-plist
@@ -0,0 +1,9 @@
+bin/mixasm
+bin/mixvm
+@unexec install-info --delete %D/info/mdk.info %D/info/dir
+info/mdk.info
+info/mdk.info-1
+info/mdk.info-2
+info/mdk.info-3
+@exec install-info %D/info/mdk.info %D/info/dir
+@dirrm share/mdk