aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-16 02:22:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-16 02:31:01 +0000
commit6df793d336dc6713ffba527e0cd64057ed5a9047 (patch)
tree329a866e4097c9dec4aea5622c119cc0f21f1f35 /lang
parent490f8b7fd84a1cdaf20bceba5dcdd95ad079d17c (diff)
downloadports-6df793d336dc6713ffba527e0cd64057ed5a9047.tar.gz
ports-6df793d336dc6713ffba527e0cd64057ed5a9047.zip
lang/erlang-runtime22: Fix build with openssl3
- Utilize USES=localbase Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime22/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/lang/erlang-runtime22/Makefile b/lang/erlang-runtime22/Makefile
index b0dfa5cc9a11..6b88067471f1 100644
--- a/lang/erlang-runtime22/Makefile
+++ b/lang/erlang-runtime22/Makefile
@@ -78,13 +78,10 @@ KQUEUE_CONFIGURE_ENABLE= kernel-poll
NATIVE_IMPLIES= HIPE
NATIVE_CONFIGURE_ENABLE= native-libs
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+ODBC_USES= localbase:ldflags
ODBC_CONFIGURE_WITH= odbc
-ODBC_CFLAGS= -I/usr/local/include
-ODBC_LDFLAGS= -L/usr/local/lib
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
-OPENSSL_VARS= BROKEN_SSL="openssl30 openssl31" \
- BROKEN_SSL_REASON="Cannot find function FIPS_mode"
SCTP_CONFIGURE_ENABLE= sctp
THREADS_CONFIGURE_ENABLE= threads
WX_USES= gl
@@ -112,6 +109,11 @@ MAKE_ARGS+= ARCH=x86
MAKE_ARGS+= ARCH=arm
.endif
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
+CFLAGS+= -Wno-error=implicit-function-declaration
+OPTIONS_EXCLUDE= OPENSSL
+.endif
+
pre-configure:
@cd ${WRKSRC} && ./otp_build autoconf