aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-29 13:30:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-29 13:30:22 +0000
commit70ef86a88171c91fac000f4c4c14cda5fb31ed98 (patch)
treeb68accf3408d3e94b7c583db66238c82c75e40f5 /lang
parent6bb8e4ec42dc25991f62866a59c8c097ccfcffd3 (diff)
downloadports-70ef86a88171c91fac000f4c4c14cda5fb31ed98.tar.gz
ports-70ef86a88171c91fac000f4c4c14cda5fb31ed98.zip
Stagify, remove check for alpha (long unsupported), convert to OptionsNG,
drop seemingly unused USE_GMAKE, and generally cleanup the port while here.
Notes
Notes: svn path=/head/; revision=341735
Diffstat (limited to 'lang')
-rw-r--r--lang/pnetlib/Makefile36
1 files changed, 12 insertions, 24 deletions
diff --git a/lang/pnetlib/Makefile b/lang/pnetlib/Makefile
index 79ffa8e44ca8..b49450c22387 100644
--- a/lang/pnetlib/Makefile
+++ b/lang/pnetlib/Makefile
@@ -14,37 +14,25 @@ COMMENT= C\# system library for pnet
BUILD_DEPENDS= cscc:${PORTSDIR}/lang/pnet-base \
treecc:${PORTSDIR}/lang/treecc
-.if !defined(WITHOUT_X11)
-USE_XLIB= yes
-.endif
-
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
USE_LDCONFIG= yes
PORTDOCS= ChangeLog-1 ChangeLog-2 ChangeLog-3 ChangeLog-4 \
- JScript-embed.txt JScript-internals.txt csunit_howto.html \
- pcf-font-format.txt translating-pnetlib.txt
-
-NO_STAGE= yes
-.include "${.CURDIR}/../pnet/Makefile.pnet"
-.include <bsd.port.pre.mk>
+ JScript-embed.txt JScript-internals.txt csunit_howto.html \
+ pcf-font-format.txt translating-pnetlib.txt
-.if ${ARCH} == "alpha"
-IGNORE= coredump during build on alpha
-.endif
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+X11_USE= XORG=x11
post-patch:
- @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} \
+ $$ac_aux_dir|$$ac_aux_dir|' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for docfile in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${docfile} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.mk>