aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 19:47:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 19:59:24 +0000
commit75ea65ec16edf992f78f4a367f56b4b9ce586bc1 (patch)
treef3fc851f193e49c0a28556afeb0b2c75299092b3 /lang
parent6557ba831b22bf3b366f4ed86db40bc23166c98d (diff)
downloadports-75ea65ec16edf992f78f4a367f56b4b9ce586bc1.tar.gz
ports-75ea65ec16edf992f78f4a367f56b4b9ce586bc1.zip
lang/ocaml-camlidl: Fix build with llvm15
Approved by: portmgr (blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/ocaml-camlidl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/ocaml-camlidl/Makefile b/lang/ocaml-camlidl/Makefile
index 7c64863229c3..2773138b45d1 100644
--- a/lang/ocaml-camlidl/Makefile
+++ b/lang/ocaml-camlidl/Makefile
@@ -24,6 +24,12 @@ DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-extract:
@${REINPLACE_CMD} -e "s,^\(OCAMLLIB=\).*,\1${STAGEDIR}${PREFIX}/lib/ocaml,g" \
-e "s,^\(BINDIR=\).*,\1${STAGEDIR}${PREFIX}/bin,g" \
@@ -56,4 +62,4 @@ test:
${WRKSRC}/tests/Makefile
cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE} all
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>