aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 05:36:35 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 06:57:12 +0000
commit7ee8c74b4662b389fc775cf60cd0a07dce400804 (patch)
tree31ca9f3ba660f7a3efcc37a6bf0c2b3eeca26b29 /lang
parenta5b5a22ade5713b3b2f9bddcb6fa95fe4aa51b9c (diff)
downloadports-7ee8c74b4662b389fc775cf60cd0a07dce400804.tar.gz
ports-7ee8c74b4662b389fc775cf60cd0a07dce400804.zip
lang/spidermonkey91: Fix build on 14
For now this is not the ideal solution. Not sure why there is a check for llvm version 80. So not touching that part of the code at the moment. This will require further investigation later. Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'lang')
-rw-r--r--lang/spidermonkey91/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/lang/spidermonkey91/Makefile b/lang/spidermonkey91/Makefile
index a89a1d87b963..99403056b15b 100644
--- a/lang/spidermonkey91/Makefile
+++ b/lang/spidermonkey91/Makefile
@@ -52,6 +52,17 @@ CONFIGURE_ENV= HOST_CC=${CC} \
BINARY_ALIAS= python3=${PYTHON_CMD}
PLIST_SUB= SP_VER=${SP_VER}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=15
+CC= clang${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+CONFIGURE_ENV+= LLVM_CONFIG=llvm-config${LLVM_VERSION} \
+ LLVM_OBJDUMP=llvm-objdump${LLVM_VERSION}
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64