aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-07 07:20:02 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-07 07:25:09 +0000
commit8932e251e160047041455cba6c1d22cd591b6d27 (patch)
tree9c7eecece5fffec67625b58078b20b48ec9c143b /lang
parentb126b7e0150ac4bb626aa4aefab4dcac403caacd (diff)
downloadports-8932e251e160047041455cba6c1d22cd591b6d27.tar.gz
ports-8932e251e160047041455cba6c1d22cd591b6d27.zip
lang/nesasm: Fix build with llvm15
- Add LICENSE NONE - Pet portclippy Approved by: portmgr (blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/nesasm/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/lang/nesasm/Makefile b/lang/nesasm/Makefile
index 83a6d9b559d1..e7b6127085a1 100644
--- a/lang/nesasm/Makefile
+++ b/lang/nesasm/Makefile
@@ -9,11 +9,20 @@ MAINTAINER= ninjin@kth.se
COMMENT= 6502 assembler with specific NES support
WWW= https://bobrost.com/nes/resources.php
-WRKSRC= ${WRKDIR}/nbasic_2004_03_14/source/${PORTNAME}/source/
+LICENSE= NONE
+
USES= zip
+WRKSRC= ${WRKDIR}/nbasic_2004_03_14/source/${PORTNAME}/source/
+
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} -e '/^CC/s/=/?=/' \
-e '/^CFLAGS/{s/=/+=/;s/-O2//;}' \
@@ -26,4 +35,4 @@ do-install:
# The next install will overwrite readme.txt with a newer readme.txt
${INSTALL_DATA} ${WRKSRC}../readme.txt ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>