aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /lang
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'lang')
-rw-r--r--lang/php56/Makefile.ext2
-rw-r--r--lang/php70/Makefile.ext2
-rw-r--r--lang/php71/Makefile.ext2
-rw-r--r--lang/php72/Makefile.ext2
4 files changed, 4 insertions, 4 deletions
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index ff53ae0f2848..612bd060453c 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -1,6 +1,6 @@
COMMENT= The ${PHP_MODNAME} shared extension for php
-USES+= php:ext
+USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 56
IGNORE_WITH_PHP= 70
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index ee5ca6692d4d..0983dfe908fe 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -2,7 +2,7 @@
COMMENT= The ${PHP_MODNAME} shared extension for php
-USES+= php:ext
+USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 70
IGNORE_WITH_PHP= 56
diff --git a/lang/php71/Makefile.ext b/lang/php71/Makefile.ext
index fabe0694ef25..dc60a841413f 100644
--- a/lang/php71/Makefile.ext
+++ b/lang/php71/Makefile.ext
@@ -2,7 +2,7 @@
COMMENT= The ${PHP_MODNAME} shared extension for php
-USES+= php:ext
+USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 71
IGNORE_WITH_PHP= 55 56 70
diff --git a/lang/php72/Makefile.ext b/lang/php72/Makefile.ext
index 08aae1a16d01..de51747412ae 100644
--- a/lang/php72/Makefile.ext
+++ b/lang/php72/Makefile.ext
@@ -2,7 +2,7 @@
COMMENT= The ${PHP_MODNAME} shared extension for php
-USES+= php:ext
+USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 72
IGNORE_WITH_PHP= 56 70 71