aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-06 21:02:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-06 21:02:44 +0000
commitadc606fcba90c48304a1b6dcb74ef9ef32684483 (patch)
tree1b6684e840d254a5f8bb785add9703a4b3b03739 /lang
parentbcc3c4a4163296cc91ea12e023fff7f3dfbbec11 (diff)
downloadports-adc606fcba90c48304a1b6dcb74ef9ef32684483.tar.gz
ports-adc606fcba90c48304a1b6dcb74ef9ef32684483.zip
- Support USE_GETOPT_LONG
- Support WITHOUT_NLS PR: ports/65262 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=106351
Diffstat (limited to 'lang')
-rw-r--r--lang/open-cobol-devel/Makefile15
-rw-r--r--lang/open-cobol-devel/files/patch-cobc::cobc.c11
-rw-r--r--lang/open-cobol-devel/files/patch-lib::Makefile.in20
-rw-r--r--lang/open-cobol-devel/pkg-plist2
-rw-r--r--lang/open-cobol/Makefile15
-rw-r--r--lang/open-cobol/files/patch-cobc::cobc.c11
-rw-r--r--lang/open-cobol/files/patch-lib::Makefile.in20
-rw-r--r--lang/open-cobol/pkg-plist2
8 files changed, 90 insertions, 6 deletions
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index eed96f2680bd..1dee18e1a35c 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -19,14 +19,25 @@ COMMENT= An open-source COBOL compiler
LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
gmp.6:${PORTSDIR}/math/libgmp4
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-readline
INSTALLS_SHLIB= yes
INFO= open-cobol
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
+LDFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.endif
.include <bsd.port.mk>
diff --git a/lang/open-cobol-devel/files/patch-cobc::cobc.c b/lang/open-cobol-devel/files/patch-cobc::cobc.c
new file mode 100644
index 000000000000..d1809c280868
--- /dev/null
+++ b/lang/open-cobol-devel/files/patch-cobc::cobc.c
@@ -0,0 +1,11 @@
+--- cobc/cobc.c.orig Thu Jun 5 09:02:15 2003
++++ cobc/cobc.c Sun Apr 4 00:32:21 2004
+@@ -36,7 +36,7 @@
+
+ #include "cobc.h"
+ #include "tree.h"
+-#include "lib/getopt.h"
++#include <getopt.h>
+
+
+ /*
diff --git a/lang/open-cobol-devel/files/patch-lib::Makefile.in b/lang/open-cobol-devel/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..56255ffbdb28
--- /dev/null
+++ b/lang/open-cobol-devel/files/patch-lib::Makefile.in
@@ -0,0 +1,20 @@
+--- lib/Makefile.in.orig Thu Jun 12 05:13:50 2003
++++ lib/Makefile.in Sun Apr 4 00:28:58 2004
+@@ -175,7 +175,7 @@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/config/depcomp
+ am__depfiles_maybe = depfiles
+-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
++@AMDEP_TRUE@DEP_FILES = \
+ @AMDEP_TRUE@ $(DEPDIR)/malloc.Po $(DEPDIR)/memcmp.Po \
+ @AMDEP_TRUE@ $(DEPDIR)/realloc.Po
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+@@ -215,8 +215,6 @@
+ distclean-compile:
+ -rm -f *.tab.c
+
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/memcmp.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Po@am__quote@
diff --git a/lang/open-cobol-devel/pkg-plist b/lang/open-cobol-devel/pkg-plist
index 2538f8f15a2e..630de4906766 100644
--- a/lang/open-cobol-devel/pkg-plist
+++ b/lang/open-cobol-devel/pkg-plist
@@ -14,5 +14,5 @@ include/libcob/termio.h
lib/libcob.a
lib/libcob.so
lib/libcob.so.1
-share/locale/ja/LC_MESSAGES/open-cobol.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
@dirrm include/libcob
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index eed96f2680bd..1dee18e1a35c 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -19,14 +19,25 @@ COMMENT= An open-source COBOL compiler
LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
gmp.6:${PORTSDIR}/math/libgmp4
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-readline
INSTALLS_SHLIB= yes
INFO= open-cobol
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
+LDFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.endif
.include <bsd.port.mk>
diff --git a/lang/open-cobol/files/patch-cobc::cobc.c b/lang/open-cobol/files/patch-cobc::cobc.c
new file mode 100644
index 000000000000..d1809c280868
--- /dev/null
+++ b/lang/open-cobol/files/patch-cobc::cobc.c
@@ -0,0 +1,11 @@
+--- cobc/cobc.c.orig Thu Jun 5 09:02:15 2003
++++ cobc/cobc.c Sun Apr 4 00:32:21 2004
+@@ -36,7 +36,7 @@
+
+ #include "cobc.h"
+ #include "tree.h"
+-#include "lib/getopt.h"
++#include <getopt.h>
+
+
+ /*
diff --git a/lang/open-cobol/files/patch-lib::Makefile.in b/lang/open-cobol/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..56255ffbdb28
--- /dev/null
+++ b/lang/open-cobol/files/patch-lib::Makefile.in
@@ -0,0 +1,20 @@
+--- lib/Makefile.in.orig Thu Jun 12 05:13:50 2003
++++ lib/Makefile.in Sun Apr 4 00:28:58 2004
+@@ -175,7 +175,7 @@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/config/depcomp
+ am__depfiles_maybe = depfiles
+-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
++@AMDEP_TRUE@DEP_FILES = \
+ @AMDEP_TRUE@ $(DEPDIR)/malloc.Po $(DEPDIR)/memcmp.Po \
+ @AMDEP_TRUE@ $(DEPDIR)/realloc.Po
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+@@ -215,8 +215,6 @@
+ distclean-compile:
+ -rm -f *.tab.c
+
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/memcmp.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Po@am__quote@
diff --git a/lang/open-cobol/pkg-plist b/lang/open-cobol/pkg-plist
index 2538f8f15a2e..630de4906766 100644
--- a/lang/open-cobol/pkg-plist
+++ b/lang/open-cobol/pkg-plist
@@ -14,5 +14,5 @@ include/libcob/termio.h
lib/libcob.a
lib/libcob.so
lib/libcob.so.1
-share/locale/ja/LC_MESSAGES/open-cobol.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
@dirrm include/libcob