aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-05-07 16:13:10 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-05-07 16:13:10 +0000
commitb79f8d86020d75dda684910737d1bf9f12fde86d (patch)
treee38b242d33803b3b20a9c7c307b0033ae11b6d11 /lang
parenta2b13dc61a6bc6bbedd6e7d986d3185e7c05ed47 (diff)
downloadports-b79f8d86020d75dda684910737d1bf9f12fde86d.tar.gz
ports-b79f8d86020d75dda684910737d1bf9f12fde86d.zip
- Move lang/open-cobol to lang/gnu-cobol to reflect project changes
- Adopt port
Notes
Notes: svn path=/head/; revision=353174
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile2
-rw-r--r--lang/gnu-cobol/Makefile33
-rw-r--r--lang/gnu-cobol/distinfo2
-rw-r--r--lang/gnu-cobol/pkg-descr4
-rw-r--r--lang/gnu-cobol/pkg-plist (renamed from lang/open-cobol/pkg-plist)21
-rw-r--r--lang/open-cobol/Makefile45
-rw-r--r--lang/open-cobol/distinfo2
-rw-r--r--lang/open-cobol/pkg-descr4
8 files changed, 48 insertions, 65 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c73b622f27b7..5ff7da2f2f9c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gnatdroid-armv7
SUBDIR += gnatdroid-binutils
SUBDIR += gnatdroid-sysroot
+ SUBDIR += gnu-cobol
SUBDIR += gnustep-base
SUBDIR += gnustep-guile
SUBDIR += go
@@ -192,7 +193,6 @@
SUBDIR += onyx
SUBDIR += oo2c
SUBDIR += oorexx
- SUBDIR += open-cobol
SUBDIR += opendylan
SUBDIR += otcl
SUBDIR += p2c
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
new file mode 100644
index 000000000000..74d1c102010e
--- /dev/null
+++ b/lang/gnu-cobol/Makefile
@@ -0,0 +1,33 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= gnu-cobol
+PORTVERSION= 1.1
+CATEGORIES= lang
+MASTER_SITES= GNU/gnucobol
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Open-source COBOL compiler
+
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+
+USE_BDB= yes
+USES= gmake libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+INFO= gnu-cobol
+
+CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+CONFIGURE_ENABLE=nls
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
+ s|db-4.[0-9]|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/lang/gnu-cobol/distinfo b/lang/gnu-cobol/distinfo
new file mode 100644
index 000000000000..0956b57975c7
--- /dev/null
+++ b/lang/gnu-cobol/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnu-cobol-1.1.tar.gz) = bd319c0d001e85835c8501ad74c9de0052fe82b8a38b4530f41b49b2af028b9d
+SIZE (gnu-cobol-1.1.tar.gz) = 1093343
diff --git a/lang/gnu-cobol/pkg-descr b/lang/gnu-cobol/pkg-descr
new file mode 100644
index 000000000000..546133868739
--- /dev/null
+++ b/lang/gnu-cobol/pkg-descr
@@ -0,0 +1,4 @@
+GNU COBOL, formerly known as Open-COBOL, is an open-source COBOL compiler,
+which translates COBOL programs to C code and compiles it using GCC.
+
+WWW: http://savannah.gnu.org/projects/gnucobol
diff --git a/lang/open-cobol/pkg-plist b/lang/gnu-cobol/pkg-plist
index 6c2c539229a4..b863b048f9bf 100644
--- a/lang/open-cobol/pkg-plist
+++ b/lang/gnu-cobol/pkg-plist
@@ -2,24 +2,15 @@ bin/cob-config
bin/cobc
bin/cobcrun
include/libcob.h
-include/libcob/byteswap.h
-include/libcob/call.h
include/libcob/codegen.h
include/libcob/common.h
include/libcob/exception.def
-include/libcob/fileio.h
-include/libcob/intrinsic.h
-include/libcob/move.h
-include/libcob/numeric.h
-include/libcob/screenio.h
-include/libcob/strings.h
include/libcob/system.def
-include/libcob/termio.h
+lib/gnu-cobol/CBL_OC_DUMP.so
lib/libcob.a
-lib/libcob.la
lib/libcob.so
lib/libcob.so.1
-%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
+lib/libcob.so.1.0.0
%%DATADIR%%/config/bs2000.conf
%%DATADIR%%/config/cobol2002.conf
%%DATADIR%%/config/cobol85.conf
@@ -28,7 +19,11 @@ lib/libcob.so.1
%%DATADIR%%/config/mf.conf
%%DATADIR%%/config/mvs.conf
%%DATADIR%%/copy/screenio.cpy
-@dirrm %%DATADIR%%/copy
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnu-cobol.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/gnu-cobol.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gnu-cobol.mo
+@dirrm include/libcob
+@dirrm lib/gnu-cobol
@dirrm %%DATADIR%%/config
+@dirrm %%DATADIR%%/copy
@dirrm %%DATADIR%%
-@dirrm include/libcob
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
deleted file mode 100644
index 058cf7cb9d93..000000000000
--- a/lang/open-cobol/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# Created by: ijliao
-# $FreeBSD$
-
-PORTNAME= open-cobol
-PORTVERSION= 1.1
-CATEGORIES= lang
-MASTER_SITES= SF
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An open-source COBOL compiler
-
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
-
-USE_BDB= yes
-USES= gmake
-USE_AUTOTOOLS= libtool
-USE_LDCONFIG= yes
-
-INFO= open-cobol
-
-CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
- s|db-4.[0-9]|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
-
-.if defined(MAINTAINER_MODE)
-test: build
- (cd ${WRKSRC}/tests; \
- ./syntax; \
- ./run)
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/open-cobol/distinfo b/lang/open-cobol/distinfo
deleted file mode 100644
index cd64ef4ff362..000000000000
--- a/lang/open-cobol/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (open-cobol-1.1.tar.gz) = 6ae7c02eb8622c4ad55097990e9b1688a151254407943f246631d02655aec320
-SIZE (open-cobol-1.1.tar.gz) = 1007791
diff --git a/lang/open-cobol/pkg-descr b/lang/open-cobol/pkg-descr
deleted file mode 100644
index a4d7b9050228..000000000000
--- a/lang/open-cobol/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-OpenCOBOL is an open-source COBOL compiler, which translates COBOL programs
-to C code and compiles it using GCC.
-
-WWW: http://www.opencobol.org/