aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-02-28 10:53:52 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-02-28 10:53:52 +0000
commitbcd35d031ea8f5e726a6ca0f912a355e3962b792 (patch)
tree8f9cd0ffd23ee09512bb25945896867899a0b063 /lang
parentdda67e8ed60f1f40b00e1291504a7d6b38ea0dfd (diff)
downloadports-bcd35d031ea8f5e726a6ca0f912a355e3962b792.tar.gz
ports-bcd35d031ea8f5e726a6ca0f912a355e3962b792.zip
devel/hugs: workaround to fix build on current
runhugs binary crashes when compiled with -O2 on i386 12-CURRENT system. Workaround it by compiling with -O0 Submitted by: Gleb Popov <6yearold_gmail.com> Differential Revision: https://reviews.freebsd.org/D14187
Notes
Notes: svn path=/head/; revision=463193
Diffstat (limited to 'lang')
-rw-r--r--lang/hugs/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 87bcaa991664..edadcb6bca80 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ARGS+= --with-pthreads
USE_GL= glut
USE_XORG= sm ice xmu xi x11
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386 && ${OSVERSION} > 1200000
+CFLAGS+= -O0
+.endif
+
post-patch:
@${REINPLACE_CMD} 's/LIBS/LIBRARIES/' ${WRKSRC}/libraries/Makefile.in
@${REINPLACE_CMD} -e '/^install :: install_notes/d ; \
@@ -53,4 +59,4 @@ do-install:
cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
. endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>