aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-11-30 06:13:34 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-11-30 06:13:34 +0000
commitbf43557044604cb6487fc1aa24ce2c210ae789da (patch)
tree10dd7508accfa6a3ffc8e631ba63a22cc2fdeb6b /lang
parente3b0bf80d1a7a3579b4284ef20edfdcdcefac2a7 (diff)
downloadports-bf43557044604cb6487fc1aa24ce2c210ae789da.tar.gz
ports-bf43557044604cb6487fc1aa24ce2c210ae789da.zip
For ports that are marked BROKEN on armv6, and also fail to build on
armv7, mark them so. This is part two of a multipart commit to bring armv7 ports to parity with armv6. Approved by: portmgr (tier-2 blanket) Obtained from: lonesome.com -exp run
Notes
Notes: svn path=/head/; revision=455167
Diffstat (limited to 'lang')
-rw-r--r--lang/abcl/Makefile1
-rw-r--r--lang/afnix/Makefile1
-rw-r--r--lang/cling/Makefile1
-rw-r--r--lang/dmd2/Makefile1
-rw-r--r--lang/gauche/Makefile1
-rw-r--r--lang/hugs/Makefile1
-rw-r--r--lang/io/Makefile1
-rw-r--r--lang/ldc/Makefile1
-rw-r--r--lang/micropython/Makefile1
-rw-r--r--lang/mosh/Makefile1
-rw-r--r--lang/nim/Makefile1
-rw-r--r--lang/onyx/Makefile1
-rw-r--r--lang/pfe/Makefile1
-rw-r--r--lang/qore/Makefile1
-rw-r--r--lang/rexx-imc/Makefile1
-rw-r--r--lang/rexx-regina/Makefile1
-rw-r--r--lang/scm/Makefile1
-rw-r--r--lang/see/Makefile1
-rw-r--r--lang/siod/Makefile1
-rw-r--r--lang/spidermonkey17/Makefile1
20 files changed, 20 insertions, 0 deletions
diff --git a/lang/abcl/Makefile b/lang/abcl/Makefile
index 735f31abe7d1..b4e160bc8bc5 100644
--- a/lang/abcl/Makefile
+++ b/lang/abcl/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Implementation of ANSI Common Lisp in Java
BROKEN_armv6= fails to build: build.xml: Java returned: 1
+BROKEN_armv7= fails to build: build.xml: Java returned: 1
PLIST_FILES= share/java/classes/abcl.jar \
share/java/classes/abcl-contrib.jar \
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 2e1658720ad3..97956a55956e 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Multi-threaded functional programming language
BROKEN_armv6= fails to compile: operator new takes type size_t as first parameterk/er
+BROKEN_armv7= fails to compile: operator new takes type size_t as first parameterk/er
BROKEN_i386= fails to build
BROKEN_powerpc= fails to configure
BROKEN_powerpc64= fails to build: afnix-setup: cannot determine linking type
diff --git a/lang/cling/Makefile b/lang/cling/Makefile
index 1449918ae40b..3ef40e83a25a 100644
--- a/lang/cling/Makefile
+++ b/lang/cling/Makefile
@@ -19,6 +19,7 @@ LICENSE_FILE_NCSA= ${WRKSRC}/tools/cling/LICENSE.TXT
LICENSE_PERMS_LLVM= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_armv6= fails to compile: AArch64TargetMachine.cpp: relocation truncated to fit: R_ARM_CALL against symbol '__aeabi_uldivmod'
+BROKEN_armv7= fails to compile: AArch64TargetMachine.cpp: relocation truncated to fit: R_ARM_CALL against symbol '__aeabi_uldivmod'
BROKEN_powerpc64= fails to compile: IncrementalParser.cpp: 'to_string' is not a member of 'std'
WRKSRC= ${WRKDIR}/src
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index 80889cba782f..b019c3036d0d 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE_DMD= ${WRKSRC}/dmd/src/backendlicense.txt
LICENSE_PERMS_DMD= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
BROKEN_armv6= dumps core: Assertion failed: (!signbit(Port::ldbl_nan)), function PortInitializer, file port.c
+BROKEN_armv7= dumps core: Assertion failed: (!signbit(Port::ldbl_nan)), function PortInitializer, file port.c
BROKEN_mips64= fails to compile: cc1: unrecognized command line option -m32
BROKEN_powerpc64= fails to build: can't mangle function with unknown linkage (void*())
BROKEN_sparc64= fails to install: divide-by-zero error
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 19bc88c687c0..8ffa9a99d774 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -16,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_armv6= Fails to build: unknown attribute __alloc_size__; also fails in assembler
+BROKEN_armv7= Fails to build: unknown attribute __alloc_size__; also fails in assembler
BROKEN_mips= Fails to build: redefinition of GC_register_dynamic_libraries
BROKEN_mips64= Fails to build: redefinition of GC_register_dynamic_libraries
BROKEN_sparc64= Fails to build: do not know how to make sparc_mach_dep.lo
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 0b82f2a64c4c..87bcaa991664 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -14,6 +14,7 @@ COMMENT= Interpreter for the functional programming language Haskell 98
BUILD_DEPENDS= bash:shells/bash
BROKEN_armv6= fails to compile: cppinput.c: invalid preprocessing directive \#!
+BROKEN_armv7= fails to compile: cppinput.c: invalid preprocessing directive \#!
BROKEN_powerpc64= fails to compile: cppinput.c: detected recursion whilst expanding macro "vector"
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/lang/io/Makefile b/lang/io/Makefile
index c241d4197995..ca0b06821854 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -12,6 +12,7 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD3CLAUSE
BROKEN_armv6= fails to compile: ucontext.h: expected parameter declarator
+BROKEN_armv7= fails to compile: Coro.c:392:2: no member named 'arm_r0' in 'mcontext_t'
USES= cmake:outsource,noninja compiler:c11 ssl
diff --git a/lang/ldc/Makefile b/lang/ldc/Makefile
index 98aaf7e0e835..6a3c7f012ab7 100644
--- a/lang/ldc/Makefile
+++ b/lang/ldc/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libconfig.so:devel/libconfig
BROKEN_aarch64= fails to compile: Error: undefined identifier _jmp_buf, did you mean alias jmp_buf?
BROKEN_armv6= fails to compile: Error: undefined identifier _jmp_buf, did you mean alias jmp_buf?
+BROKEN_armv7= fails to compile: Error: undefined identifier _jmp_buf, did you mean alias jmp_buf?
BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
USES= cmake
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index 50e34f350abe..4752d6038bb6 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -20,6 +20,7 @@ USE_GITHUB= yes
PLIST_FILES= bin/micropython
BROKEN_armv6= fails to assemble: error: invalid operand for instruction
+BROKEN_armv7= fails to assemble: error: invalid operand for instruction
WRKSRC_SUBDIR= unix
diff --git a/lang/mosh/Makefile b/lang/mosh/Makefile
index b517aa848dab..64f446110ca7 100644
--- a/lang/mosh/Makefile
+++ b/lang/mosh/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libonig.so:devel/oniguruma
BROKEN_armv6= fails to link: os_dep.c: undefined reference to '__stack_base__'
+BROKEN_armv7= fails to link: os_dep.c: undefined reference to '__stack_base__'
BROKEN_mips64= fails to compile: os_dep.c: redefinition of 'GC_register_dynamic_libraries'
NOT_FOR_ARCHS= aarch64
NOT_FOR_ARCHS_REASON= gcconfig.h: the collector has not been ported to this machine/OS combination
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 3c3c14063199..e1b0e0c8f103 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
BROKEN_aarch64= fails to compile: crt1.c: undefined reference to main
BROKEN_armv6= fails to compile: crt1.c: undefined reference to main
+BROKEN_armv7= fails to compile: crt1.c: undefined reference to main
BROKEN_mips64= fails to build: build.sh: clang: not found
BROKEN_powerpc64= fails to build: build.sh: clang: not found
BROKEN_sparc64= fails to build: build.sh: clang: not found
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 906ce8d330cd..bf0fab9dba7f 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS= cook:devel/cook
LIB_DEPENDS= libpcre.so:devel/pcre
BROKEN_armv6= fails to compile: building for onyx-5.1.2_6: error code 1
+BROKEN_armv7= fails to compile: building for onyx-5.1.2_6: error code 1
BROKEN_mips= fails to compile: building for onyx-5.1.2_6: error code 1
BROKEN_mips64= fails to compile: building for onyx-5.1.2_6: error code 1
diff --git a/lang/pfe/Makefile b/lang/pfe/Makefile
index a855326517e0..a9a59e8ec302 100644
--- a/lang/pfe/Makefile
+++ b/lang/pfe/Makefile
@@ -12,6 +12,7 @@ COMMENT= Implementation of ANSI Forth
BROKEN_aarch64= fails to compile: implicit declaration of function 'PFE_SBR_COMPILE_EXIT' is invalid in C99
BROKEN_armv6= fails to compile: implicit declaration of function 'PFE_SBR_COMPILE_EXIT' is invalid in C99
+BROKEN_armv7= fails to compile: implicit declaration of function 'PFE_SBR_COMPILE_EXIT' is invalid in C99
BROKEN_i386= fails to link
BROKEN_powerpc= fails to compile
BROKEN_powerpc64= fails to build: lvalue required as increment operand
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index 0086d699edfe..ff8c8bd1628e 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/bin/bash:shells/bash
BROKEN_armv6= fails to compile: calling a private constructor of class 'ReferenceNode'
+BROKEN_armv7= fails to compile: calling a private constructor of class 'ReferenceNode'
BROKEN_powerpc= fails to build
BROKEN_powerpc64= fails to compile: unsupported relocation against r1
diff --git a/lang/rexx-imc/Makefile b/lang/rexx-imc/Makefile
index 70b96ab9d59f..5bf6c2dd0ecb 100644
--- a/lang/rexx-imc/Makefile
+++ b/lang/rexx-imc/Makefile
@@ -14,6 +14,7 @@ COMMENT= Procedural programming language designed by IBM's UK Laboratories
CONFLICTS= rexx-regina-* oorexx-[0-9]*
BROKEN_armv6= fails to link: /nxb-bin/usr/bin/ld: hidden symbol __aeabi_uidivmod in libgcc.a is referenced by DSO
+BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: hidden symbol __aeabi_uidivmod in libgcc.a is referenced by DSO
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Make
diff --git a/lang/rexx-regina/Makefile b/lang/rexx-regina/Makefile
index c34314b1de6e..1652788df86d 100644
--- a/lang/rexx-regina/Makefile
+++ b/lang/rexx-regina/Makefile
@@ -20,6 +20,7 @@ LICENSE= LGPL21+
BROKEN_aarch64= Does not build: error: expected expression
BROKEN_armv6= Does not build: error: expected expression
+BROKEN_armv7= Does not build: error: expected expression
BROKEN_mips= Does not build: error: expected expression
BROKEN_mips64= Does not build: error: expected expression
BROKEN_powerpc64= Does not build: error: expected expression
diff --git a/lang/scm/Makefile b/lang/scm/Makefile
index 371edb24702c..6ae6f6b246f2 100644
--- a/lang/scm/Makefile
+++ b/lang/scm/Makefile
@@ -17,6 +17,7 @@ LICENSE= LGPL21
BROKEN_aarch64= does not link: undefined reference to sbrk
BROKEN_armv6= does not build: fails self-tests
+BROKEN_armv7= does not build: fails self-tests
BROKEN_mips= does not build
BROKEN_mips64= does not build
BROKEN_powerpc64= does not build: error: r4rstest.scm: segment violation 11
diff --git a/lang/see/Makefile b/lang/see/Makefile
index e84878afa87a..2aae639f0453 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -22,6 +22,7 @@ LICENSE_PERMS_DTOA.C= ${_LICENSE_PERMS_DEFAULT}
BROKEN_aarch64= fails to configure: floating point not detected: Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined
BROKEN_armv6= fails to configure: floating point not detected: Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined
+BROKEN_armv7= fails to configure: floating point not detected: Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined
OPTIONS_DEFINE= GC DEBUG DOCS
OPTIONS_DEFAULT= GC
diff --git a/lang/siod/Makefile b/lang/siod/Makefile
index 3c32836b9fdb..119bdbc5c952 100644
--- a/lang/siod/Makefile
+++ b/lang/siod/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small footprint implementation of the Scheme programming language
BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_armv7= fails to link: ld: siod: hidden symbol `__aeabi_uidivmod' in /usr/lib/libgcc.a(aeabi_uidivmod.o) is referenced by DSO
BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
USE_LDCONFIG= yes
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index eb614a0d5f07..adca953602d4 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -21,6 +21,7 @@ MAKE_ARGS+= JS_THREADSAFE=YES \
CFLAGS+= -I${LOCALBASE}/include/nspr
BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: FreeBSD12.0-CURRENT_DBG.OBJ/js: hidden symbol `__aeabi_uidivmod' in /usr/lib/libgcc.a(aeabi_uidivmod.o) is referenced by DSO
BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
BROKEN_sparc64= fails to link