aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-02-19 14:42:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-02-19 14:42:06 +0000
commitd5d2ae54de1e1e5472c02f33b2d5726982705bb4 (patch)
tree400fed0f0cf259b19582fa6c73daeb60358b54ac /lang
parentd4b6405f4053c8b4adb1f9516afe272c428ae29c (diff)
downloadports-d5d2ae54de1e1e5472c02f33b2d5726982705bb4.tar.gz
ports-d5d2ae54de1e1e5472c02f33b2d5726982705bb4.zip
lang/intel-compute-runtime: update to 21.07.19042
Notes
Notes: svn path=/head/; revision=566070
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile3
-rw-r--r--lang/intel-compute-runtime/distinfo8
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf18
3 files changed, 13 insertions, 16 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index e33ed8d5a6d6..144ecc7af26d 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,13 +1,12 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 21.06.18993
+DISTVERSION= 21.07.19042
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 2a423820aaa4.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
-PATCHFILES+= 7a91ef844a98.patch:-p1 # NEO_BUILD_DEBUG_SYMBOLS_PACKAGE
MAINTAINER= jbeich@FreeBSD.org
COMMENT= OpenCL implementation for Intel HD 5000 (Gen8) or newer
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index b1188bb672c2..1f24f151c725 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,7 +1,5 @@
-TIMESTAMP = 1612206884
-SHA256 (intel-compute-runtime-21.06.18993_GH0.tar.gz) = 13008a5bf6b5da993217bafe8c57fa4bf85ee590068ebb1e9b90dffc2cb8b124
-SIZE (intel-compute-runtime-21.06.18993_GH0.tar.gz) = 3742086
+TIMESTAMP = 1612812767
+SHA256 (intel-compute-runtime-21.07.19042_GH0.tar.gz) = f554de1d8eb3eca57682be2139c3bea99f04edb28d36608a9d67753b876373d7
+SIZE (intel-compute-runtime-21.07.19042_GH0.tar.gz) = 3753534
SHA256 (2a423820aaa4.patch) = dd034e856e75d70bc6b63204aa2c67530a3212d111b67a703e4cbeb84e61685b
SIZE (2a423820aaa4.patch) = 947
-SHA256 (7a91ef844a98.patch) = 3c628bb5e83fb79b63cfc66dd4f6cef6ae0cbe0b6ee0e2dd39f51294857e15fb
-SIZE (7a91ef844a98.patch) = 13251
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
index 236bfd7f5757..fafdfa4bc9e2 100644
--- a/lang/intel-compute-runtime/files/patch-no-perf
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -32,12 +32,12 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
}
LinuxEngineImp::LinuxEngineImp(OsSysman *pOsSysman, zes_engine_group_t type, uint32_t engineInstance) : engineGroup(type), engineInstance(engineInstance) {
---- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2020-09-11 07:53:58 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-02-08 19:32:47 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.cpp
-@@ -37,8 +37,10 @@ ze_result_t LinuxSysmanImp::init() {
- pPmt = new PlatformMonitoringTech();
- UNRECOVERABLE_IF(nullptr == pPmt);
- pPmt->init(myDeviceName, pFsAccess);
+@@ -42,8 +42,10 @@ ze_result_t LinuxSysmanImp::init() {
+ auto rootPciPathOfGpuDevice = getPciRootPortDirectoryPath(realRootPath);
+ PlatformMonitoringTech::create(pParentSysmanDeviceImp->deviceHandles, pFsAccess, rootPciPathOfGpuDevice, mapOfSubDeviceIdToPmtObject);
+
+#ifdef __linux__
pPmuInterface = PmuInterface::create(this);
UNRECOVERABLE_IF(nullptr == pPmuInterface);
@@ -45,12 +45,12 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
return ZE_RESULT_SUCCESS;
}
---- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2020-09-11 07:53:58 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2021-02-08 19:32:47 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.h
-@@ -13,7 +13,9 @@
- #include "level_zero/core/source/device/device.h"
+@@ -14,7 +14,9 @@
+ #include "level_zero/tools/source/sysman/linux/firmware_util/firmware_util.h"
#include "level_zero/tools/source/sysman/linux/fs_access.h"
- #include "level_zero/tools/source/sysman/linux/pmt.h"
+ #include "level_zero/tools/source/sysman/linux/pmt/pmt.h"
+#ifdef __linux__
#include "level_zero/tools/source/sysman/linux/pmu/pmu_imp.h"
+#endif