aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /lang
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'lang')
-rw-r--r--lang/f2c/Makefile1
-rw-r--r--lang/linux-j/Makefile1
-rw-r--r--lang/nim/Makefile2
-rw-r--r--lang/nml/Makefile8
-rw-r--r--lang/pike78/Makefile2
5 files changed, 4 insertions, 10 deletions
diff --git a/lang/f2c/Makefile b/lang/f2c/Makefile
index 3b103a39a994..328356a36184 100644
--- a/lang/f2c/Makefile
+++ b/lang/f2c/Makefile
@@ -75,7 +75,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/libf2c/libf2c.so.2 ${STAGEDIR}${PREFIX}/lib
${LN} -sf libf2c.so.2 ${STAGEDIR}${PREFIX}/lib/libf2c.so
-post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/lang/linux-j/Makefile b/lang/linux-j/Makefile
index 9c7e233f9884..e1b623395c3d 100644
--- a/lang/linux-j/Makefile
+++ b/lang/linux-j/Makefile
@@ -41,7 +41,6 @@ do-install:
${BRANDELF} -t Linux ${WRKSRC}/j${PORTVERSION:S/b//g}/jconsole
${INSTALL_PROGRAM} ${WRKSRC}/j${PORTVERSION:S/b//g}/jconsole ${STAGEDIR}${PREFIX}/lib/j/jconsole
-post-install:
${MV} ${STAGEDIR}${PREFIX}/man/man1/jconsole.1 ${STAGEDIR}${PREFIX}/man/man1/j-jconsole.1
.include <bsd.port.mk>
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 2cd852a3a359..1399279aaa54 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -35,8 +35,6 @@ do-build:
do-install:
cd ${WRKSRC} && ${SH} install.sh ${STAGEDIR}${PREFIX}
-
-post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nim
.include <bsd.port.post.mk>
diff --git a/lang/nml/Makefile b/lang/nml/Makefile
index dabac5cf9e2b..2eac2069544d 100644
--- a/lang/nml/Makefile
+++ b/lang/nml/Makefile
@@ -35,10 +35,6 @@ post-patch:
do-install:
${DO_MAKE_BUILD} -C ${WRKSRC} PREFIX="${STAGEDIR}${PREFIX}" ${INSTALL_TARGET}
@${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' ${STAGEDIR}${PREFIX}/lib/nml/ld.conf
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/emacs
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/vim
${INSTALL_DATA} ${WRKSRC}/contrib/emacs/* ${STAGEDIR}${DATADIR}/contrib/emacs
@@ -47,4 +43,8 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/$i
.endfor
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index a08f729b8149..45103fe9448f 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -102,8 +102,6 @@ post-patch:
do-install:
@cd ${WRKSRC} && ${MAKE_CMD} ${INSTALL_TARGET} buildroot=${STAGEDIR}
-
-post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/pike/${PORTVERSION}/bin/pike
${INSTALL_SCRIPT} ${WRKSRC}/bin/hilfe ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/pike.1 ${STAGEDIR}${MAN1PREFIX}/man/man1