aboutsummaryrefslogtreecommitdiff
path: root/mail/annoyance-filter/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-01-02 00:31:57 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-01-02 00:31:57 +0000
commit101d4c730124944ea9cc8b1955356fb45beb5708 (patch)
tree194ecec36cfad2fc0ac124b988dd0aec0e121311 /mail/annoyance-filter/Makefile
parenta8f032a31df944b7443029d237bf63a891f61a51 (diff)
downloadports-101d4c730124944ea9cc8b1955356fb45beb5708.tar.gz
ports-101d4c730124944ea9cc8b1955356fb45beb5708.zip
Add annoyance-filter 1.0b, Adaptive Bayesian Junk Mail Filter.
annoyance-filter uses Bayesian statistics to determine the probability an E-mail message is junk based on an analysis of its contents compared to collections of known junk and legitimate E-mail. Suggested by: phk
Notes
Notes: svn path=/head/; revision=97056
Diffstat (limited to 'mail/annoyance-filter/Makefile')
-rw-r--r--mail/annoyance-filter/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/annoyance-filter/Makefile b/mail/annoyance-filter/Makefile
new file mode 100644
index 000000000000..e008ee47ccc4
--- /dev/null
+++ b/mail/annoyance-filter/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: annoyance-filter
+# Date created: 2004-01-02
+# Whom: Sergei Kolobov <sergei@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= annoyance-filter
+PORTVERSION= 1.0b
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.fourmilab.ch/annoyance-filter/
+MASTER_SITE_SUBDIR= ${PORTNAME:S/-//}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Adaptive Bayesian Junk Mail Filter
+
+#USE_GPG= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CFLAGS+= ${CPPFLAGS}
+
+MAN1= annoyance-filter.1
+DOCS= COPYING INSTALL README *.pdf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}-run ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>