aboutsummaryrefslogtreecommitdiff
path: root/mail/cclient/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-11-26 12:05:13 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-11-26 12:05:13 +0000
commit5ccd0436d2153ad0ce45663451cd4efa3a15137a (patch)
tree6bb07bcfc97bc4c886c0e8ed4dcbeecb139e35a8 /mail/cclient/Makefile
parent58b9a1c196a3f5ec1830fd1c41b3955b6979fab2 (diff)
downloadports-5ccd0436d2153ad0ce45663451cd4efa3a15137a.tar.gz
ports-5ccd0436d2153ad0ce45663451cd4efa3a15137a.zip
anders assigned me a PR to update pine, so he must have meant me to update
this too. :) * Mostly a simple version update, although I tweaked a few things * Make some Makefile variables more... variable * SSLTYPE update to match new c-client makefile * Remove a spurious variable from the port Makefile * Tab'ify a couple places in patches that had to be regenerated anyway
Notes
Notes: svn path=/head/; revision=71113
Diffstat (limited to 'mail/cclient/Makefile')
-rw-r--r--mail/cclient/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index 074c2bb00a88..2e3eefe400ed 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= cclient
-PORTVERSION= 2001a
+PORTVERSION= 2002
PORTEPOCH= 1
CATEGORIES= mail devel
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/ \
http://atreides.freenix.no/~anders/ \
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/imap/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
-MASTER_SITE_SUBDIR= . old
-DISTNAME= imap-2001a
+DISTNAME= imap-${PORTVERSION}
EXTRACT_SUFX= .tar.Z
MAINTAINER= anders@FreeBSD.org
@@ -22,11 +21,11 @@ MAINTAINER= anders@FreeBSD.org
INSTALLS_SHLIB= yes
ALL_TARGET= bsf
.if defined(WITH_SSL)
-MAKE_ARGS+= SSLTYPE=unix
+MAKE_ARGS+= SSLTYPE=unix.nopwd
USE_OPENSSL= yes
.endif
-WRKSRC= ${WRKDIR}/imap-2001a
+WRKSRC= ${WRKDIR}/${DISTNAME}
USE_REINPLACE= yes
SHLIBBASE= c-client4
@@ -35,9 +34,6 @@ SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}
MAKE_ENV= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
PLIST_SUB= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
-PREFIX_FIX_FILES= Makefile src/osdep/unix/Makefile \
- src/osdep/unix/Makefile.gss
-
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "aout"
@@ -45,7 +41,7 @@ SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}.0
.endif
post-patch:
-.for file in ${PREFIX_FIX_FILES}
+.for file in Makefile src/osdep/unix/Makefile src/osdep/unix/Makefile.gss
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/${file}
.endfor