aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail/Makefile.claws
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-10-05 11:25:29 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-10-05 11:25:29 +0000
commit441d6f48003e70a00c705da71d7dbdc7ed1cd910 (patch)
tree7defe4a233e866af3a2af3cc379fabca90969635 /mail/claws-mail/Makefile.claws
parente7f149e7cd104240d8c4cf1ce66f624db6fa6349 (diff)
downloadports-441d6f48003e70a00c705da71d7dbdc7ed1cd910.tar.gz
ports-441d6f48003e70a00c705da71d7dbdc7ed1cd910.zip
- Fix comboboxes vcalendar bug by adding upstream patches [1]
- Add support for STAGEDIR - Properly set configure iconv args PR: ports/182439 [1] Reported by: Gerard Seibert <gerard@seibercom.net>
Notes
Notes: svn path=/head/; revision=329440
Diffstat (limited to 'mail/claws-mail/Makefile.claws')
-rw-r--r--mail/claws-mail/Makefile.claws8
1 files changed, 4 insertions, 4 deletions
diff --git a/mail/claws-mail/Makefile.claws b/mail/claws-mail/Makefile.claws
index ced483787491..45edf52d2c37 100644
--- a/mail/claws-mail/Makefile.claws
+++ b/mail/claws-mail/Makefile.claws
@@ -9,11 +9,10 @@ MAINTAINER= pawel@FreeBSD.org
LICENSE= GPLv3
USE_BZIP2= yes
-USES+= gmake pkgconfig
+USES+= gmake iconv pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
- --disable-dbus
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} --disable-dbus
CLAWS_PLUGINS= acpi_notifier \
address_keeper \
@@ -56,6 +55,7 @@ RUN_DEPENDS+= claws-mail>=${PORTVERSION}:${PORTSDIR}/mail/claws-mail
MASTERDIR= ${.CURDIR}/../../mail/claws-mail
DESCR= ${.CURDIR}/pkg-descr
+FILESDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
PKGMESSAGE= ${.CURDIR}/pkg-message
@@ -73,7 +73,7 @@ do-build:
do-install:
. for p in ${CLAWS_PLUGINS_BUILD}
- cd ${WRKSRC}/src/plugins/${p} && ${GMAKE} install
+ cd ${WRKSRC}/src/plugins/${p} && ${GMAKE} install DESTDIR="${STAGEDIR}"
. endfor
.endif