aboutsummaryrefslogtreecommitdiff
path: root/mail/cleanup-maildir/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 15:14:10 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 15:14:10 +0000
commit8ec37e4f4203b2cdd0b58fb5c6b251153f72abb4 (patch)
treefd8562e01e3daf1d493c95682179d9e964dd8ee6 /mail/cleanup-maildir/Makefile
parent58eb7b74b1785d33249cfb05f75369c7d9856e2f (diff)
downloadports-8ec37e4f4203b2cdd0b58fb5c6b251153f72abb4.tar.gz
ports-8ec37e4f4203b2cdd0b58fb5c6b251153f72abb4.zip
Resurrect and update mail/cleanup-maildir to 0.3.1. This application has now
been ported to Python 3.
Notes
Notes: svn path=/head/; revision=566073
Diffstat (limited to 'mail/cleanup-maildir/Makefile')
-rw-r--r--mail/cleanup-maildir/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/mail/cleanup-maildir/Makefile b/mail/cleanup-maildir/Makefile
new file mode 100644
index 000000000000..1a2ff42ca492
--- /dev/null
+++ b/mail/cleanup-maildir/Makefile
@@ -0,0 +1,32 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cleanup-maildir
+PORTVERSION= 0.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= mail python
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Script for cleaning up mails in Maildir folders based on arival date
+
+LICENSE= AS-IS
+LICENSE_NAME= AS-IS
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygraph>=0.2.1:graphics/py-pygraph@${PY_FLAVOR}
+
+USES= python:3.6+ shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= ehaupt
+SHEBANG_FILES= cleanup-maildir.py
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/cleanup-maildir
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cleanup-maildir.py \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>