aboutsummaryrefslogtreecommitdiff
path: root/mail/courier
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:30:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:30:02 +0000
commitf5b1e3399be52eb7d303f781d679dc0e05d2d4c2 (patch)
tree8fb554ebcaa8e067fa5c1fd9e7b34c813d3d64b7 /mail/courier
parentaf07884dbd2ffc98eba47b35347948c8b258e05d (diff)
downloadports-f5b1e3399be52eb7d303f781d679dc0e05d2d4c2.tar.gz
ports-f5b1e3399be52eb7d303f781d679dc0e05d2d4c2.zip
[PATCH] mail/courier: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54957 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88151
Diffstat (limited to 'mail/courier')
-rw-r--r--mail/courier/Makefile9
-rw-r--r--mail/courier/scripts/configure.courier9
2 files changed, 16 insertions, 2 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 7dfd310775f0..a6a792e3b611 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -109,6 +109,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
WITH_SENDFAX="${WITH_SENDFAX:L}" \
WITH_IPV6="${WITH_IPV6:L}" \
WITH_TRANSPORT="${WITH_TRANSPORT}" \
+ WITH_GHOSTSCRIPT_AFPL="${WITH_GHOSTSCRIPT_AFPL:no}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}"
@@ -122,6 +123,14 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
pre-everything::
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.${PORTNAME}
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${PERL} -pi -e 's:\@datadir\@:\@sysconfdir\@:g;' \
${WRKSRC}/*/mk*cert.* \
diff --git a/mail/courier/scripts/configure.courier b/mail/courier/scripts/configure.courier
index 524ca5e5d3ed..c719caf51e6c 100644
--- a/mail/courier/scripts/configure.courier
+++ b/mail/courier/scripts/configure.courier
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/courier/scripts/Attic/configure.courier,v 1.9 2003-08-28 12:57:51 edwin Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/courier/scripts/Attic/configure.courier,v 1.10 2003-08-31 01:30:02 edwin Exp $
[ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ] && exit
@@ -251,7 +251,12 @@ while [ "$1" ]; do
echo "BUILD_DEPENDS+= procmail:\${PORTSDIR}/mail/procmail"
;;
\"SendFax\")
- echo "BUILD_DEPENDS+= gs:\${PORTSDIR}/print/ghostscript-gnu"
+ if [ "x${WITH_GHOSTSCRIPT_AFPL}" = "xyes" ]
+ then
+ echo "BUILD_DEPENDS+= gs:\${PORTSDIR}/print/ghostscript-afpl"
+ else
+ echo "BUILD_DEPENDS+= gs:\${PORTSDIR}/print/ghostscript-gnu"
+ fi
echo "BUILD_DEPENDS+= pnmscale:\${PORTSDIR}/graphics/netpbm"
echo "BUILD_DEPENDS+= giftopnm:\${PORTSDIR}/graphics/netpbm"
echo "BUILD_DEPENDS+= jpegtopnm:\${PORTSDIR}/graphics/netpbm"