aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-04-01 17:10:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-04-01 17:10:31 +0000
commitb567ca5647da05b44fe7b0dd22068357430ad59a (patch)
tree67560826c2f3f309185123303765699891cb0643 /mail/dovecot
parent06d4b7781358e29a61e5420dbf748c9d2d8911ea (diff)
downloadports-b567ca5647da05b44fe7b0dd22068357430ad59a.tar.gz
ports-b567ca5647da05b44fe7b0dd22068357430ad59a.zip
Update dovecot to 2.3.1, and dovecot-pigeonhole to 0.5.1
This is a very large update, and it WILL require manually updating existing conf files, though the changes to do so are not extensive. Updating instructions are here: https://wiki2.dovecot.org/Upgrading/2.3 Additionally there are various cleanups to the dovecot rc(8) script, and support for a LUA scripting interface for dovecot. The decision was made not to import the 2.3.0 or 2.3.0.1 releases here, due to the number of existing bugs. ler and I have been dogfooding it for months now, and all of the bugs I've encountered are fixed in this 2.3.1 release. This update is the result of many, many hours of collborative work between ler and me, and the input of many people on the freebsd-ports list.
Notes
Notes: svn path=/head/; revision=466172
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile20
-rw-r--r--mail/dovecot/distinfo6
-rw-r--r--mail/dovecot/files/dovecot.in11
-rw-r--r--mail/dovecot/files/pkg-message.in15
-rw-r--r--mail/dovecot/pkg-plist71
5 files changed, 77 insertions, 46 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index ad1777809da8..362bd17cd190 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -4,17 +4,12 @@
######################################################################
# Anytime PORTVERSION changes please bump PORTREVISION of #
# mail/dovecot-pigeonhole. See ports/146029 for an explanation. #
-# #
-# Please be careful when updating this port as changes to this port #
-# can break mail/dovecot-pigeonhole. In order to ensure the least #
-# amount of breakage possible please consult the maintainer of that #
-# port before updating this one. #
######################################################################
PORTNAME= dovecot
-PORTVERSION= 2.2.35
+PORTVERSION= 2.3.1
CATEGORIES= mail ipv6
-MASTER_SITES= https://www.dovecot.org/releases/2.2/
+MASTER_SITES= https://www.dovecot.org/releases/2.3/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Secure, fast and powerful IMAP and POP3 server
@@ -24,7 +19,7 @@ LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
LICENSE_FILE_MIT= ${WRKSRC}/COPYING.MIT
-USES= cpe iconv libtool ssl
+USES= cpe iconv libtool pkgconfig ssl
USE_RC_SUBR= dovecot
GNU_CONFIGURE= yes
@@ -40,7 +35,7 @@ INSTALL_TARGET= install-strip
USERS= dovecot dovenull
GROUPS= ${USERS}
-OPTIONS_DEFINE= LIBWRAP LZ4 VPOPMAIL DOCS EXAMPLES
+OPTIONS_DEFINE= LIBWRAP LUA LZ4 VPOPMAIL DOCS EXAMPLES
OPTIONS_DEFAULT=GSSAPI_NONE LIBWRAP
OPTIONS_SUB= yes
@@ -71,6 +66,9 @@ GSSAPI_MIT_DESC= Use MIT GSSAPI from security/krb5
# General options
LIBWRAP_CONFIGURE_WITH= libwrap
+LUA_CONFIGURE_WITH= lua
+LUA_USES= lua
+
LZ4_CONFIGURE_WITH= lz4
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
@@ -145,6 +143,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|' \
${WRKSRC}/src/plugins/fts/decode2text.sh
+post-patch-LUA-on:
+ @${REINPLACE_CMD} -e '/^libdovecot_lua_la_DEPENDENCIES =/ s|LUA_LIBS|true|' \
+ ${WRKSRC}/src/lib-lua/Makefile.in
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${MV} ${STAGEDIR}${DOCSDIR}/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
diff --git a/mail/dovecot/distinfo b/mail/dovecot/distinfo
index c7a176bc5f11..24cf131f8b97 100644
--- a/mail/dovecot/distinfo
+++ b/mail/dovecot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521471634
-SHA256 (dovecot-2.2.35.tar.gz) = cce15db2fc5233386b63a3cf21c465c09e6e55014ed66c4f184b7d221a47180c
-SIZE (dovecot-2.2.35.tar.gz) = 6185237
+TIMESTAMP = 1522193729
+SHA256 (dovecot-2.3.1.tar.gz) = 0883821b97fd02a084a84b9469a681f7e6edc56541d854b5419d98891c51fb93
+SIZE (dovecot-2.3.1.tar.gz) = 6703089
diff --git a/mail/dovecot/files/dovecot.in b/mail/dovecot/files/dovecot.in
index 7a7ce56644e8..540a5a827676 100644
--- a/mail/dovecot/files/dovecot.in
+++ b/mail/dovecot/files/dovecot.in
@@ -38,16 +38,13 @@ restart_cmd="restart_cmd"
extra_commands="reload"
start_precmd()
-{ # Ensure runtime directories exist with correct permissions
- local login_user login_gid
- login_user=$(${command} ${command_args} -a | /usr/bin/awk -F '= ' '/^default_login_user =/ { print $2 }')
- login_gid=$(/usr/sbin/pw usershow -n "${login_user}" 2>/dev/null | /usr/bin/cut -d: -f4)
+{ # Ensure runtime directory exists with correct permissions
/usr/bin/install -o root -g wheel -m 0755 -d ${base_dir}
}
stop_postcmd()
-{ # Cleanup runtime directories
- rm -rf ${base_dir} 2>/dev/null
+{ # Cleanup runtime directory. The dovecot.conf link has to stay.
+ /usr/bin/find ${base_dir} ! -type l -delete
}
restart_cmd()
@@ -68,7 +65,7 @@ for config in ${dovecot_config}; do
echo "==Error=="
echo "Config file ${config} does not exist. If this is"
echo "a new installation, please create the config files as outlined in"
- echo " # pkg info -D dovecot2"
+ echo " # pkg info -D dovecot"
fi
run_rc_command "$1"
done
diff --git a/mail/dovecot/files/pkg-message.in b/mail/dovecot/files/pkg-message.in
index 905b3401815a..b06f0866a918 100644
--- a/mail/dovecot/files/pkg-message.in
+++ b/mail/dovecot/files/pkg-message.in
@@ -17,9 +17,9 @@
---------------------------------------------------------------------
-To avoid a risk of mailbox corruption, do not set the
-security.bsd.see_other_uids or .see_other_gids sysctls to 0
-if Dovecot is storing mail for multiple concurrent users (PR 218392).
+ To avoid a risk of mailbox corruption, do not set the
+ security.bsd.see_other_uids or .see_other_gids sysctls to 0
+ if Dovecot is storing mail for multiple concurrent users (PR 218392).
---------------------------------------------------------------------
@@ -28,3 +28,12 @@ if Dovecot is storing mail for multiple concurrent users (PR 218392).
one of graphics/xpdf or graphics/poppler-utils.
---------------------------------------------------------------------
+
+ There are some potentially breaking changes in Dovecot 2.3. If you
+ are upgrading from Dovecot 2.2:
+
+ * Read https://wiki2.dovecot.org/Upgrading/2.3
+ * Merge the configuration file changes from
+ %%ETCDIR%%/examples-config/
+
+---------------------------------------------------------------------
diff --git a/mail/dovecot/pkg-plist b/mail/dovecot/pkg-plist
index b9d0e480f6e4..3d02328729ea 100644
--- a/mail/dovecot/pkg-plist
+++ b/mail/dovecot/pkg-plist
@@ -12,6 +12,7 @@ bin/dsync
%%ETCDIR%%/example-config/conf.d/20-imap.conf
%%ETCDIR%%/example-config/conf.d/20-lmtp.conf
%%ETCDIR%%/example-config/conf.d/20-pop3.conf
+%%ETCDIR%%/example-config/conf.d/20-submission.conf
%%ETCDIR%%/example-config/conf.d/90-acl.conf
%%ETCDIR%%/example-config/conf.d/90-plugin.conf
%%ETCDIR%%/example-config/conf.d/90-quota.conf
@@ -31,7 +32,6 @@ bin/dsync
%%ETCDIR%%/example-config/dovecot-sql.conf.ext
%%ETCDIR%%/example-config/dovecot.conf
%%ETCDIR%%/README
-include/dovecot/abspath.h
include/dovecot/access-lookup.h
include/dovecot/acl-api-private.h
include/dovecot/acl-api.h
@@ -73,6 +73,7 @@ include/dovecot/backtrace-string.h
include/dovecot/base32.h
include/dovecot/base64.h
include/dovecot/bits.h
+include/dovecot/bloomfilter.h
include/dovecot/bsearch-insert-pos.h
include/dovecot/buffer.h
include/dovecot/byteorder.h
@@ -108,8 +109,6 @@ include/dovecot/dbox-save.h
include/dovecot/dbox-storage.h
include/dovecot/dict-client.h
include/dovecot/dict-private.h
-include/dovecot/dict-sql-settings.h
-include/dovecot/dict-sql.h
include/dovecot/dict-transaction-memory.h
include/dovecot/dict.h
include/dovecot/dns-lookup.h
@@ -130,14 +129,14 @@ include/dovecot/dsasl-client-private.h
include/dovecot/dsasl-client.h
include/dovecot/dsync-brain.h
include/dovecot/dsync-ibc.h
-include/dovecot/duplicate.h
include/dovecot/eacces-error.h
include/dovecot/env-util.h
+include/dovecot/event-filter.h
+include/dovecot/event-log.h
include/dovecot/execv-const.h
include/dovecot/fail-mail-storage.h
include/dovecot/failures.h
-include/dovecot/fd-close-on-exec.h
-include/dovecot/fd-set-nonblock.h
+include/dovecot/fd-util.h
include/dovecot/fdatasync-path.h
include/dovecot/fdpass.h
include/dovecot/file-cache.h
@@ -186,6 +185,7 @@ include/dovecot/hostpid.h
include/dovecot/http-auth.h
include/dovecot/http-client-private.h
include/dovecot/http-client.h
+include/dovecot/http-common.h
include/dovecot/http-date.h
include/dovecot/http-header-parser.h
include/dovecot/http-header.h
@@ -272,6 +272,8 @@ include/dovecot/ioloop.h
include/dovecot/iostream-lz4.h
include/dovecot/iostream-openssl.h
include/dovecot/iostream-private.h
+include/dovecot/iostream-proxy.h
+include/dovecot/iostream-pump.h
include/dovecot/iostream-rawlog-private.h
include/dovecot/iostream-rawlog.h
include/dovecot/iostream-ssl-private.h
@@ -318,10 +320,11 @@ include/dovecot/istream.h
include/dovecot/json-parser.h
include/dovecot/json-tree.h
include/dovecot/lda-settings.h
+include/dovecot/lib-event-private.h
+include/dovecot/lib-event.h
include/dovecot/lib-signals.h
include/dovecot/lib.h
include/dovecot/llist.h
-include/dovecot/lmtp-client.h
include/dovecot/log-throttle.h
include/dovecot/login-common.h
include/dovecot/login-proxy-state.h
@@ -333,6 +336,7 @@ include/dovecot/mail-cache-private.h
include/dovecot/mail-cache.h
include/dovecot/mail-copy.h
include/dovecot/mail-deliver.h
+include/dovecot/mail-duplicate.h
include/dovecot/mail-error.h
include/dovecot/mail-html2text.h
include/dovecot/mail-index-alloc-cache.h
@@ -427,6 +431,7 @@ include/dovecot/mdbox-sync.h
include/dovecot/mech-otp-skey-common.h
include/dovecot/mech-plain-common.h
include/dovecot/mech.h
+include/dovecot/memarea.h
include/dovecot/mempool.h
include/dovecot/message-address.h
include/dovecot/message-binary-part.h
@@ -448,8 +453,8 @@ include/dovecot/mkdir-parents.h
include/dovecot/mmap-util.h
include/dovecot/module-context.h
include/dovecot/module-dir.h
-include/dovecot/mountpoint-list.h
include/dovecot/mountpoint.h
+include/dovecot/murmurhash3.h
include/dovecot/mycrypt.h
include/dovecot/net.h
include/dovecot/nfs-workarounds.h
@@ -460,7 +465,6 @@ include/dovecot/oauth2.h
include/dovecot/ostream-cmp.h
include/dovecot/ostream-dot.h
include/dovecot/ostream-encrypt.h
-include/dovecot/ostream-escaped.h
include/dovecot/ostream-failure-at.h
include/dovecot/ostream-file-private.h
include/dovecot/ostream-hash.h
@@ -477,6 +481,7 @@ include/dovecot/passdb-cache.h
include/dovecot/passdb-template.h
include/dovecot/passdb.h
include/dovecot/password-scheme.h
+include/dovecot/path-util.h
include/dovecot/pkcs5.h
include/dovecot/pop3-capability.h
include/dovecot/pop3-client.h
@@ -519,7 +524,6 @@ include/dovecot/quota-plugin.h
include/dovecot/quota-private.h
include/dovecot/quota.h
include/dovecot/quoted-printable.h
-include/dovecot/rand.h
include/dovecot/randgen.h
include/dovecot/raw-storage.h
include/dovecot/raw-sync.h
@@ -545,13 +549,31 @@ include/dovecot/sha1.h
include/dovecot/sha2.h
include/dovecot/sha3.h
include/dovecot/shared-storage.h
+include/dovecot/smtp-address.h
+include/dovecot/smtp-client-command.h
+include/dovecot/smtp-client-connection.h
+include/dovecot/smtp-client-private.h
+include/dovecot/smtp-client-transaction.h
include/dovecot/smtp-client.h
+include/dovecot/smtp-command-parser.h
+include/dovecot/smtp-command.h
+include/dovecot/smtp-common.h
+include/dovecot/smtp-params.h
+include/dovecot/smtp-parser.h
+include/dovecot/smtp-reply-parser.h
+include/dovecot/smtp-reply.h
+include/dovecot/smtp-server-private.h
+include/dovecot/smtp-server.h
+include/dovecot/smtp-submit-settings.h
+include/dovecot/smtp-submit.h
+include/dovecot/smtp-syntax.h
include/dovecot/sort.h
include/dovecot/sql-api-private.h
include/dovecot/sql-api.h
include/dovecot/sql-db-cache.h
-include/dovecot/ssl-proxy.h
+include/dovecot/stats-client.h
include/dovecot/stats-connection.h
+include/dovecot/stats-dist.h
include/dovecot/stats-parser.h
include/dovecot/stats.h
include/dovecot/str-find.h
@@ -565,7 +587,6 @@ include/dovecot/subscription-file.h
include/dovecot/syslog-util.h
include/dovecot/test-common.h
include/dovecot/time-util.h
-include/dovecot/timing.h
include/dovecot/unichar.h
include/dovecot/unix-socket-create.h
include/dovecot/unlink-directory.h
@@ -654,10 +675,10 @@ lib/dovecot/lib21_fts_squat_plugin.a
lib/dovecot/lib21_fts_squat_plugin.so
lib/dovecot/lib30_imap_zlib_plugin.a
lib/dovecot/lib30_imap_zlib_plugin.so
-lib/dovecot/lib90_stats_plugin.a
-lib/dovecot/lib90_stats_plugin.so
-lib/dovecot/lib95_imap_stats_plugin.a
-lib/dovecot/lib95_imap_stats_plugin.so
+lib/dovecot/lib90_old_stats_plugin.a
+lib/dovecot/lib90_old_stats_plugin.so
+lib/dovecot/lib95_imap_old_stats_plugin.a
+lib/dovecot/lib95_imap_old_stats_plugin.so
lib/dovecot/lib99_welcome_plugin.a
lib/dovecot/lib99_welcome_plugin.so
lib/dovecot/libdcrypt_openssl.a
@@ -702,10 +723,10 @@ lib/dovecot/libfs_mail_crypt.a
lib/dovecot/libfs_mail_crypt.so
lib/dovecot/libssl_iostream_openssl.a
lib/dovecot/libssl_iostream_openssl.so
-lib/dovecot/stats/libstats_auth.a
-lib/dovecot/stats/libstats_auth.so
-lib/dovecot/stats/libstats_mail.a
-lib/dovecot/stats/libstats_mail.so
+lib/dovecot/old-stats/libold_stats_mail.a
+lib/dovecot/old-stats/libold_stats_mail.so
+lib/dovecot/old-stats/libstats_auth.a
+lib/dovecot/old-stats/libstats_auth.so
libexec/dovecot/aggregator
libexec/dovecot/anvil
libexec/dovecot/auth
@@ -731,6 +752,7 @@ libexec/dovecot/ipc
libexec/dovecot/lmtp
libexec/dovecot/log
libexec/dovecot/maildirlock
+libexec/dovecot/old-stats
libexec/dovecot/pop3
libexec/dovecot/pop3-login
libexec/dovecot/quota-status
@@ -738,8 +760,9 @@ libexec/dovecot/rawlog
libexec/dovecot/replicator
libexec/dovecot/script
libexec/dovecot/script-login
-libexec/dovecot/ssl-params
libexec/dovecot/stats
+libexec/dovecot/submission
+libexec/dovecot/submission-login
libexec/dovecot/xml2text
man/man1/deliver.1.gz
man/man1/doveadm-acl.1.gz
@@ -767,7 +790,6 @@ man/man1/doveadm-kick.1.gz
man/man1/doveadm-log.1.gz
man/man1/doveadm-mailbox-cryptokey.1.gz
man/man1/doveadm-mailbox.1.gz
-man/man1/doveadm-mount.1.gz
man/man1/doveadm-move.1.gz
man/man1/doveadm-penalty.1.gz
man/man1/doveadm-proxy.1.gz
@@ -776,6 +798,7 @@ man/man1/doveadm-pw.1.gz
man/man1/doveadm-quota.1.gz
man/man1/doveadm-reload.1.gz
man/man1/doveadm-replicator.1.gz
+man/man1/doveadm-save.1.gz
man/man1/doveadm-search.1.gz
man/man1/doveadm-stats.1.gz
man/man1/doveadm-stop.1.gz
@@ -804,13 +827,13 @@ share/aclocal/dovecot.m4
%%DATADIR%%/stopwords/stopwords_ru.txt
%%DATADIR%%/stopwords/stopwords_sv.txt
%%LDAP%%include/dovecot/ldap-client.h
-%%LDAP%%lib/dovecot/dict/libdict_ldap.a
-%%LDAP%%lib/dovecot/dict/libdict_ldap.so
%%LDAP%%lib/dovecot/libdovecot-ldap.a
%%LDAP%%lib/dovecot/libdovecot-ldap.so
%%LDAP%%lib/dovecot/libdovecot-ldap.so.0
%%LDAP%%lib/dovecot/libdovecot-ldap.so.0.0.0
%%LIBWRAP%%libexec/dovecot/tcpwrap
+%%LUA%%include/dovecot/dlua-script-private.h
+%%LUA%%include/dovecot/dlua-script.h
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.a
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.so
%%LUCENE%%lib/dovecot/lib21_fts_lucene_plugin.a