aboutsummaryrefslogtreecommitdiff
path: root/mail/enigmail-thunderbird
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-04-24 05:45:20 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-04-24 05:45:20 +0000
commit06ef3e779be3559d49e53f84b447e8f018d82e45 (patch)
tree7f633e033bbae2d58267092371f3881fdee9946f /mail/enigmail-thunderbird
parentfdff5debfe531c55b72fb202ba96a331d7c297fc (diff)
downloadports-06ef3e779be3559d49e53f84b447e8f018d82e45.tar.gz
ports-06ef3e779be3559d49e53f84b447e8f018d82e45.zip
Fix build on tinderbox, moving the configure stage inside enigmail.
Tested by: kris
Notes
Notes: svn path=/head/; revision=160281
Diffstat (limited to 'mail/enigmail-thunderbird')
-rw-r--r--mail/enigmail-thunderbird/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/mail/enigmail-thunderbird/Makefile b/mail/enigmail-thunderbird/Makefile
index 71c7fc7083ff..c20cfec2cbfc 100644
--- a/mail/enigmail-thunderbird/Makefile
+++ b/mail/enigmail-thunderbird/Makefile
@@ -14,12 +14,13 @@ PKGNAMEPREFIX?= thunderbird-
MAINTAINER= ale@FreeBSD.org
COMMENT?= A GnuPG extension for the Thunderbird mail client
-EXTRACT_DEPENDS=${GECKO_WRKSRC}/Makefile:${PORTSDIR}/${GECKO_PORTDIR}:configure \
- zip:${PORTSDIR}/archivers/zip \
- gmake:${PORTSDIR}/devel/gmake \
- intltool-extract:${PORTSDIR}/textproc/intltool
+EXTRACT_DEPENDS=${GECKO_WRKSRC}/configure:${PORTSDIR}/${GECKO_PORTDIR}:patch
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= nspr4:${PORTSDIR}/devel/nspr
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ nspr4:${PORTSDIR}/devel/nspr \
+ nss3:${PORTSDIR}/security/nss \
+ Xft.2:${PORTSDIR}/x11-fonts/libXft
RUN_DEPENDS= ${GECKO}:${PORTSDIR}/${GECKO_PORTDIR} \
gpg:${PORTSDIR}/security/gnupg
@@ -34,8 +35,11 @@ WRKSRC= ${WRKDIR}/mozilla
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_GNOME= gtk20 libidl
+USE_GCC= 3.4+
+USE_GNOME= gtk20 libidl desktopfileutils
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+CFLAGS+= -I${X11BASE}/include
XPI_FILE= ${DISTNAME}-${GECKO}-freebsd-${ARCH}.xpi
PLIST_FILES= %%DATADIR%%/${XPI_FILE}
@@ -49,10 +53,6 @@ do-extract:
cd ${WRKSRC}/mailnews/extensions && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS}; \
done
-pre-patch:
- @${REINPLACE_CMD} -e "s|${GECKO_PORTDIR}|mail/enigmail-${GECKO}|g" \
- `${FIND} ${WRKSRC} -name autoconf.mk`
-
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} export)
@(cd ${WRKSRC}/modules/libreg; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})